MozillaZine

Thunderbird Message Filters disappear

Discussion of bugs in Mozilla Thunderbird
_XeNoMoRpH_
 
Posts: 1
Joined: January 7th, 2005, 2:15 am

Post Posted January 7th, 2005, 2:53 am

I create quite a lot of filters, making mails from certain contacts being moved into
specific folders on my IMAP Account.

After I create filters from messages, to for instance move a mail to a folder, after a restart they could be gone.
What is a bit annoying is that it's so random. After a restart all of the filters may be present, and after another one
some may be gone!

From what I recall, I have made a filter manually (that is from the 'Message Filters' window, not 'Create filter from Message')
and it seems to be present all the time.

Is the 'Create filter from Message' not functioning properly?

(I've also checked my Thunderbird profile security, and I have admin rights)

XP Pro SP2
TB 1.0
IMAP Account

Yoeri
 
Posts: 78
Joined: May 22nd, 2003, 1:57 am
Location: Belgium

Post Posted January 7th, 2005, 5:25 am

Also problems with filters here ...

The filters don't dissapear, but they just don't get applied ... unless I do it manually

brianread
 
Posts: 1
Joined: January 10th, 2005, 2:12 am
Location: West Lancashire, UK

Post Posted January 10th, 2005, 2:20 am

and here as well - i have about 60 mail rules (64?) and any more seem to get created, and can be applied to folder, but after a restart the new rules are gone. This is driving me nuts!!

peggybaker
 
Posts: 1
Joined: January 11th, 2005, 9:26 pm

Post Posted January 11th, 2005, 9:28 pm

Yes, I've had the same experience--filters are or (seemingly randomly) are not saved. And sometimes the filters that haven't gone away don't get applied. Very strange

hjmf
 
Posts: 3
Joined: May 2nd, 2004, 3:16 am

Post Posted January 14th, 2005, 7:43 am

Yep, Same problem random disappearing (vanishing) filters. Can not find any logic why the rules disappear.

hjmf
 
Posts: 3
Joined: May 2nd, 2004, 3:16 am

Post Posted January 14th, 2005, 7:48 am


hjmf
 
Posts: 3
Joined: May 2nd, 2004, 3:16 am

Post Posted January 14th, 2005, 7:52 am

Since the above link does not give the correct link I give a new link and add the text of this link here.

http://forums.mozillazine.org/viewtopic ... ear+filter

Filters are saved in a file called msgFilterRules.dat that exists in the folder corresponding to your account under your profile folder.

Take it step by step and keep looking at the file for changes and whether they are registered there and when they disappear as you trace your steps of creating the filter, closing TB and re-opening it....

My hunch is that you have some permissions issue on the folder and/or that particular file beacuse of which TB is not able to write to the file....

Amberwolf

User avatar
 
Posts: 6
Joined: January 31st, 2005, 10:41 pm

Post Posted January 31st, 2005, 11:01 pm

I have also noticed this problem of vanishing filters.

I am using all filters in my Local Folders section of the filters dialog, none are in individual accounts. I do it this way because I *don't* want them to run automatically, only when I choose.

What happens is that I will create a new Filter or two, usually (but not always) by rightclicking the email address in a message window and choosing Create Filter From Message. I almost always define the filter for "Match Any", with both "Sender Is (AddressOfPerson)" and "To Is (AddressOfPerson)", with "Move To Folder" checked and defined as a folder for mail just for/from that person or group. Thus I can sort my conversations with people by running this filter on my Sent folder and my Local Folders Inbox.

If I then run the filter at that time, it works fine, but there is a not-yet-determined chance that the next time I start Thunderbird 1.0, it will not only not run that filter when I "Run Filters on Folder", but that the filter will not even *exist*!

I have examined the msgFilterRuls.dat file in Local Folders and verified that it does not contain the rules.

Jeroen_NL appears to be completely right about the pattern to the bug, as I do recall that sometimes I have opened the filter list afterward, more often I have not, and thus this would explain why some are saved and some are lost.

I was going to start copying that file before exiting Thunderbird 1.0 each time, so I can copy/paste them back in when I find them missing, but the filters in question are *not even written to the file* unless you first open the Filter list dialog! That is why they are lost, apparently. What I find strange is that they do exist in memory until the program is closed, since they do work until you close and reopen Thunderbird 1.0.


I have replied to the other thread I found at:
http://forums.mozillazine.org/viewtopic.php?t=189226
with the identical reply, because it is the same problem as far as I can see.

theillien

User avatar
 
Posts: 62
Joined: January 21st, 2004, 11:27 am

Post Posted February 28th, 2008, 11:45 am

Has there been a solution found for this? The link provided by hjmf doesn't actually provide one but instead gives someone's opinion on why it is happening. I've checked my permissions on the msgFilterRules.dat file under each of my accounts and the have rw------- permissions set. This isn't the issue. It is something else entirely. Also, if I'm looking at one set of rules and try to switch to another set, nothing happens. I can't switch between rulesets.

I'm using TB v2.0.0.9 on Linux.

Amberwolf

User avatar
 
Posts: 6
Joined: January 31st, 2005, 10:41 pm

Post Posted February 28th, 2008, 1:43 pm

Unfortunately there appears to be no solution until the bug causing the filters to not be written to the rules file unless you first open the Filter list dialog is fixed.

It is not a permissions issue, as this happens on any system I use TB on, even with manual permissions settings for files and folders instead of default WinXP settings.

I have tried it with the default installation where data is placed inside the Documents and Settings subfolders, and the current way I use it, which is with a "Mail" folder in the root of my primary harddisk containing all TB mail/rules/folder data, and it makes no difference.

It doesn't matter if I have any addons/extensions installed or not.

I am still using 1.x series (1.5.something I think now) due to addon incompatibilities with 2.x, so I don't know if 2.x still has the identical issue, but I suspect your report verifies the bug still exists.

I do not know why you can't switch between rulesets, that's probably a different bug.

Basically, the root cause of the bug here is simply that it never writes any rule information to the rules file until you exit the rule dialog *and re-open* (and probably re-close) the rule dialog. Thus any changes made are always lost if this is not done.

theillien

User avatar
 
Posts: 62
Joined: January 21st, 2004, 11:27 am

Post Posted March 3rd, 2008, 10:19 am

The only way I've found around this problem is to copy the msgFilterRules.dat file to another computer on which the bug has not appeared, edit the filters there and copy them back. I was able to get my filters in place by copying the file from my Linux box to my Windows box, edited the filters there and copied them back. I now have functioning filters that are doing what I've been trying to get them to do for the past forever and a half.

Amberwolf

User avatar
 
Posts: 6
Joined: January 31st, 2005, 10:41 pm

Post Posted March 3rd, 2008, 12:38 pm

Then that is a slightly different problem from the one I see, because all I have to do is open the filters dialog a second time, after having edited or added a filter and closed the dialog, then reclose the dialog, and the filters are saved.

The key to working around the bug is to do that second reopen and close of the dialog before you exit TB, and then it will save your work, otherwise it is lost.

theillien

User avatar
 
Posts: 62
Joined: January 21st, 2004, 11:27 am

Post Posted March 3rd, 2008, 12:39 pm

That doesn't work for me. I've tried it.

SoaRex

User avatar
 
Posts: 369
Joined: April 20th, 2003, 10:01 pm
Location: Japan, the earth, the solar system

Post Posted March 8th, 2008, 7:13 pm

If many tmprules-XXXX.dat are kept as a result of Bug 375292, Bug 362539 can occur.
Bug 375292 Stray tmprules.dat files created when getting new messages (fixed by Tb 2.0.0.12)
Bug 362539 Filters rules disappears when restarting due to >10000 /tmp/tmprules-*.dat files (fixed by trunk only)

Does many tmprules-XXXX.dat exist in temp directory?
I yes, "delete all of them" will be a workaround?

MikeDixon
 
Posts: 1
Joined: March 12th, 2008, 10:51 am

Post Posted March 12th, 2008, 11:13 am

I've been running into this recently too - I'm not sure when it started, but it's currently happening in 2.0.12 on Windows XP.

The error console reports:

Error: uncaught exception: [Exception... "Component returned failure code: 0x8052ffff [nsIMsgFilterList.saveToDefaultFile]" nsresult: "0x8052ffff (<unknown>)" location: "JS frame :: chrome://messenger/content/FilterListDialog.js :: onFilterClose :: line 396" data: no]

This gets generated every time I close the filters window.

EDIT: Ok, this turned out to be dumb on my part. My account's local folder was set to a network drive that isn't available anymore, and so of course it wasn't going to be able to save my settings.

That said, this shouldn't be an unhandled exception - there should have been a dialog explaining that files couldn't be saved because the folder doesn't exist and couldn't be created. Check your account settings, etc etc.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest