MozillaZine

Font Rendering Changes / smudgy bold fonts in TB 52

Discussion of bugs in Mozilla Thunderbird
winedog
 
Posts: 46
Joined: January 17th, 2005, 2:27 pm

Post Posted April 18th, 2017, 2:20 pm

Were there any changes in the font rendering for Thunderbird 52. It seems that there is some shading happening on adjacent pixels and is most obvious when bold fonts are used. It feels like the fonts look a little smudged.

It is most obvious on bolded lower-case 'a' where the center of the 'a' gets filled in.

Image

Maybe it's always been this way and I'm just hallucinating, but as soon as the TB 52 update happened while I was in middle using TB this morning and it restarted the fonts just looked a little more jagged / rough / smudged to me?

impar
 
Posts: 98
Joined: August 8th, 2007, 1:45 pm

Post Posted April 20th, 2017, 6:55 am

Have the same problem since v52.0.1.
Googled for a solution and all I could find was support.mozilla.org links that direct to "Page not found" error.

Any solution?
Classic Theme Restorer, the solution to the Australis problem!
https://addons.mozilla.org/pt-pt/firefo ... erestorer/

Lnwdz
 
Posts: 146
Joined: June 12th, 2012, 7:59 am

Post Posted May 7th, 2017, 11:30 am

At least for my WinXP, it's the same skia problem that affects Firefox 52+ on some systems.

To change font rendering back to cairo:
Tools > Options > Advanced > General > Config Editor
Change gfx.content.azure.backends from
direct2d1.1,skia,cairo to
direct2d1.1,cairo,skia

It probably isn't necessary to change gfx.canvas.azure.backends the same way.

impar
 
Posts: 98
Joined: August 8th, 2007, 1:45 pm

Post Posted May 8th, 2017, 6:43 am

Thanks!

That did it. :)
Classic Theme Restorer, the solution to the Australis problem!
https://addons.mozilla.org/pt-pt/firefo ... erestorer/

bugblatter
 
Posts: 57
Joined: June 21st, 2005, 12:31 am

Post Posted May 19th, 2017, 8:23 pm

Same for me. TB just updated to 52.1.1 yesterday for me and the fonts became all blurry and faint. Since exactly this happened to me on ff 52 a few months ago (must have transferred over), I knew what to do (exactly what Lnwfdz said above).

From my surface reading of it, Azure (ff/tb 2D graphics engine) defaults to a software backend when hw accel (direct2d) is not available (like in Windows XP it seems) or is disabled. This used to default to cairo (old) but they decided to switch to skia (newer) which is supposed to be better with the caveat that fonts might look different. So we're switching the pref back to the way it was before, with cairo in front of skia. This impacts Windows XP users in particular since newer Windows users (Vista+) would still be using hw accel (unless they turn it off).

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest