MozillaZine

Spell Check doesn’t respect typographic apostrophes

Discussion of bugs in Mozilla Thunderbird
manngo
 
Posts: 15
Joined: September 30th, 2007, 12:53 am

Post Posted June 13th, 2020, 10:52 pm

When I send an email, I have Thunderbird first checking the spelling. However, it always stops on words like doesn’t or haven’t, where the spell check stops at the apostrophe rather than taking in the whole word.

You’ll note that I am using a typographic apostrophe (’ or “smart quote”) not the prime symbol (' or “intellectually challenged quote”). I assume that the spell check thinks it’s being used as a quotation character, so it marks the end of the word. I know it’s tough, but it would be facing the same problem with straight quotes, and other software seems to get the interpretation right.

There’s no point in adding what it finds to my dictionary, because doesn doesn’t properly belong there, and haven has a different meaning.

What do I need to do to get the spell check to work with typographic apostrophes? I refuse to sacrifice my principles and resort to straight apostrophes.

I might add that this only occurs in the spell check before sending. The spellcheck-as-you-type feature correctly accepts the typographical quote, while it still picks up genuine spelling errors. I guess the solution for now is to turn off the check-before-sending option, but that’s not fixing the error.

I don’t know whether this is relevant, but I am referring to TB 68.9.0 (64-bit) on a Macintosh; the problem has always been there, as far as I recall.

Comment: I don’t know whether this is a Mac-only issue. I would appreciate some feedback here. Windows users can enter a typographic apostrophe (’) by entering alt-0146 - that is, hold alt while entering 0146 on the numeric keypad, then release alt.
Last edited by DanRaisch on June 14th, 2020, 4:28 am, edited 1 time in total.
Reason: (Mac) added to Subject line.

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest