MozillaZine

invisible messages

Discussion of bugs in Mozilla Thunderbird
thegriper
 
Posts: 1
Joined: May 21st, 2007, 10:56 am

Post Posted May 21st, 2007, 11:03 am

In thunderbird 2.0.0.0 on windows 2000 I'm having a problem with messages received
(I know this because of the
new mail notifier) but they never show up on the screen in the list.
They can be found and read by a search and be seen in the inbox file if I look at
it with a text editor but
they never show up on the screen. I tried rebuilding the index and that didn't
do it. I don't know what causes only some messages to trigger this. (I'm using pop 3 to
download). I've already detected two of them since I upgraded friday.

I'd like to revert back to 1.5 What is a good way to do that?
thanks so much for any advice.

saintive
 
Posts: 4
Joined: April 9th, 2005, 1:25 am
Location: France

Post Posted May 21st, 2007, 11:31 am

ARe you sure that in the menu View, sub-menu "Discussion" you have selected "all" and not the option "unread".

e633
 
Posts: 6
Joined: May 25th, 2007, 11:03 am

Post Posted May 25th, 2007, 11:07 am

Same thing here... but if i re-check for new mail all of the ghost messages materialize as they should.

DanRaisch
Moderator

User avatar
 
Posts: 106842
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted May 25th, 2007, 2:40 pm

thegriper wrote:In thunderbird 2.0.0.0 on windows 2000 I'm having a problem with messages received
(I know this because of the
new mail notifier) but they never show up on the screen in the list.
They can be found and read by a search and be seen in the inbox file if I look at
it with a text editor but
they never show up on the screen. I tried rebuilding the index and that didn't
do it. I don't know what causes only some messages to trigger this. (I'm using pop 3 to
download). I've already detected two of them since I upgraded friday.
.


How recently have you compacted your message folders? This action is a necessary part of using Thunderbird and other email programs. Messages "deleted" from the Inbox or other folders, or moved from one folder to another, are not really removed from the source file until the folder is compacted. See this URL for additional information on the subject - http://kb.mozillazine.org/Compacting_folders

To compact a folder, click on the folder title in the (left hand) folder pane and then right click. In the resulting context menu select "Compact".

Also see this URL - http://kb.mozillazine.org/Keep_it_worki ... derbird%29
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

e633
 
Posts: 6
Joined: May 25th, 2007, 11:03 am

Post Posted May 25th, 2007, 3:33 pm

I compacted every time the program asked, and i've just done it again. We'll see if the problem re-occurs... stay tuned, i'll give an update as soon as i can!

DanRaisch
Moderator

User avatar
 
Posts: 106842
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted May 25th, 2007, 7:09 pm

If you have been compacting, here's a next step to try in case compacting this time does not change the situation --

Close Thunderbird and navigate to your Profile Folder (see the Knowledge Base to the right to find out where that is located on your operating system). Find the file Inbox.msf. Note that there will be two file with the name Inbox but only one of these will have the MSF extension. Delete the file with the MSF extension. Restart Thunderbird and see if things are back to normal.
Vista Home Premium 64 - FX 37.0.1 & TB 31.6.0 Win 8.1 - FX 37.0.1 and TB 31.6.0

e633
 
Posts: 6
Joined: May 25th, 2007, 11:03 am

Post Posted May 26th, 2007, 8:28 am

Done everithing but solved nothing :s

What now?

P.S.: i use Avast antivirus 4.7 home

RobertAW
 
Posts: 7
Joined: May 25th, 2007, 6:14 pm
Location: new jersey

Post Posted May 27th, 2007, 8:58 am

I have what sounds like a variation on your invisible e-mail problem, e633. I'm migrating to a new computer, so I have Outlook running on the old computer, Thunderbird 2.0 on the new computer (xp sp2 on both), and both e-mail clients set to leave mail on the server.

Twice, there has been an e-mail that showed up on Outlook and not on Thunderbird (one of the e-mails was a notification from this forum!). The missing e-mail is not in the trash, and no junk folder has been set up yet (at least, none is visible), so it's not there. The difference between my case and yours is that when I search by subject or by sender, I get nothing. In other words, I'm not sure these messages are even being received by Thunderbird, though they're definitely on the server when Thunderbird downloads the mail.

Daifne
Moderator

User avatar
 
Posts: 122733
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted May 27th, 2007, 9:07 am

Then Outlook is downloading it and deleting it from the server, basically not leaving it for Thunderbird to get. This is a completely different issue.
JE SUIS CHARLIE
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

RobertAW
 
Posts: 7
Joined: May 25th, 2007, 6:14 pm
Location: new jersey

Post Posted May 27th, 2007, 11:51 am

No, Outlook didn't delete the e-mail from the server. It was still on the server afterwards. I verified that. As I said, both Outlook and Thunderbird were set not to delete the e-mails on the server after downloading them.

Also: Thunderbird *did* manage to download about 11 of the 12 messages that Outlook downloaded. There was just one e-mail missing.

This has happened on three separate occasions (once since I first reported it). There definitely seems to be an unresolved problem here. Thunderbird is either failing to download some of my mail or downloading it and then somehow losing it.

Thanks very much,

Bob W

Daifne
Moderator

User avatar
 
Posts: 122733
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted May 27th, 2007, 6:42 pm

Then start a new topic in Thunderbird Support rather than confusing this one.
JE SUIS CHARLIE
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

e633
 
Posts: 6
Joined: May 25th, 2007, 11:03 am

Post Posted May 31st, 2007, 12:21 pm

Still here... me and my little problem... anything left to try?

jennifein
 
Posts: 1
Joined: June 4th, 2007, 4:56 pm

Post Posted June 4th, 2007, 4:58 pm

I am having the same problem ... Thunderbird says its downloading the messages pops up says I have new mail but there is NOTHING in the inbox. I can't search but then I go back to gmail mark them unread set it back to download all mail even if I already did go back to thunderbird again says it downloading all email but still nothing. I've tried compacting and deleting .msf and still nothing.

Daifne
Moderator

User avatar
 
Posts: 122733
Joined: July 31st, 2005, 9:17 pm
Location: Where the Waters Meet, Wisconsin

Post Posted June 4th, 2007, 5:09 pm

Daifne wrote:Then start a new topic in Thunderbird Support rather than confusing this one.
JE SUIS CHARLIE
“If you make people think they're thinking, they'll love you; but if you really make them think, they'll hate you.” ― Harlan Ellison
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

ka4426
 
Posts: 1
Joined: June 6th, 2007, 6:50 am
Location: UK

Post Posted June 6th, 2007, 6:52 am

compacting the inbox worked perfectly for me, and retrieved several missing "invisible" messages, both read and unread

Return to Thunderbird Bugs


Who is online

Users browsing this forum: No registered users and 1 guest