MozillaZine

How to turn off auto complete

Closed Forum
Guest
Guest
 

Post Posted August 16th, 2003, 10:28 pm

How do you turn off the auto complete features?

I don't want the pulldown on the URL bar with past sites and I dont want form fields inside web pages to have the pull down of past sugestions either.

These pulldown menus generally get in my way, for instance typing in a url. Some times my mouse cursor will be left where one of these menus appears and when I press the enter key it selects the option the mouse was highlighting when I did not want that.

I've been looking for the better part of the day and cannot find out how to disable these menu's, can I get some help?

- Thanks

Guest
Guest
 

Post Posted August 17th, 2003, 12:26 am

to turn off autocomplete in forms

tools menu > options > privacy > saved form information > uncheck the box

look around in the options for anything else you might want to change. and visit texturizer.net/firebird for more

Nitin
Moderator

User avatar
 
Posts: 3483
Joined: February 27th, 2003, 9:38 pm
Location: San Jose, CA

Post Posted August 17th, 2003, 12:58 am

Turning off autocomplete does not work with 0.6.1 milestone

Make sure you're using a recent nightly.
I'd recommend Aug 16 build.
If you're not using Firefox, you're not surfing the web, you're suffering it.
Join the MZ folding@home team.

Buddy Christ
 
Posts: 287
Joined: April 20th, 2003, 2:51 am

Post Posted August 17th, 2003, 3:42 am

Are you completely clueless? The August 16th build has the new password manager that cannot be shut off. For someone who has over 500 posts and is a moderator I expect more...

shadytrees
Moderator

User avatar
 
Posts: 11743
Joined: November 30th, 2002, 6:41 am

Post Posted August 17th, 2003, 5:20 am

Be gentle now.
To completely turn off autocomplete, find and rename satchel.xpt in your Firebird programs directory (Start menu->Find...->Type in satchel.xpt) to anything else you want. I have 3000+ posts so I'm crossing my fingers I'm right. :-)

Guest
Guest
 

Post Posted August 17th, 2003, 8:28 am

Thanks for the assistance.
Renaming the satchel.xpt file worked for the forms inside a web page but not for the URL.

On the same line of thinking I tried to rename autocomplete.xpt which worked but also had the side effect of not being able to press enter in the URL line, you have to click the GO button. Do you have any other Ideas to prevent the pulldown for the URL part?

Äkiidoll

User avatar
 
Posts: 5473
Joined: August 16th, 2003, 2:03 pm
Location: USA

Post Posted August 19th, 2003, 1:38 am

Anonymous wrote:Thanks for the assistance.
Renaming the satchel.xpt file worked for the forms inside a web page but not for the URL.

On the same line of thinking I tried to rename autocomplete.xpt which worked but also had the side effect of not being able to press enter in the URL line, you have to click the GO button. Do you have any other Ideas to prevent the pulldown for the URL part?


There is a "Turn off auto complete" extension here at the Extensions Room, I'm not aware of how to disable it in the addy bar though. The extension will allow you to use the extension instead of digging deep into unknown territory for those less inclined.

http://extensionroom.mozdev.org/#noautocomp

Hope this helps some one else, as I see your issue has been resolved.
:usa
Caetck

Nitin
Moderator

User avatar
 
Posts: 3483
Joined: February 27th, 2003, 9:38 pm
Location: San Jose, CA

Post Posted August 19th, 2003, 1:59 am

Buddy Christ wrote:Are you completely clueless? The August 16th build has the new password manager that cannot be shut off. For someone who has over 500 posts and is a moderator I expect more...


browser.formfill.enable != password manager.
Bug 199819 if you're interested in things other than flaming.

Anonymous wrote:Thanks for the assistance.
Renaming the satchel.xpt file worked for the forms inside a web page but not for the URL.

On the same line of thinking I tried to rename autocomplete.xpt which worked but also had the side effect of not being able to press enter in the URL line, you have to click the GO button. Do you have any other Ideas to prevent the pulldown for the URL part?


You can turn off URL autocomplete by turning off history. Set it to 0 days.
If you're not using Firefox, you're not surfing the web, you're suffering it.
Join the MZ folding@home team.

Dunderklumpen
 
Posts: 16224
Joined: March 9th, 2003, 8:12 am

Post Posted August 19th, 2003, 2:51 am

Buddy Christ wrote:Are you completely clueless? The August 16th build has the new password manager that cannot be shut off. For someone who has over 500 posts and is a moderator I expect more...


I suggest that you sit down, take some deep breaths, perhaps grab a cup of coffe and try to grasp that the people in here are only human and there´s absolutely no reason to jump to any conclusions or to start a flame war. We try to help out - in doing so we might make some misstakes and there are a nice ways to point that out - perhaps with a simple question such as:

Does´n that version have the X bug?

Aretak

User avatar
 
Posts: 172
Joined: August 19th, 2003, 12:32 pm
Location: United Kingdom

Post Posted August 19th, 2003, 12:40 pm

Heh, I just came here to ask the exact same thing. Thanks for the link Caetck, it worked a treat. :)

Äkiidoll

User avatar
 
Posts: 5473
Joined: August 16th, 2003, 2:03 pm
Location: USA

Post Posted August 19th, 2003, 2:17 pm

Aretak wrote:Heh, I just came here to ask the exact same thing. Thanks for the link Caetck, it worked a treat. :)


Aretak
Hey not a problem, glad I could help. As you can see here, there are more than one way to solve issues - But we are all here to help as best we can.

**To the flamers**
Try using kindness and understanding in your posts, we all make mistakes, and some users are at different learning curves than others, as well as there being more than one method to solve any particular issue. Please keep in mind that NO one has all the correct answers, these world class MozillaDevelopers are striving for the same end user product that you are. <strong>*Excellence*</strong>

Gecko rules!
Happy browsing everyone
Caetck
A prisoner of Christ Jesus, by His stripes I was healed

whatever
Guest
 

Post Posted December 31st, 2003, 5:59 pm

I am a parent of three kids (two teenagers), and I would really relish the ability to only turn the URL auto-complete off without disabling the history.

This gives me the (quasi) ability to occasionally review what my kids might be looking at without having to worry about whichever porn site they may have been looking at popping up when I'm with my youngest, or my wife, or a house guest. If anyone is working on extension to this affect I would definately like to hear about it.

Return to Miscellaneous Support


Who is online

Users browsing this forum: No registered users and 1 guest