Multibooters think be careful? Linux and others.

Discuss various technical topics not related to Mozilla.

User avatar
Posts: 12569
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 30th, 2020, 7:50 am

Added Ubuntu 20.04, most recent release the other day and tried the ZFS setup.
Worked fine and install and updates seemed OK, However. . .
. . . being dumb and adventurous I decided to return the boot menu to another distribution.
Normally the Uefi Bios has no issues with this but in this case, once the re-install of the grub packages was performed Ubuntu was missing from the list on a re-boot. The install was performed off-line which should not make a difference but note there was an update of grub2 in the update manager list which seems odd as the system was not on-line during the install.
When going on-line and refreshing the updates the reading of the Grub changelog made checking for Efi preliminary.
I've had some problems with EFI setup and removed it completely from some of the newer OSs. The biggest issue was with the efibootmanager, which for some reason made my DVD/readwrite drive disappear from the BIOS boot list. Once the efi packages were removed and the original grub re-installed things went back to normal.
My system is a home build so it wasn't originally a different manufacturer or operating system to begin with.
It seems to me the Efi setup is fine for a single OS setup but to set grub to look for the efi first is disregarding systems which are not EFI.
Also if experimenting with the ZFS setup remember to keep the boot on the ZFS system and not the others.
There also appears to be some other speed problems opening legacy files with the ZFS setup.
PS I'd have posted this to Ubuntu forums but the Ubuntu One account went with the OS.
I'll try a re-install with the normal stuff.
Doesn't matter what you say, it's wrong for a toaster to walk around the house and talk to you


User avatar
Posts: 39259
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted April 30th, 2020, 9:15 am

Hi Grumps,
That sounds like it caused you a bit of time & frustration tracking down the errant culprit.

Please ref; the following saga...
About 5 or 6 weeks ago, I tried to install WIN10 v1903 on my dual boot WIN7 M/C to update the 1511 version.
WIN7 on the "C" drive & WIN10, v1511 on the "D" drive.
(I installed WIN10 many, many moons ago, just never used it.)

The install failed mid-steam...
When I tried to un-install the failed WIN10 I had heaps of problems.

Tried Windows Safe Mode etc., etc.
Eventually was able to rid myself of the crap by wiping the partition, BUT...
I ended up with a whole lot of "extra" files in my WIN7 partition.

They all were like this...
Original file name, eg; xxxxxx.img~57DRXTH8 or .xml or .txt or whatever.
Naturally, the ~57DRXTH8 varied on every affected, nah, duplicated file.
(At least they were all easy to see re; the pre 'tilde' > ~ & then all capitals randomly inter spaced with numerals.)

So far, I've managed to find & delete well over 15 to 20 GIG of the damn things. (Lost count.)
Had to do some locating in Windows Safe Mode, also exposing Windows "HIDDEN" files etc
& they were in places you would never have thought of.

eg; I have a series (that's lots of them), of old, authentic Adobe Photoshop CS2 Flash tutorials from their web site that I've use occasionally
& I had to go through each one & remove those damn ~XXXXXXXX files, one by one.
Open folder, change VIEW to LIST, locate each one, hold the CONTROL Key, go down the list, left clicking each one & then DELETE each batch.
Repeat as necessary.
Anyone want to help out? :)

After I had deleted (in batches over the weeks), all that I found,
I ran the dreaded CCleaner & removed them (in batches) from the registry.

I'm still not sure if I've got them all, but the M/C is running a lot quicker.

Talk about a hassle.

Anyone want WIN10 v1903? It's free. :)

Ta for reading.
ps. I forgot to say Thanks for the heads-up Grumps....Just that you're a tad late.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-
(Always choose the "Custom" Install.)


User avatar
Posts: 12569
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted May 1st, 2020, 6:09 am

@Limpet235 - Years ago in one of my posts I noted a couple of packages which might have helped you.
One opened Windows systems so you could see all the various files ,read plus delete and another to edit them using a hex editor like 1010 edit. Remembered the other package Directory Snoop
Probably in some of my first thousand posts somewhere.
Also I'm lucky having the LiveCD for Focal Fossa and hadn't gone too far with moving the straw around in the manger, you know old dogs.
Did a re-install and will test it today to make sure.
You might want to see if there's something like gparted which allows a wipe, discovery, size changes and reformat of partitions for Windows
I'd put Ubuntu Budgie on the laptop next to Mint 19.3 and after finding some limitations on packages I'd become accustomed too, wiped the partition and then enlarged the one for the Mint, really kind of simple from when things first started.
It's all part of it and it did say it was experimental, sometimes the rocket blows up.
After normal install of Focal Fossa was able to relocate the grub menu
There was also an update of the grub2 for pc packages so UEFI stays intact.
Doesn't matter what you say, it's wrong for a toaster to walk around the house and talk to you

Return to MozillaZine Tech

Who is online

Users browsing this forum: No registered users and 5 guests