MozillaZine


Can't log onto BitDefender Central from FireFox

User Help for Mozilla Firefox
pokeefe0001
 
Posts: 99
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted May 18th, 2022, 3:23 pm

When I try logging onto BitDefender's BitDefender Central web page using FireFox I am given the login page again. When using Chrome the login succeeds. I'm not getting any useful help from BitDefender so I'm trying from the FireFox side.

As near as I can tell, this particular login page is reached only by links from other BitDefender pages. One of those links is
https://login.bitdefender.com/central/l ... itdefender

That link works on Chrome -that is, I succeed in logging in. With FireFox that login page is re-displayed. I have no idea where to start diagnosing this.
Patrick O'Keefe
Win10 x64 Pro, FF 100.0.1 TB 78.11.0

DanRaisch
Moderator

User avatar
 
Posts: 125490
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 18th, 2022, 4:50 pm

Try clearing the Firefox cache and deleting any cookies relating to that particular site.

pokeefe0001
 
Posts: 99
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted May 18th, 2022, 5:55 pm

I should have mentioned that I did that. I also created a new userid (which is an email address) and password just in case there was related to the email address (althouh that should also have effected Chrome).
Patrick O'Keefe
Win10 x64 Pro, FF 100.0.1 TB 78.11.0

therube

User avatar
 
Posts: 21024
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted May 19th, 2022, 9:25 am

What version of FF, 72 or 95 or ...?
If 72 (who knows, maybe even if 95), they may be using chrome-isms that are not available in 72?

If you attempt to log in from a Private Window, does the same happen?
If you attempt to log in from a new, clean Profile, does the same happen?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

dickvl

User avatar
 
Posts: 53668
Joined: July 18th, 2005, 3:25 am

Post Posted May 21st, 2022, 10:41 am

(wrong thread)

pokeefe0001
 
Posts: 99
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted May 21st, 2022, 4:33 pm

therube wrote:What version of FF, 72 or 95 or ...?
If 72 (who knows, maybe even if 95), they may be using chrome-isms that are not available in 72?

It happens on both 96 and 100. It did not happen on a new, clean installation of FF on a computer that never had it installed so I've dug a bit deeper. Even though I thought I had exonerated it, I've discovered the culprit is NoScript. I've marked as "safe" all sites NoScript finds on the BitDefender login page, but there is undoubtedly some nested script that doesn't stay around long enough for me to see. (That statement probably proves I don't really know how NoScript works.)

Is there any FF debugging mode where it lists every page visited?

Is there any diagnosis mode for NoScript that lists all blocked scripts or pages? I know I should probably ask that on a NoScript forum (if such a forum exists).
Patrick O'Keefe
Win10 x64 Pro, FF 100.0.1 TB 78.11.0

pokeefe0001
 
Posts: 99
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted May 21st, 2022, 9:53 pm

More strange information. I created a new profile, installed NoScript, and had no trouble logging onto BitDefender. The problem seems to be a combination of my profile, NoScript, and the BitDefender web page. I guess I should create a new default profile. Is there any way to transfer bookmarks, cookies, and password data to a new profile without copying the whole profile? I'm pretty sure the answer is "yes" for bookmarks and maybe for password data (not encrypted), but is there a way to extract specific cookies from a profile? I'm going to loose a session data if I cannot do that.
Patrick O'Keefe
Win10 x64 Pro, FF 100.0.1 TB 78.11.0

pokeefe0001
 
Posts: 99
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted May 23rd, 2022, 11:30 am

I found instructions on transferring bookmarks and password data, and an extension for exporting/importing cookies. One corrupted cookie was found and not imported. I have no idea if that was my problem - I sort of doubt it - but I no longer have the problem
Patrick O'Keefe
Win10 x64 Pro, FF 100.0.1 TB 78.11.0

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 5 guests