MozillaZine


Update from 91 ESR to 102 ESR has two issues for me

User Help for Mozilla Firefox
rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 22nd, 2022, 4:37 pm

Forced to update (expected) and 102 ran like two flat tires and no spare. MANY hours of searching got me reasonably successful in acceptable performance. But two problems, one which could easily be a bug:

1. I can find no way including in about: Config to enable lazy tab loading. In other words, open a group but not load each tab until it is clicked on.

Where did that go?

2. This one is more unique.

I have a desktop install of ESR and a portable ESR install on a thumb drive. For MANY years I backed up bookmarks on my desktop and restored them to FF on my thumb drive. Now, after I shut down the portable (which takes a very long time) there are multiple bookmarks. Html files that seem to merge on shutdown. Problem is, on the thumb drive this is not completed before FF shutdown and the processes closed. Results in damaged bookmark files and a crash EVERY time.

IF I drag the copy of FF ESR portable to my desktop and perform the same procedure, no problems. So somehow on a USB 3 thumb drive the process of merging bookmarks. Html files is too slow and will cause a crash consistently.

jscher2000

User avatar
 
Posts: 11686
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted September 22nd, 2022, 11:05 pm

rebop wrote:1. I can find no way including in about: Config to enable lazy tab loading. In other words, open a group but not load each tab until it is clicked on.

How are you opening a group of tabs? Is this, for example, you right-click on a folder of bookmarks and Open All Bookmarks?

rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 23rd, 2022, 3:58 am

My normal way is to use Tab Session Manager, but that has a built in Lazy Opening feature which is painfully slow. So in looking for a FF feature (which I could not find as a setting) I test opening a group of bookmarks.

Thanks for the reply.

Just to clarify a bit, what was behind that is I had 91 working very well but 102 would peg CPU usagage at 100% for a long time, sometimes as long as it took to open all tabs. Lazy is one solution if it worked smoothly and quickly enough. Having Performance set to 1 in 91 worked, but that setting is gone in 102 and the about:config for dom.ipc.processCount defaultied to 8 and setting to 1 made no difference in the amount of running processes.

Maybe the background on why I was looking for this is helpful.

rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 23rd, 2022, 2:34 pm

Got great clues in other forum where it seems I have had browser.bookmarks.autoExportHTML set to true.

I did not make that change, nor can I find an addon that did or even could have. But with that change to false and deleting the bookmarks.html file, everything runs smoother and the portable versions seem much more stable. Maybe not 100% but definitely 90%.

So scratching my head how that setting could have been changed.

Still would love to know where in about:config I could set lazy tab opening.

Thanks!

dickvl

User avatar
 
Posts: 53811
Joined: July 18th, 2005, 3:25 am

Post Posted September 23rd, 2022, 4:51 pm

dom.ipc.processCount only works if Fission is disabled (that is why you do not see it in Settings).
fission.autostart = false

rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 24th, 2022, 5:06 am

dickvl wrote:dom.ipc.processCount only works if Fission is disabled (that is why you do not see it in Settings).
fission.autostart = false


Thanks. When I do that, there is no change when dom.ipc.processCount is changed. The amount of processes seem only dictated by fission. Though greatly improved this way. Not as good as previously when set to performance of 1.

dickvl

User avatar
 
Posts: 53811
Joined: July 18th, 2005, 3:25 am

Post Posted September 24th, 2022, 1:59 pm

When you disable Fission (fission.autostart = false) and restart Firefox then you should be able to find "Content process limit" in Settings.
Settings -> General -> Performance -> [] Use recommended performance settings

See also about:processes

rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 24th, 2022, 2:22 pm

Wow!! You are correct and it is set to 1 there. I never thought to look after turning off fission.

My "perception" is 102 set this way does not run as smotthly as 91, but I am at a liveable point.

Thanks so much for all the help. Likely will post another question on a change in 102 I tend to think I solved a few years agao and connot recall the solution.

Learned a lot in this thread. Thanks so much!

JodyThornton

User avatar
 
Posts: 150
Joined: August 12th, 2004, 5:59 pm
Location: Richmond Hill, Ontario (Canada)

Post Posted September 25th, 2022, 1:55 am

I'm also surprised I haven't heard anything about this issue at all:
viewtopic.php?f=38&t=3099998

I have it up on Bugzilla, but I thought maybe somebody else would have encountered it.
Cheers,
Jody Thornton
(Richmond Hill, Ontario)

therube

User avatar
 
Posts: 21288
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted September 27th, 2022, 11:01 am

(I know nothing of the extension nor how it might affect things...)

Have a look at:
about:config, tab.*load, & some of the settings in there.

browser.tabs.loadInBackground
defaults to false (which you would want, I'm thinking)
& then some of the others might be worth a tinker?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

rebop
 
Posts: 34
Joined: February 1st, 2015, 2:47 pm

Post Posted September 27th, 2022, 12:25 pm

Thanks. Not seeing anything of interest.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 5 guests


cron