MozillaZine

PDF & Flash cause Firefox to crash

User Help for Mozilla Firefox
ancientangler
Guest
 

Post Posted May 28th, 2009, 11:19 am

I'm running Firefox 3.0.10, but the following symptoms began about a week ago while running 3.0. If I click on a link to a PDF file, Firefox crashes immediately. As of yesterday, clicking on a link requiring Flash (like a youtube video) causes an immediate crash too.

This morning, I completely uninstalled and reinstalled Adobe Reader (v 9.x) as well as Flash player, using new files from the appropriate Adobe web site. I also updated Firefox from 3.0 to 3.0.10. No luck. Still crashes. The computer is checked for nasties twice every day using AVG (for viruses) and ZoneAlarm (for spyware). Nothing else has been changed on this computer in several months. Using Windows XP SP2, and all updates are done manually.

Any help would be appreciate. This new problem makes no sense.

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 28th, 2009, 11:30 am

Try running in Mozilla Safe Mode to see if the issue might be caused by an installed extension -- http://kb.mozillazine.org/Safe_mode
Also see this link -- http://kb.mozillazine.org/Standard_diag ... Firefox%29 (One initial step might be to create a new profile and try running that with nothing installed but one or the other of those plug-ins)

http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

ancientangler
Guest
 

Post Posted May 28th, 2009, 12:32 pm

Interesting. Running safe mode solved the problem. Now: Should disabling extensions be enough to eliminate their effects for testing purposes, or should they be completely uninstalled?

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 28th, 2009, 1:02 pm

If things are working in safe mode, disabling should be sufficient, but it may not be necessary to disable all extensions. Manually disable them all, then launch in regular mode to confirm things are working properly. Next, enable one extension, shut down and restart Firefox. See if the problem reoccurs. If not, enable another extension (in addition to the first) and close and restart Firefox. Repeat the procedure until the problem shows up. The last enabled extension will be the cause of the conflict.

Note that if you have many installed extensions you could enable them a few at a time, with the caution that if the problem appears you will have to back track and disable the last set and reenable them one by one to find the culprit.

ancientangler
Guest
 

Post Posted May 28th, 2009, 1:12 pm

Thank you. Problem eliminated. I only had 3 extensions, so whacking them all wasn't a big deal. Before I begin adding them back again, do you have a favorite flash blocking tool? I was using FlashBlock, and the occurrence of the problem absolutely did NOT coincide with its installation, but I'm always interested in better tools if they exist.

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 28th, 2009, 1:28 pm

You're welcome. I'm not using anything other than FlashBlock for that purpose so I really can't offer any guidance on that issue.

ancientangler
Guest
 

Post Posted May 28th, 2009, 2:06 pm

I still can't view the videos at www.cnn.com, but that problem's been around forever and I have yet to find a solution. I've erased & reinstalled everything except my furnace.

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 28th, 2009, 2:36 pm

No problem viewing them here. There are a load of JavaScripts running on that page. Do you have JavaScript enabled under Tools->Options->Content?
Is one of the extensions you have installed NoScript or AdBlock Plus (or a similar script blocking addon)?

ancientangler
Guest
 

Post Posted May 28th, 2009, 2:53 pm

All I have is Flashblock, which is operative, along with 3 disabled ones: Java Quick Start and a couple that came with AVG antivirus. Javascript is enabled. In its advanced settings, none of the limiters are checked. Very strange.

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted May 28th, 2009, 6:17 pm

What version of AVG are you running? Version 8.5 has been reported as problematic in many situations. You might try running with that utility after removing it from the Windows start up programs folder and rebooting the system.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 6 guests