MozillaZine

Homepage changed to google after restart

User Help for Mozilla Firefox
nuaris
Guest
 

Post Posted June 15th, 2009, 9:05 pm

My homepage always redirects to http://www.google.com no matter what I do. I do not have a user.js file, and I am quite sure that there is no malware in the system because hijackthis looks clean. Is there anything else I can do to fix this?

Thanks.

DanRaisch
Moderator

User avatar
 
Posts: 107720
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted June 16th, 2009, 4:29 am

Have you tried resetting the home page under Tools->Options->Main->Home page?

Guest
Guest
 

Post Posted June 17th, 2009, 9:54 pm

I have tried that, but it still returns to http://www.google.com no matter what I try to change the homepage to.

DanRaisch
Moderator

User avatar
 
Posts: 107720
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted June 18th, 2009, 4:44 am

See if this article is helpful -- http://kb.mozillazine.org/Corrupt_localstore.rdf

Guest
Guest
 

Post Posted June 19th, 2009, 7:52 pm

Just tried that, went into safe mode and "reset toolbars and controls" but that didn't work. Is there anything else that can be done?

DanRaisch
Moderator

User avatar
 
Posts: 107720
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted June 20th, 2009, 9:31 am

Did you delete the file localstore.rdf before resetting the toolbars and controls?

Guest
Guest
 

Post Posted June 22nd, 2009, 10:58 pm

Deleting localstore.rdf and starting safe mode fixes the problem. But it still reverts to the google homepage when firefox is started again. Could there be another cause for this problem?

DanRaisch
Moderator

User avatar
 
Posts: 107720
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted June 23rd, 2009, 4:34 am

If the problem exists in standard mode but not in Safe Mode the problem is caused by an installed extension. You can disable all such add-ons and reenable them one by one until you see this failure again. The last one enabled will be the cause of the problem. It's best to close and restart Firefox after each new extension is enabled.

Guest
Guest
 

Post Posted June 28th, 2009, 5:41 pm

Sorry for the late reply. Disabling all add-ons didn't fix the problem. The homepage returned to google again after firefox is restarted. Is there anything else left to try or would it be better to just reinstall firefox?

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 17 guests