MozillaZine

disable "This Connection is Untrusted" messages

User Help for Mozilla Firefox
WiteLite
Guest
 

Post Posted July 20th, 2009, 6:47 pm


spok
Guest
 

Post Posted July 22nd, 2009, 2:19 pm

Do you use windows ? If so, it can be a virus.

Bluefang

User avatar
 
Posts: 7850
Joined: August 10th, 2005, 2:55 pm
Location: Vermont

Post Posted July 22nd, 2009, 4:00 pm

There have always been ghosts in the machine... random segments of code that have grouped together to form unexpected protocols. Unanticipated, these free radicals engender questions of free will, creativity, and even the nature of what we might call the soul...

dickvl

User avatar
 
Posts: 51515
Joined: July 18th, 2005, 3:25 am

Post Posted July 22nd, 2009, 8:55 pm

If you need to connect to that site then install the root certificate:
http://ist.mit.edu/services/certificates/guide#site

elisab
Guest
 

Post Posted July 27th, 2009, 11:48 pm

This is strange indeed. Another example: https://linuxfr.org/

Very likely a spyware or virus somewhere for windows users.

Shael
Guest
 

Post Posted August 3rd, 2009, 2:01 am

Anonymous wrote:I just reinstalled windows today. and i now get this message for "every" https site i visit.
yahoo mail
gmail
hotmail
bank
every random one i click on it says this.
whats going on?
its a fresh install
I have the exact same prob while running Win7 x64 RTM - fresh install.. every site is coming up as "Connection is Untrusted" yousendit.com as well..

This is laaaame. hope it's not cause my copy of win is unregistered.. cause that would be painfully sly MS work..
Last edited by LIMPET235 on August 3rd, 2009, 2:14 am, edited 1 time in total.
Reason: To remove the offensive language.

adhi_hargo
Guest
 

Post Posted August 11th, 2009, 5:03 pm

Yep, this is very annoying. I have to add security exception for Yahoo! Mail, Facebook, even every single add-on page on Firefox's own add-ons repository. And as if that's not annoying enough, I can't seem to add exception using only keyboard navigation...

dickvl

User avatar
 
Posts: 51515
Joined: July 18th, 2005, 3:25 am

Post Posted August 11th, 2009, 5:58 pm

Which security software (firewall) do you have?
There are firewalls (e.g. Kaspersky) that install a proxy to monitor the internet traffic and send their own certificate instead of the certificate from the web server.
You need to install the Kaspersky root certificate to make Firefox recognize the issuer of the certificates.

Guest
Guest
 

Post Posted August 12th, 2009, 7:08 am

Check your system date and time if you've just done a fresh install, I had this same problem with a fresh install of windows and the system date and time were incorrect. I've just changed to the correct date and time and this solved my problems. Hope this helps.

Guest
Guest
 

Post Posted August 14th, 2009, 12:40 am

Guest wrote:Check your system date and time if you've just done a fresh install, I had this same problem with a fresh install of windows and the system date and time were incorrect. I've just changed to the correct date and time and this solved my problems. Hope this helps.


Yep thats the answer, just removed the battery from my mother board so that i can replace it later and now firefox disalowing connection to hotmail and is ultimitly how i ended up here.

Im not suggesting this is the fix to everyones computer on this issue but your mother board battery may be on the way out. Who ever said it was a virus causing this is just insighting panic.

post2forum
 
Posts: 132
Joined: September 1st, 2005, 7:22 pm

Post Posted August 17th, 2009, 12:33 pm

I don't see the option to make an exception. I am going through a proxy. But there is no option to make exceptions.

Image

Gingerbread Man

User avatar
 
Posts: 7413
Joined: January 30th, 2007, 10:55 am

Post Posted August 17th, 2009, 12:53 pm

post2forum wrote:I don't see the option to make an exception.

  1. Type about:config in the address bar and press Enter.
  2. Press the big button to bypass the warning.
  3. In the Filter: bar, paste browser.xul.error_pages.enabled
  4. In the search results, double-click browser.xul.error_pages.enabled to set its value to true.

post2forum
 
Posts: 132
Joined: September 1st, 2005, 7:22 pm

Post Posted August 17th, 2009, 1:58 pm

Thank you for the advice. It was already set true (default).
I changed browser.ssl_override_behavior to 2 but no change.
My clock is set correctly.
With the proxy disabled I do not receive the warnings.
With the proxy enabled I see a message box warning for any site I try to visit that is https, paypal amazon etc.
But there is no override notice. I tried from a test profile as well.

Gingerbread Man

User avatar
 
Posts: 7413
Joined: January 30th, 2007, 10:55 am

Post Posted August 17th, 2009, 3:28 pm

browser.ssl_override_behavior determines if the Firefox will fill out the exception URL and download the certificate once you choose to set up an exception. It has nothing to do with the dialog box that you posted above, which is what you get when XUL error pages are disabled.

Image

Try starting in Safe Mode. Do you have an explanation for those two [#] signs in the title bar?

post2forum
 
Posts: 132
Joined: September 1st, 2005, 7:22 pm

Post Posted August 17th, 2009, 6:41 pm

Hi thanks for your reply. Regarding the # signs, I run firefox sandboxed using Sandboxie.

I tried in safe mode but I still get a message box and no override.

EDIT: I tried Firefox 3.5 and I can see the page come up, but I cannot add an exception. I click the button and it does nothing. I tried on another user account and same thing. I also re-tried Firefox 3 and I still get the message box.
So guess what I did? I tried Firefox 2 and the message box comes up and I choose to accept temporarily for this session, and it works. I can override in FF2 but not FF3 or FF3.5...
I am not on a work computer and I have no access restrictions other than Sandboxie. I did try FF3.5 both with and without Sandboxie. I have the same issue regardless. The override page comes up but the button does nothing.
Last edited by post2forum on August 17th, 2009, 7:00 pm, edited 1 time in total.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 11 guests