MozillaZine

Firefox only displays source code

User Help for Mozilla Firefox
Mort_Coyle
 
Posts: 3
Joined: October 6th, 2004, 10:18 am

Post Posted October 6th, 2004, 10:30 am

Hello!

I'm considering migrating my company's desktops from IE to Firefox, but have run into a small problem. Our initial webmail page seems to only work with IE. When I try to access it with Firefox, it displays the source code, not the actual page. We don't have a webmaster and I'm not a web developer. Here's the link to the page: http://www.mansonconstruction.com/webmail

I'm thinking that the problem is with this line: <meta http-equiv="Refresh" content="0;URL=http://www.mansonconstruction.com/servlet/webacc">, which does a redirect, but I can't figure out what's incorrect about it.
The page that this is supposed to redirect to (/servlet/webacc) works just fine in Firefox, so the problem seems to be getting this redirect to function.

Any suggestions?

Thanks!

LeRoi
Moderator

User avatar
 
Posts: 10346
Joined: September 15th, 2003, 10:22 am

Post Posted October 6th, 2004, 10:38 am

The mime type of the server is probably configured to display text/plain, which IE "overlooks" and displays as html, Firefox won't overlook such mistakes.

Validation Results

Mort_Coyle
 
Posts: 3
Joined: October 6th, 2004, 10:18 am

Post Posted October 6th, 2004, 11:39 am

Thanks for the suggestion. I checked on the mime type configuration on the web server and it shows:

type=text/html exts=htm,html

So that doesn't appear to be the source of the problem. I also tried adding a DOCTYPE statement to the page, but that made no difference.
Last edited by Mort_Coyle on October 6th, 2004, 12:04 pm, edited 1 time in total.

LeRoi
Moderator

User avatar
 
Posts: 10346
Joined: September 15th, 2003, 10:22 am

Post Posted October 6th, 2004, 11:43 am


Duey
 
Posts: 155
Joined: November 7th, 2002, 8:06 pm

Post Posted October 6th, 2004, 12:07 pm

> type=text/html exts=htm,html

You'll need to put an extension on your webmail page for that to work. It's still coming up as text/plain (via Tools menu in Firefox, Page Info) for me.

[edit to add:] sorry, didn't read your first post fully, didn't know you didn't have a webmaster/etc. It probably would be better not to try to add an extension to your webmail page since that'll probably break stuff.

[and some more:] The page http://www.mansonconstruction.com/servlet/webacc seems to work for me in Firefox. Maybe you should link to that instead?

Duey

Mort_Coyle
 
Posts: 3
Joined: October 6th, 2004, 10:18 am

Post Posted October 6th, 2004, 12:32 pm

Aha! That got me going in the right direction. The default mime type was set to text/plain. Since the webmail page doesn't have an extension, it was using the default mime type. I set the default to text/html and that fixed it. I use "webmail" without an extension to make it easier for my end-users.

Thanks for your help guys!

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot], gregmlang and 19 guests