MozillaZine

Are you sure you want to navigate away from this page?

User Help for Mozilla Firefox
hillyard
Guest
 

Post Posted September 16th, 2009, 7:48 pm

Firefox has just started giving me this message "Are you sure you want to navigate away from this page?" Is there a way to eliminate that window?

smsmith
Moderator

User avatar
 
Posts: 18889
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted September 16th, 2009, 8:07 pm

Any specific site where you get this message?
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

dickvl

User avatar
 
Posts: 51514
Joined: July 18th, 2005, 3:25 am

Post Posted September 16th, 2009, 8:47 pm


uHuRu1976
Guest
 

Post Posted September 16th, 2009, 11:26 pm

oh, it's solved!

The facebook gadget on igoogle causes that issue.
Last edited by Dartman on September 17th, 2009, 4:38 am, edited 2 times in total.
Reason: Removed explicit, replaced with another word.

Guest
Guest
 

Post Posted September 17th, 2009, 10:54 pm

Well I don't have iGoogle, and I get those messages frequently...

...even when I'm just staring at Facebook... not even navigating away from a page... I'll just be sitting there and all of a sudden the message will pop up. Very aggravating.....

JonathanMurray

User avatar
 
Posts: 18
Joined: December 13th, 2004, 4:32 pm

Post Posted September 19th, 2009, 5:08 am

The problem is not solved. While the Facebook iGoogle app may activate the symptom, it is not the cause. I can say this with 100% certainty because I have the problem on three machines, two of which never load my iGoogle page. Oh, and I don't have that app loaded to my iGoogle, regardless.

The only common denominator is Facebook itself, which some have already identified as having added some obnoxious code to annoy auto-refreshers. We just need a greasemonkey pro to write us a script to strip it out and all will be well again.

Another suggestion is to clear the cache, but I have found that only works for a short while.
Jonathan G Murray
http://www.lanoitar.com

smsmith
Moderator

User avatar
 
Posts: 18889
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted September 19th, 2009, 6:25 am

I tried clearing my Facebook cookies, but that wasn't it.
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Psyberwolf

User avatar
 
Posts: 15
Joined: August 22nd, 2004, 10:44 am
Location: Round Lake Beach, IL

Post Posted September 19th, 2009, 8:55 am

I've been getting this same annoying pop-up recently out of the blue. I cleared out my cache, history, and cookies (to make sure nothing old is in the background) and I still get the problem. That and the continuous unable to load the page error. At least the problem, for me, is it's only contained to Facebook.
What if the Hokey Pokey IS what it's all about?

smsmith
Moderator

User avatar
 
Posts: 18889
Joined: December 7th, 2004, 8:51 pm
Location: Illinois

Post Posted September 19th, 2009, 9:02 am

From the link that dickvl posted, it sounds like Facebook has changed some sort of script on the page (probably to prevent people from constantly reloading some of the applications to increase the score or something stupid like that). So it's really a Facebook problem.

In that link, somebody posted a Greasemonkey script that is supposed to stop it, but I don't know how to write Greasemonkey scripts and I really only see this once or twice a session.

I suppose turning of javascript is a workaround, but not a good one.
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

Guest
Guest
 

Post Posted September 20th, 2009, 11:11 am

i too am getting that message on FB and also have been having a hell of a time posting comments to my own wall. i have to turn of AV, clear cache, then i can turn on the AV again, before it will post. frustrating.

Crookid
Guest
 

Post Posted September 20th, 2009, 12:49 pm

I'm having the exact same problem and it's only contained to FB. Regardless of where I click within FB, I get the pop up message. This is only a recent phenomenon for me. I use AdBlock Plus and have tried to add filters to block it but haven't had any luck (mostly because I don't know what I should be blocking). I don't have the igoogle add-on and I won't disable Java. I guess I can go outside again.

Dan Lutes
Guest
 

Post Posted September 20th, 2009, 7:04 pm

Also getting the message "are you sure you want to navigate away from this page" and it just started yesterday with no changes...since I have uploaded Windows Explorer 8.0 and de-activated ALL google apps and still no luck...it is definitely FB only and I don't use Farmtown or any geeky apps

rakhma_f
Guest
 

Post Posted September 23rd, 2009, 2:38 am

me too. i got the same problem on fb only starting this morning. i dunno how to solve it n when i googled it seems im not the only one.... it's definitely fb problem..... anyone has been succeed solving this???

Dwight_Stegall

User avatar
 
Posts: 21
Joined: June 13th, 2008, 11:56 am

Post Posted January 26th, 2010, 1:53 am

There is no solution to this problem. The box you are seeing is nothing more than an average Javascript Confirm box embedded in the HTML source code of the site you are viewing. I used to use these myself.

I don't even use Igoogle and I still get this. I get it at surfthechannel.com

Most sites these days use Javascript in some way or another. If you disable it you will miss out on a lot of great content.

This is just one of those things we all just have to live with.

Those of you that use Igoogle try http://www.netvibes.com. Igoogle is the worst start page on the web.

i make my own start pages.

dickvl

User avatar
 
Posts: 51514
Joined: July 18th, 2005, 3:25 am

Post Posted January 26th, 2010, 12:45 pm

There have been reports that certain Google gadgets caused this issue.
See http://support.mozilla.com/tiki-view_fo ... tId=450695

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], ted 1950 and 21 guests