MozillaZine

Firefox vs. Citrix Ica client (WebInterface) HOWTO

User Help for Mozilla Firefox
LBJ
Guest
 

Post Posted November 12th, 2004, 8:10 am

Ive been trying for some time to find a solution on how to use Web Interface (WI) with Firefox, but the tips so far has either not worked or not been a complete solution...
After trying a few different solutions i found out what works, using WI only or WI with CSG/RSA.

Versioninfo:

Windows XP, SP2
FireFox 1.0

Webinterface with RSA/CSG.

Metaframe Access Client 8.0 (8.100.29670 128-bit SSL)

After installing both Firefox and the Ica client, the following files have to be copied from ..\Citrix\ICA Client\ to ..\Mozilla Firefix\plugins\ :

npicaN.dll (v. 8.100.29670.0)
icalogon.dll (v. 8.100.29670.0)
PScript.dll (doesnt list a ver.)
sslsdk_b.dll (v. 8.100.29670.0)
cgpcfg.dll (doesnt list a ver.)
TcpPServ.dll (doesnt list a ver.)
CgpCore.dll (doesnt list a ver.)

and from ..\Citrix\ICA Client\resource\en\ to ..\Mozilla Firefix\plugins\ :

npicanUI.dll (v. 8.100.29670.0)

To use WebInterface without RSA/CSG support you only the following file copied from ..\Citrix\ICA Client\ to ..\Mozilla Firefix\plugins\ :

npicaN.dll (v. 8.100.29670.0)

Hope this can be of help to someone other than myself :)

Guest
Guest
 

Post Posted December 9th, 2004, 1:08 pm

Thank you. It was useful for me!

sberg
 
Posts: 40
Joined: November 22nd, 2004, 9:29 am
Location: Sweden

Post Posted December 27th, 2004, 8:28 am

For v8.00.24737 you also need

sslsdkUI.dll

from \resourc\en\

Guest
Guest
 

Post Posted January 26th, 2005, 9:16 pm

Thanks, that did the trick.

sphemy
Guest
 

Post Posted January 30th, 2005, 2:48 pm

That's strange, i dit nothing about this, and it works for me. I use firefox 1.0, I installed MetaFrame Presentation Server Client Packager - Version 8.x. Link: http://www.citrix.com/site/SS/downloads ... 36&pID=186
The only problem I've got was with the certificate of the website where I was logging into. I've got the following error: "Server Certificate not trusted. Ssl error 61".
But after installing the certificated (by clicking on a link when I've opened the website in IE), the problem was gone.

Guest
Guest
 

Post Posted February 8th, 2005, 9:01 am

Two things...

I found that if you install the Citrix client first and then Firefox, the plugin doesn't exist in the Firefox folder and you have to manually copy the files. I think the reasons for this are obvious. But if you (uninstall and then) install the Citrix client after you have installed Firefox, the files should get automatically copied correctly. This certainly simplified the process for me.

The second thing is that I also found that the icalogUI.dll file in resource\en was also copied over by the Client installation. I'm not sure if this is a "required" file, but in my mind, if Citrix is doing it as part of their installation, it can't hurt.

e-stewart
Guest
 

Post Posted June 10th, 2009, 6:26 am

Thanks. The first post solved my problem.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 22 guests