MozillaZine

Java Console extensions

User Help for Mozilla Firefox
twl845

User avatar
 
Posts: 163
Joined: March 12th, 2005, 7:18 am

Post Posted January 21st, 2010, 4:32 pm

Hi, I just upgraded to v3.6, and checked my extensions at tools>add ons> extensions. I see that there are numerous Java Console entries listed as extensions. They are listed as:
Java Console 6.0.02, 6.0.03, 6.0.05, 6.0.07, 6.0.11, 6.0.13, 6.0.14, 6.0.15 and 6.0.17.
My question is, are all these entries needed, or do we only need 6.0.17? Thanks in advance. :)
If it ain't broke don't fix it.

47QS
Guest
 

Post Posted January 21st, 2010, 7:51 pm

same here i had all kinds of old consoles but my only sun java machine that is installed is the 6_u18 as of recently. ofcourse it came a long way ever since 6_u1 u14 u16 u17 and u18 and such stuff...

i wonder if this is a firefox 3.6 bug as my older firefox 3.5.7 didnt have all these console entries for java stuff......

weird. do we have a bugzilla # yet for this?

Bluefang

User avatar
 
Posts: 7857
Joined: August 10th, 2005, 2:55 pm
Location: Vermont

Post Posted January 21st, 2010, 8:39 pm

Java Console is a 3rd party extension from Sun. IIRC, I think this is installed when you Install/Update Sun Java.

Just uninstall the versions you don't need/use/have. There are some uninstaller extensions available (don't know if you need to use them)
https://addons.mozilla.org/en-US/firefo ... le&cat=all
There have always been ghosts in the machine... random segments of code that have grouped together to form unexpected protocols. Unanticipated, these free radicals engender questions of free will, creativity, and even the nature of what we might call the soul...

twl845

User avatar
 
Posts: 163
Joined: March 12th, 2005, 7:18 am

Post Posted January 21st, 2010, 9:16 pm

Bluefang wrote:Java Console is a 3rd party extension from Sun. IIRC, I think this is installed when you Install/Update Sun Java.

Just uninstall the versions you don't need/use/have. There are some uninstaller extensions available (don't know if you need to use them)
https://addons.mozilla.org/en-US/firefo ... le&cat=all

Hi, Thanks for responding. You say to uninstall the versions I don't need, but as I implied in my post, I asked if I should uninstall all but the 6.0.17. I don't know which ones/one I need.
If it ain't broke don't fix it.

dickvl

User avatar
 
Posts: 52869
Joined: July 18th, 2005, 3:25 am

Post Posted January 21st, 2010, 9:24 pm

6 U18 is the latest version of Java, so you can uninstall them all and update or do a full install of Java 6 U18 (that is usually a lot faster: seconds versus minutes)

See http://java.sun.com/javase/downloads/index.jsp#jre

Bluefang

User avatar
 
Posts: 7857
Joined: August 10th, 2005, 2:55 pm
Location: Vermont

Post Posted January 21st, 2010, 10:33 pm

I asked if I should uninstall all but the 6.0.17. I don't know which ones/one I need.

If you need to ask, then you don't need them.

The Java Console extension does not impact the functionality of Java in Firefox. It just lets you monitor and debug running applets. Unless you're developing a Java applet, you probably have little use for it.
There have always been ghosts in the machine... random segments of code that have grouped together to form unexpected protocols. Unanticipated, these free radicals engender questions of free will, creativity, and even the nature of what we might call the soul...

Guest
Guest
 

Post Posted January 22nd, 2010, 7:10 am

The uninstall feature is not available only disable. How should I proceed?

twl845

User avatar
 
Posts: 163
Joined: March 12th, 2005, 7:18 am

Post Posted January 22nd, 2010, 7:52 am

OK thanks for setting me straight everyone. :D
If it ain't broke don't fix it.

paulo99
Guest
 

Post Posted January 22nd, 2010, 9:50 am

I got the same issue (viewtopic.php?f=38&t=1710075) and someone told me it's a side effect of hidden extensions that don't stay hidden.
Some plugins have hidden addons like the Java Platform or Songbird.

See the (old) bug report about this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=508109

Hope it helps. :)

Guest
Guest
 

Post Posted January 22nd, 2010, 10:09 am

Is it ok to disable the excess Java extensions or just leave well enough alone?

russws
 
Posts: 23
Joined: July 16th, 2003, 9:33 am

Post Posted January 22nd, 2010, 10:20 am

The old ones are easy to get rid of
FYI, the latest version of Java SE will bring your console up to 6.0.18. If you don't have that you might as well update Java - you can do it from Control Panel if you have Windows.

In any case, close Firefox, go to the main Firefox installation, i.e Program Files/Mozilla Firefox/Extensions
You will see all the Java extensions with similar file names {CAFEEEFAC...}
Delete all but the newest.
Restart Firefox

MikeGrieff
 
Posts: 2
Joined: December 6th, 2008, 3:46 pm

Post Posted January 23rd, 2010, 8:04 pm

I recently updated java to 6.0.18. Shortly there after Firefox would not open a new window, and when I closed Firefox and would restart Firefox, it would not startup. I jus', went thru my Add-Ons, disabling each until Firefox would open a new window and would not be left running in Task Manager Processes. The culprit turned out to be Java Console 6.0.18; I disabled it. After reading the posts here I may, jus', uninstall the Add-On.

Mike Yohe
Guest
 

Post Posted February 1st, 2010, 1:57 pm

MikeGrieff wrote:I recently updated java to 6.0.18. Shortly there after Firefox would not open a new window, and when I closed Firefox and would restart Firefox, it would not startup. I jus', went thru my Add-Ons, disabling each until Firefox would open a new window and would not be left running in Task Manager Processes. The culprit turned out to be Java Console 6.0.18; I disabled it. After reading the posts here I may, jus', uninstall the Add-On.


Just had the same problem. I, too, disabled Java Console 6.0.18 (and enabled 6.0.17) and Firefox seems to be working fine now.

Guest
Guest
 

Post Posted February 27th, 2010, 10:06 am

Enough with the perpetual, incessant Java console micro-updates already!!!

1) Java console update notification
2) Update Java console (by ver x.x.02 increments, no less!)
3) Pop-up notification that older Java console "no longer compatible"
4) Pestered to restart (just-started) Firefox
5) Repeat of all above every 2-3 days, ad-nauseum and seemingly ad-infinitum ](*,)

This can NOT be right!!

Sure hope that this helps: "" ... disabled Java Console 6.0.18 (and enabled 6.0.17) and Firefox seems to be working fine now."

Bffld
Guest
 

Post Posted March 4th, 2010, 11:03 am

I am having similar problems; upgraded to Firefox 3.6, saw multiple Java Console extensions, so I uninstalled all but most recent, which is 6.0.13. I am running XP. I had a window freeze up with a subscript thus "javascript: void (0)" (not exact syntax, but very similar). Looking at available Java Console extensions on the Firefox page, I do not see Java Console 6.0.17 or 6.0.18, or even the one I currently have, 6.0.13. All I find is 6.0.01 and 6.0.02. And when I install those, I get a message saying they are no longer supported and will be removed upon Firefox restarting...

Pretty strange; I don't know much about these arcane matters, so any response, in any depth of detail (the more the better) is welcome. Thanks.

Return to Firefox Support


Who is online

Users browsing this forum: alexo, Bing [Bot] and 13 guests