facebook friends missing profile pictures

User Help for Mozilla Firefox

Post Posted February 23rd, 2010, 3:58 pm

I use firefox and on my comp all the profile pictures are missing. What they post is, but not their pictures. I have been going to the live post 4 days now at the time specified and it is always closed.
When i use IE, all the pictures shoe up. Very disgusted with the entire experience and no one real person to ask or talk to. Can anyone help me please???


User avatar
Posts: 39774
Joined: October 18th, 2007, 1:45 pm
Location: Next door to the west

Post Posted February 23rd, 2010, 4:23 pm

First, if you click in the area where a picture should be in and right click, is "Block Images from..." check?
Second, does it happen in safe mode?
Post wrangler
"Given this sequence of events, the argument is like the thirteenth chime of a clock: you not only know it's wrong, but it causes you to wonder about everything you heard before. "


User avatar
Posts: 51631
Joined: July 18th, 2005, 3:25 am

Post Posted February 23rd, 2010, 4:25 pm

It is possible that you accidentally clicked the 'Block Images' item in the right click context menu while trying to save an image.
Check the image exceptions: Tools > Options > Content: Load Images: Exceptions
See ... tent+panel

A way to see if images are blocked is to click the favicon (Site Identification icon) on the left side of the location bar and click the "More Information" button.
This will open the Security tab of the Page Info window (also accessible via Tools > Page Info).
Go to the Media tab of that Page Info window.
Select the first image and scroll down though the list with the Down arrow.
If an image is grayed and there is a check-mark in the box Block Images from... then remove that mark to unblock the images from that domain.

See also ... o_not_load


Post Posted January 8th, 2011, 12:53 pm

I was having the same problem. You're right the images had gotten blocked somehow. Thanks so much.


Post Posted June 29th, 2011, 10:32 am

Went to Tools, Options, Conyent, Load Images - Exceptions. Discovered profile pics had been blocked (God knows how...). Solved the problem - thanks :)


Post Posted August 10th, 2011, 6:03 pm

WOW!!!!! Thank you soo much this fixed it! You are great! have a blessed day =D> :wink:


Post Posted September 19th, 2011, 8:55 am

Thanks very much. I found the problem under options like you said. Apparently I had accidentally blocked Facebook images.

vibino (INDIA)

Post Posted January 24th, 2012, 3:21 am

Thanks a lot...u r a blessing..muah :mrgreen:

Return to Firefox Support

Who is online

Users browsing this forum: Bing [Bot] and 10 guests