MozillaZine

Mac Favicons Missing on Bookmarks Toolbar

User Help for Mozilla Firefox
Don346354
Guest
 

Post Posted August 15th, 2010, 2:31 am

I recently installed Firefox on my mac and Favicons don't show up on the bookmarks toolbar. I often use favicons instead of text so this is a real problem. I read that the "Stylish" addon is supposed to work but people are reporting that it no longer works. Seems like a simple fix. Any ideas?

Gingerbread Man

User avatar
 
Posts: 7412
Joined: January 30th, 2007, 10:55 am

Post Posted August 15th, 2010, 3:04 am

Many people are clueless and have no idea what they're doing. How about you actually try the Stylish styles, and then post back only if they don't work?
http://userstyles.org/styles/5969
http://userstyles.org/styles/10169

andy2435
Guest
 

Post Posted August 15th, 2010, 6:25 am

How about I already did before the last Firefox update and now Stylish is crashing Firefox. Why the hell would something as simple as a favicon not show up by default in Firefox.

RobertJ
Moderator

User avatar
 
Posts: 9253
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 15th, 2010, 8:20 am

It does but not on a Mac until FF4. In the meantime I'm told this code placed in your userchrome.css will do it.

userchrome.css is here

/Users/<user_acct>/Library/Application Support/Firefox/Profiles/<random>.default/chrome/

If you don't have a userchrome.css use userchrome-example.css and follow the instructions.

Note that the code MUST BE BELOW THIS LINE

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

NOTE ALSO: I have not tested this. EDIT: I have tested after modifying the code slightly. It works but only provides bookmark icons. I would guess that by playing around with the CSS you could get it to show text for a bookmark folder and an icon for an actual bookmark. However I don't have the time.

Code: Select all
.bookmark-item > .toolbarbutton-icon {
    display: -moz-box ! important;
    background-position: 0px 1px !important;
    padding-right: 3px ! important;
}

.bookmark-item:hover > .toolbarbutton-icon {
    background: url("chrome://global/skin/toolbar/toolbarbutton-customhover-mid.png") repeat-x;
    display: -moz-box ! important;
    background-position: 0px 1px !important;
    padding-right: 3px ! important;
}

.bookmark-item[container]:hover:active > .toolbarbutton-icon,
.bookmark-item[container][open="true"] > .toolbarbutton-icon {
    background: url("chrome://browser/skin/bookmark-open-mid.png") repeat-x !important;
}

.bookmark-item[container] > .toolbarbutton-icon { display: none ! important }

.bookmark-item[image] > .toolbarbutton-icon {
    display: -moz-box ! important;
    background-position: 0px 1px !important;
    padding-right: 3px ! important;
    float:right !important;
}

 .bookmark-item  .toolbarbutton-text {
  display: none !important;
  }


EDIT: In case you are wondering I found the info here.

.
FF 39.0 - FF 40.0b9 - FF42.0a - TB 38.1 - TB 40.0b1 - TB 41.0a - Mac OSX 10.10.4 Quad-Core Intel Xeon 5500
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2015

Gingerbread Man

User avatar
 
Posts: 7412
Joined: January 30th, 2007, 10:55 am

Post Posted August 15th, 2010, 12:44 pm

andy2435 wrote:Stylish is crashing Firefox.

That's okay, you don't need it. Stylish only offers a more convenient way to edit userChrome.css and userContent.css. Please note that the filename is case-sensitive (and RobertJ improperly capitalized it twice).
andy2435 wrote:Why the hell would something as simple as a favicon not show up by default in Firefox.

I believe the developers were trying to give Firefox a more native Mac appearance (i.e. make it more like Safari).

RobertJ
Moderator

User avatar
 
Posts: 9253
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted August 16th, 2010, 11:06 am

OK. Had a chance to play around with this. This code added to userchrome.css

Code: Select all
 /* This allows bookmark favicons on the bookmark toolbar */
 
.bookmark-item > .toolbarbutton-icon {
    display: -moz-box ! important;
    background-position: 0px 1px !important;
    padding-right: 1px ! important;
}

/* Disable this rule to see folder icons for containers */
.bookmark-item[container] > .toolbarbutton-icon {
    display: none ! important
}

.bookmark-item:hover > .toolbarbutton-icon {
    background: url("chrome://global/skin/toolbar/toolbarbutton-customhover-mid.png") repeat-x;
}

.bookmark-item[container]:hover:active > .toolbarbutton-icon,
.bookmark-item[container][open="true"] > .toolbarbutton-icon {
    background: url("chrome://browser/skin/bookmark-open-mid.png") repeat-x !important;
}



will on the bookmarks toolbar

  1. Show the names of bookmark folders without icons
  2. Will show the icons only of bookmarks

like this
Image

Note: to remove the name from the bookmark icon simply leave the Name: field blank in the bookmark properties.

.
FF 39.0 - FF 40.0b9 - FF42.0a - TB 38.1 - TB 40.0b1 - TB 41.0a - Mac OSX 10.10.4 Quad-Core Intel Xeon 5500
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2015

still confused
Guest
 

Post Posted September 3rd, 2010, 7:54 am

Thanks RobertJ for taking the time to try to solve this problem, and I am sure your comments are all well and good for those who have a clue what code is and how to manipulate it. But is there no obvious way to get favicons to display on the FF bookmarks toolbar? I have tried all the suggestions I've read online and still nothing. And my brother tediously runs FF on his PC and the favicons display without problem - as I once did - and now I have him scoring geek points...

Gingerbread Man

User avatar
 
Posts: 7412
Joined: January 30th, 2007, 10:55 am

Post Posted September 3rd, 2010, 8:24 am

  1. Open the Help menu and choose Troubleshooting Information.
  2. Click the Show in Finder button.
  3. Close Firefox, either by opening the Firefox menu and choosing Quit Firefox or right-clicking the dock icon and choosing Quit.
  4. Back in the Finder window, you'll probably see a single folder. Open it, then open the chrome subfolder.
  5. If there is no userChrome.css file, right-click userChrome-example.css and choose Duplicate. Change the copy's name to userChrome.css
  6. Open userChrome.css with TextEdit.
  7. Scroll up to RobertJ's post, click the Select All link and copy the text to the clipboard.
  8. Back in TextEdit, paste the text at the bottom, then save and close the file.

no longer confused
Guest
 

Post Posted September 3rd, 2010, 9:13 am

Many thanks. This has worked fine.

RobertJ
Moderator

User avatar
 
Posts: 9253
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted September 3rd, 2010, 9:19 am

:D
FF 39.0 - FF 40.0b9 - FF42.0a - TB 38.1 - TB 40.0b1 - TB 41.0a - Mac OSX 10.10.4 Quad-Core Intel Xeon 5500
Computers I've used: IBM 7094/UNIVAC 1108/IBM 360/DEC PDP11/DEC VAX-11 780/DEC VAXstation 8000/Sun SPARCstation 2/Mac from 1984 to 2015

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], redwolfe_98 and 24 guests