MozillaZine

what the heck is superfish??

User Help for Mozilla Firefox
James
Moderator

User avatar
 
Posts: 27654
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted February 1st, 2011, 4:42 pm

Denkzettel wrote:Foxlingo added this x in the last update! Beware.

We know if you read the previous posts mentioning this.

pbo_06
Guest
 

Post Posted February 1st, 2011, 6:44 pm

Well I was using "Similar web" Add-on and that was the reason why I had the same problem, every time I wanted to go to the home, the browser started opening http://www.superfish.com. I just uninstaled the add-on and that was the solution.

nnvee
Guest
 

Post Posted February 2nd, 2011, 4:01 pm

not sure what it is aside from being adware and annoying but the firefox addon "NoScript" blocks it unless u choose not too. some help i hope sorry for u IE users. worth a try for firefoxerz. :?: #-o =D>

nnvee
Guest
 

Post Posted February 2nd, 2011, 4:05 pm

ON SEEING A PREVIOUS POST, i TOO HAD RECENTLY UPDATED "fOX lINGO" COULD BE THE CULPRIT??

mariacanet
Guest
 

Post Posted February 3rd, 2011, 5:16 pm

galeward wrote:I just had an update for FoxLingo install on Firefox yesterday and Superfish showed up after that. Thank goodness for NoScript!

I got rid of the fishy by selecting FoxLingo Options->Main->then Deselecting 'Enable translated price comparison and currency conversion into [currency] (Powered by SuperFish)'. I wonder how many other add-ons this thing has attached itself to. [-X


Thanks a lot . That's one of the reasons why Superfish showed up as loading in my default home page. Will go on investigating.
Again : Thank you .

Iconoclast_usually
 
Posts: 9
Joined: July 10th, 2005, 11:50 am

Post Posted February 12th, 2011, 5:04 am

This stupid bit of overhead didn't show up until I had a spam msg to an eMail acct which I never post "in public." This was deleted w/o opening (see Mailwasher Pro for a sweet app to scrutinize eMail right on the server). Perhaps FoxLingo loaded SuperFish and the latter opened my sys to the spam? IAC, as others have noted, NoScript blocks it.

saurabhsmarty
Guest
 

Post Posted February 21st, 2011, 11:10 pm

snapster wrote:If you have the IETab plus addon, check its settings, if you select anything but basic mode, it will add the price comparison. I guess this is the root cause


ya this one is right ans :D
thanks...

OzPete
Guest
 

Post Posted February 22nd, 2011, 1:43 pm

mariacanet wrote:
galeward wrote:I just had an update for FoxLingo install on Firefox yesterday and Superfish showed up after that. Thank goodness for NoScript!

I got rid of the fishy by selecting FoxLingo Options->Main->then Deselecting 'Enable translated price comparison and currency conversion into [currency] (Powered by SuperFish)'. I wonder how many other add-ons this thing has attached itself to. [-X


Thanks a lot . That's one of the reasons why Superfish showed up as loading in my default home page. Will go on investigating.
Again : Thank you .


Thanks galeward, identified Foxlingo as culprit, one click and it stopped 'superfish' (fingers crossed) or at least identified how i got it!

Thanks to others on thread for exploring what was going on here...first post, quick answer...cheers

AK49BWL
Guest
 

Post Posted February 22nd, 2011, 6:14 pm

Firefox 3.5.16 on Windows 7, I noticed this as well, NoScript kept showing Superfish no matter what page.. even about:blank! So I knew it had to be an addon, and lo-n-behold, it was FoxLingo... The way I fixed it, you don't have to remove FoxLingo. Just remove the file named "nsSuperfishComponent.js" in the Firefox profile ( C:\Users\%username%\AppData\Roaming\Mozilla\Firefox\Profiles\{string}.default\extensions\{ef62e1ce-d2a4-4cdd-b7ec-92b120366b66} (the big string after \extensions\ may be different, just use Windows Search for "superfish" and select Look in File Contents)).. Restart browser, and bam, no more superfish. Tho I'm tempted to get rid of FoxLingo as well, as I REALLY don't like stuff getting added to my machine without me telling it to, and FoxLingo doesn't tell you anything about it upon installing.

J_Fix
Guest
 

Post Posted February 25th, 2011, 1:01 pm

[quote="Guest"]I mistakenly associated AdBlock Plus with Superfish. It was the latest version of IE Tab plus that added Superfish. There are three options for setup. Two contain price comparison. I chose "Basic" and got rid of Superfish.

Confirmed. I only had to deselect the "price comparison" option and it is gone.

Thnx,
Joop.

Jim Somebody
Guest
 

Post Posted March 2nd, 2011, 12:14 pm

bad name. might as well call it "superphish" for the impression it leaves. I'm not saying there's any phishing happening; I'm just saying it's a really poor choice of name for anything offered online.

cheryldon
Guest
 

Post Posted March 7th, 2011, 1:07 pm

edit your host file on your computer and add:

127.0.0.1 http://www.superfish.com
127.0.0.1 superfish.com

This won't remove superfish, it just will block it.

This also seems to speed up your browser for some reason :D

sdjkfklsad;jf;
Guest
 

Post Posted March 15th, 2011, 9:21 am

snapster wrote:If you have the IETab plus addon, check its settings, if you select anything but basic mode, it will add the price comparison. I guess this is the root cause


This worked for mine! I hate that stuff! If I want a feature, I'll turn in on. Don't turn it on for me!

Tez_B
Guest
 

Post Posted March 15th, 2011, 7:17 pm

On my Firefox 4.0/Mac installation Converter 1.0.0 was the culprit. Tracked it down to a preference checkbox.

I'm not 100 per cent certain that Converter itself was to blame, though. The add-on's developer is insistent that by default the pref is unchecked, and I first noticed the pop-ups happening after Firefox was updated from beta to the 4.0RC.

tjarvis
Guest
 

Post Posted March 24th, 2011, 8:53 am

To get rid of "super fish" go to my computer, c drive, programs. Go to the Surf Canyon folder, open it and uninstall.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests