MozillaZine

FF defaults to manual proxy: 127.0.0.1

User Help for Mozilla Firefox
greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 11th, 2010, 10:38 am

This is requiring me to manual change the setting every time I start FF after a reboot. I did some searching on this but didn't find the exact problem, and the directions were too vague. What I need to know is how to change the default setting back to "no proxy". In the threads I found, it seems as several people were trying to do the opposite. Please point me to the right thread if available. Thanks.

Anonymosity
 
Posts: 8141
Joined: May 7th, 2007, 12:07 pm

Post Posted December 11th, 2010, 3:52 pm

Do you have a user.js file in your profile? That could be doing that.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 11th, 2010, 7:46 pm

Anonymosity wrote:Do you have a user.js file in your profile? That could be doing that.


I'm not sure what that is. I know about the settings in "about:config" and thought that's where I would change a parameter. Looked in Program Files>Firefox for a "user.js" file. Not finding it there.

James
Moderator

User avatar
 
Posts: 25487
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted December 12th, 2010, 1:29 am

The user.js file will be in your Profiles, not in the Program folder as the Profile there is just a template and not the real Profile. You need to be able to view hidden folders/files. The user.js file does not exist by default.

http://kb.mozillazine.org/user.js_file
http://kb.mozillazine.org/Profile_folder_-_Firefox
(*.mozillaZine.org is not Mozilla!)
The Complaint Department at Mozilla (current complaints) (<It is not a real complaint site but for jokes/testing of bugzilla).
The Complaint department link is borked until unknown time.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 12th, 2010, 9:44 am

Found a user.js. Here's the contents:

user_pref("network.cookie.cookieBehavior", 0);
user_pref("privacy.clearOnShutdown.cookies", false);
user_pref("security.warn_viewing_mixed", false);
user_pref("security.warn_viewing_mixed.show_once", false);
user_pref("security.warn_submit_insecure", false);
user_pref("security.warn_submit_insecure.show_once", false);


Nothing about a proxy, however. I believe that it was malware that created this file. The malware was previously taken care of. Should I delete the file anyways?

Anonymosity
 
Posts: 8141
Joined: May 7th, 2007, 12:07 pm

Post Posted December 12th, 2010, 12:20 pm

If you did not make that file, you might as well delete it. I have a user.js file that I use to preserve my settings, but I made that one myself.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 13th, 2010, 9:37 pm

Ok, file deleted. Still have the manual proxy issue.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 14th, 2010, 8:37 am

Any ideas? Is there something I can change in "about:config"?

Anonymosity
 
Posts: 8141
Joined: May 7th, 2007, 12:07 pm

Post Posted December 14th, 2010, 12:01 pm

Is it the http port that gets changed? You could try looking for these lines in the prefs.js file with:
network.proxy.http
network.proxy.http_port
Delete those lines if you find anything there and then reset the setting in the Options to "no proxy" for http. I am thinking that maybe there is a corrupted line in the prefs.js file, and that this would correct it.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 14th, 2010, 6:36 pm

Guess I did not explain the problem well enough. Under Advanced>Network>Settings tab where it says "Configure Proxies to Access The Internet" the default setting every time I restart FF is "Manual proxy configuration" which requires me to open up the settings and change it back to the default (I'm assuming) "No proxy" setting in order to surf the internet. Am I right thinking that default should be "No proxy"?
Anonymosity wrote:Is it the http port that gets changed?


The proxy gets automatically changed to the HTTP Proxy: 127.0.0.1 port 50370

As far as the prefs.js file I deleted it and restarted FF. I rechecked in the profiles folder and it didn't come back some how. It's gone for good; just like it should have. No file to work with, obviously.

Anonymosity
 
Posts: 8141
Joined: May 7th, 2007, 12:07 pm

Post Posted December 15th, 2010, 2:35 pm

When you restart Firefox after removing the prefs.js file, Firefox will make a new one if you change any settings away from the defaults. Some extensions also put their settings into prefs.js.
Just out of curiosity, what is YFF35? It is in your user-agent.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 23rd, 2010, 3:44 pm

Anonymosity wrote:Just out of curiosity, what is YFF35? It is in your user-agent.


I have no idea what that is. Never heard of it.

greggery
 
Posts: 9
Joined: April 20th, 2005, 12:07 pm

Post Posted December 26th, 2010, 4:28 pm

Anonymosity wrote:Is it the http port that gets changed? You could try looking for these lines in the prefs.js file with:
network.proxy.http
network.proxy.http_port
Delete those lines if you find anything there and then reset the setting in the Options to "no proxy" for http. I am thinking that maybe there is a corrupted line in the prefs.js file, and that this would correct it.



Ok, my mistake. I thought we were still talking about the "user.js" file, not the "prefs.js" file.

Here's a few lines from that:

user_pref("network.cookie.prefsMigrated", true);
user_pref("network.proxy.http", "127.0.0.1");
user_pref("network.proxy.http_port", 50370);
user_pref("network.proxy.no_proxies_on", "true");
user_pref("network.proxy.type", 0);

Anything unusual? Should I delete the file and restart?

dfoulkes

User avatar
 
Posts: 18340
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted December 27th, 2010, 8:26 am

I would "rename" those files and not delete them... so, rename it (or move it out) and then restart FF.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

KWierso
 
Posts: 8772
Joined: May 7th, 2006, 10:29 pm
Location: California

Post Posted December 27th, 2010, 8:59 am

Or make a backup copy of it elsewhere and just delete those "network.proxy.*" lines.

Return to Firefox Support


Who is online

Users browsing this forum: Pim and 31 guests