MozillaZine


How do you disable SmartScreen Filter in Mozilla Firefox?

User Help for Mozilla Firefox
VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 8th, 2011, 12:32 pm

Let's start with what has already been suggested.

Bematli
Guest
 

Post Posted January 8th, 2011, 1:09 pm

LIMPET235 wrote:Hi,
After searching high & low, I haven't found any answer as to how to remove it.

Best I came up with was to disable it in IE8.
Dunno.
Nothing that I could find on MS fora.

Maybe you should try a Google, subbing all the terms?

Just a thought...
Does this "Smart Screen" look the same in IE8 & Firefox?

I don't know, it only opens on Firefox since it's my default browser.

VanillaMozilla wrote:Bematli, you're adjusting Microsoft security settings and they give you instructions on how to do it with Microsoft software, right? If the instructions apply specifically to IE and only IE, can't you just use IE for this one task?

What do you mean?

combep wrote:I suspect the filter is actually turned on in live messenger and turning it off in IE won't help. Since it isn't part of Firefox you can't turn it off there either.

Without "hacking" the impression I got was that messenger forced you to use some antivirus program to scan links and files, so if you didn't configure it to use the one you already have, it required you to use a mini-antivirus provided by them combined with smartscreen. Switching it to use your own antivirus gets around that, or using another IM client which can still access the messenger network, or using a different IM network completely.

Then how do you switch the Anti-Virus of your MSN? I knew how to do this with the old MSN, but not with the new one. Also, I prefer using the real client, not some third-party program.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 8th, 2011, 2:01 pm

Maybe you need to start over with a screen shot that shows the problem.

Guest
Guest
 

Post Posted January 8th, 2011, 2:05 pm

It takes a few seconds to turn off smart screen in IE, that might fix it (although I don't think it will) start by trying that.
http://www.microsoft.com/security/filte ... creen.aspx

For further testing, you could then set your default browser to be IE temporarily. If links open without interference (after smartscreen is off), then some filter (plugin or extension) may have gotten in Firefox. If they still don't it is a messenger setting.

JHFORD
Guest
 

Post Posted January 9th, 2011, 10:21 am

DISABLE UR smart screen filter

JHFORD2005
Guest
 

Post Posted January 9th, 2011, 10:23 am

DISABLE THIS S.O.B.

Glav
Guest
 

Post Posted January 9th, 2011, 1:51 pm

With this addon : https://addons.mozilla.org/fr/firefox/addon/5064/
Then you click on Tools -> Extensions -> Redirector -> [Options]
You Add a new redirection, with :

Example URL = http://link.live.net/?l=http%3a%2f%2fwww.foo.com%2fbar%2f&h=itWsyZHjrlEFsiwF88uQrxzR07adAQGROv79wRiLd%2fs%3d&p=1
Include Pattern = http://link.live.net/?l=*&h=*
Exclude Pattern =
(leave it blank)
Redirect to = $1
Pattern type = wildcard
Unescape matches = checked

Guest
Guest
 

Post Posted January 12th, 2011, 9:29 pm

I'm having the same problem for Chrome. I don't use IE at all but if someone sends me a link through the Windows Live Messenger the smartscreen filter will come up and warn me about the website. I don't think I would really care very much if it would work when I clicked continue. Whenever I do, however, it only sends me a logo of the website and not the actual link.

It really annoys me and I've tried to find every way to remove it. Internet Options in IE doesn't even come up with SmartScreen as a filter and I don't believe I have it for Chrome.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 12th, 2011, 10:11 pm

Glav, I'm not so sure about that. Do you know what the actual problem is? Can you describe it for us? If not, you don't solve a problem that might be caused by an add-on, by adding yet another add-on.

LIMPET235
Moderator

User avatar
 
Posts: 39429
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 12th, 2011, 10:14 pm

Seems that a few are not happy with IE interfering with Firefox, again......or is it AVG or any security app?
> http://support.microsoft.com/search/def ... 081&mode=r


[edit]
How to post screen shots > http://kb.mozillazine.org/Posting_a_scr ... _the_forum
Please keep them ~600 x 400 or so, or just paste the Forum Thumbnail URL link.
[/edit]
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-79.0-93.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 12th, 2011, 10:22 pm

OK, I think I get it. The OP is using Windows Messenger, which sometimes triggers warnings about bad Web sites, etc. via a MS feature called SmartScreen. SmartScreen opens an advisory Web site as a warning, using the default browser, which in the is case is Fx.

So if you don't want SmartScreen, Bernatti, your task is to turn it off. I don't think this is a Firefox problem in any way.

At least I think that's what's going on. But I quit, since Bernatti has not posted any details or screen shots or even a reference to the guides that he found. Not a Firefox problem, as far as I can tell. Good luck.

Scorzonera

User avatar
 
Posts: 562
Joined: May 14th, 2004, 1:31 am

Post Posted January 13th, 2011, 12:47 am

Looks like there's a GreaseMonkey (= a Firefox add-on) script to disable it.

Remove SmartScreen for Live Messenger 2011:
Script Summary:
Automatically open the requested website. Skips the confirmation page required on live messenger 2011. Removes the smartscreen from Live 2011.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 13th, 2011, 7:20 am

OK, here it is. From Microsoft, what it is and how to turn it off. Bernatti, read this and follow it. Also read my warning below.
Microsoft wrote:We strongly recommend that you use the Phishing Filter in Internet Explorer 7 or the SmartScreen Filter in Internet Explorer 8 or Internet Explorer 9 to protect your personal and financial information. To have us turn on the SmartScreen or Phishing filter for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.
Back to the top
Fix it for me

To turn on the SmartScreen or Phishing filter automatically, click the Fix this problem button or link. Then click Run now in the Automated Troubleshooting Services page and follow the steps in this wizard.

Fix this problem
Microsoft Automated Troubleshooting Services: Diagnose and fix Windows security problems automatically
Back to the top
Let me fix it myself
To turn on the SmartScreen or Phishing filter yourself, follow these steps:

1. Close all Internet Explorer windows.
2. Open a new Internet Explorer window.
3. When you see the message that states that the "HP Smart Web Printing add-on can cause Internet Explorer to crash or to stop responding," click Always open Internet Explorer without this add-on.

Was this information helpful? Please send us your feedback


Windows Internet Explorer 9

To turn the SmartScreen Filter on or off, follow these steps:

1. Click the Tools icon, and then click Safety.
2. Click one of the following items:
* Turn On SmartScreen Filter
* Turn Off SmartScreen Filter

3. In the Microsoft SmartScreen Filter dialog box, select one of the following items, and then click OK:
* Turn on SmartScreen Filter (recommended)
* Turn off SmartScreen Filter

Internet Explorer 8

To turn the SmartScreen Filter on or off, follow these steps:

1. Start Window Internet Explorer 8.
2. On the Safety menu, point to SmartScreen Filter, and then click one of the following:
* Turn On SmartScreen Filter
* Turn Off SmartScreen Filter
3. In the Microsoft SmartScreen Filter dialog box, click one of the following, and then click OK:
* Turn on SmartScreen Filter (recommended)
* Turn off SmartScreen Filter

For more information about the SmartScreen Filter, visit the following Microsoft Web site:
https://smartscreen.microsoft.com/faq.aspx (https://smartscreen.microsoft.com/faq.aspx)
Internet Explorer 7

To turn the Phishing Filter on or off, follow these steps:

1. Start Windows Internet Explorer 7.
2. On the Tools menu, point to Phishing Filer, and then click Turn On Automatic Website Checking or Turn Off Automatic Website Checking.
3. Confirm the selection, and then click OK.

For more information about the Windows Internet Explorer 7 Phishing Filer filter, visit the following Web site:
http://www.microsoft.com/athome/securit ... ilter.mspx (http://www.microsoft.com/athome/securit ... ilter.mspx)
If you suspect that you have been a victim of fraud, visit the following Web site:
http://www.microsoft.com/protect/yourse ... emedy.mspx (http://www.microsoft.com/protect/yourse ... emedy.mspx)

If you're going to use Microsoft security tools, then you have to use them. If you don't want them, turn them off. But if you receive a warning and then choose to ignore it, you're on your own. If thieves break into your computer and silently steal your banking passwords, no computer support forum can repair the damage.

Scorzonera

User avatar
 
Posts: 562
Joined: May 14th, 2004, 1:31 am

Post Posted January 13th, 2011, 10:23 am

@ VanillaMozilla:
Problem is; all that will not work for Windows Live Messenger 2011 users.
The OP will still receive these smartscreen messages within Firefox, because they are generated by WLM 2011 and it cannot be turned off (except for the workaround I posted earlier).

Settings made in IE will have no influence on it, at all. It is a WLM 2011 thingy.

See also:
Live Messenger and the "link harvesting black box in the sky", for some fun reading about this.

VanillaMozilla
 
Posts: 13808
Joined: November 7th, 2005, 11:26 am

Post Posted January 13th, 2011, 10:35 am

Argh. I see. Sounds like a Microsoft WLM problem. I'm fortunate I don't worry about those any more. Maybe he could totally remove whatever program/widget/demon/virus/OS causes it. That seems to be WLM.

Or else he could figure that the warning might be correct, and ignoring it might affect his personal and financial future.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 7 guests