MozillaZine

WAV files truncated when playing inside Firefox

User Help for Mozilla Firefox
dandrewk
Guest
 

Post Posted February 1st, 2005, 10:46 am

I have searched this forum, and haven't found anyone else with this problem:

When playing any .WAV file inside Firefox (QT 6.5.2), the file only plays about 10seconds and stops. The progress bar runs its full course, but the entire file never plays out. It happens at all websited, including the "test" one at the following:

http://forums.mozillazine.org/viewtopic ... 10#qtsetup

MP3's, MIDI all play their full course. The WAV file acts like it is only about 10 seconds long.

I don't have this difficulty within IE.

Please help! This makes accessing voicemail via Callvantage kinda useless.

Guest
Guest
 

Post Posted February 1st, 2005, 2:57 pm

Ok, I just tried a lengthy WAV file from my homepage, and if plays fine in Firefox.

The problem seems to be with Callvantage's website. The voicmail files (WAV format) will only play about 10 seconds in Firefox. In IE, they play fine.

Anybody else experience this with Callvantage or any other website? Any workarounds?

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 1st, 2005, 3:00 pm

I've heard this same complaint about truncated .wavs with Quickie Time. I'm using Winamp to play those .wavs. No problems. I've also played a file successfully with Winamp that QT users were unable to get working. Associate to Winamp!

rtmjr50

User avatar
 
Posts: 6318
Joined: August 2nd, 2004, 5:06 pm
Location: Raleigh, NC USA

Post Posted February 1st, 2005, 3:02 pm

Anonymous wrote:Ok, I just tried a lengthy WAV file from my homepage, and if plays fine in Firefox.

The problem seems to be with Callvantage's website. The voicmail files (WAV format) will only play about 10 seconds in Firefox. In IE, they play fine.

Anybody else experience this with Callvantage or any other website? Any workarounds?


sounds like thay are using some IE coding that works only with IE ... have you tried to contact customer support .... bet you the answer is works in IE ...

later, Richard
Rule #1: My computer is always right, the human is always the problem .. RULE #2: See Rule #1
using Win XP/SP2 (home) FF1.5.0.9 FF2.0.0.1 FF3a1 Tbird1.5.0.9 ==> Press for More Answers <==
No colours in sig please.

dandrewk
Guest
 

Post Posted February 1st, 2005, 3:19 pm

FatJohn wrote:I've heard this same complaint about truncated .wavs with Quickie Time. I'm using Winamp to play those .wavs. No problems. I've also played a file successfully with Winamp that QT users were unable to get working. Associate to Winamp!


I have winamp, QT, Windows media, iTunes, Creative Media player... etc.

How do I associate WAV within Firefox to use something besides the Quicktime plug-in?

Thanks for your help!

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 1st, 2005, 3:36 pm

Yep.

dandrewk
Guest
 

Post Posted February 1st, 2005, 4:01 pm

Are there any other Firefox plugins that will play .WAV, or is there some way that I can force a WAV link within Firefox to launch an external player?

old FatJohn
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted February 1st, 2005, 4:28 pm

<Long Shot In Pitch Black>
One thing you might want to fool around with is your mimetypes.rdf in your profile folder. You might want to edit it and remove references to wav or maybe even rename (~delete) the mimetypes.rdf file.
</Long Shot In Pitch Black>

dandrewk
Guest
 

Post Posted February 1st, 2005, 9:50 pm

jrzycrim wrote:Not any of which I'm aware. I was thinking you could disable the quicktime plugin and enable the default plugin which should try to download and play the wav in the associated player. I couldn't get it to work for me although I remember it working in the past. Maybe not for wav files though... Anyway, if you want to try it:

Enter about:plugins in the address bar
Enter plugin.default_plugin_disabled in the filter field at the top
Double click on that setting to toggle it to false.
Close Firefox
Launch Quicktime
Go to Edit > Preferences > Quicktime Preferences
Select "Browser Plugin" in the drop-down at the top
Click Mime Settings
Uncheck Wave under Audio
Click OK
Restart Firefox.


That did the trick! Thanks!

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], Steve2526 and 21 guests