MozillaZine

After updating- ff4 bookmark folder icons disappeared [Linux

User Help for Mozilla Firefox
Wasser
Guest
 

Post Posted March 28th, 2011, 9:46 am

Hi, I have updated 3 different computers to firefox 4, and in all of them, the folders' icons in my bookmarks disappeared. everything is functional and newly created folder have the same problem.

If I click in 'Show All Bookmarks', in the window where it displays the bookmarks, the icons appear just fine. It's just in the bookmarks' menu and bookmarks' toolbar that the problem appears.

System info:
-All the systems are synced using Mozilla Sync AND XMarks
-All the systems are Ubuntu
-Version 4.0 final

Thanks for the help
Last edited by LoudNoise on April 1st, 2011, 1:11 pm, edited 1 time in total.
Reason: Added Linux to title

tankzt
Guest
 

Post Posted April 1st, 2011, 1:08 pm

I have the same problem. Anyone know how to fix it? I'm running Ubuntu 10.10 32-bit.

Anonymosity
 
Posts: 8573
Joined: May 7th, 2007, 12:07 pm

Post Posted April 1st, 2011, 11:01 pm

You mean that there are no folder icons at all in the menu? What happens if you use a third-party theme? Why would there not be folder icons? That helps distinguish folders from single bookmarks.

Wasser
Guest
 

Post Posted April 4th, 2011, 7:51 am

I didn't try that... but what I can tell you is that one of the versions affected is the Ubuntu Netboox Remix, which supposedly uses a different theme...

tankzt
Guest
 

Post Posted April 4th, 2011, 7:59 am

That's correct. Even with another theme the icons are still missing. I also don't see any icons next to the items in the Firefox menu.

jimmydean123
Guest
 

Post Posted April 9th, 2011, 6:03 am

If you go to System - Preferences - Appearance then click on the Interface tab, check "Show Icons In Menus" then restart Firefox. It worked for me on Ubuntu 9.10

Wasser
Guest
 

Post Posted April 11th, 2011, 10:25 am

jimmydean123 wrote:If you go to System - Preferences - Appearance then click on the Interface tab, check "Show Icons In Menus" then restart Firefox. It worked for me on Ubuntu 9.10

Hi, I tried, but in ubuntu 10.10 there isn't a tab in the appearance window called "Interface" and I couldn't find the option "Show Icons In Menus" in the other tabs :/

Any other ideas?

Grumpus

User avatar
 
Posts: 12296
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 11th, 2011, 11:27 am

Could be jimmydean was referring to the Ubuntu /System/Preferences/Appearance.
There are control there for the showing of icons or text or icons and text.

Also you could make sure both Navigation and Bookmarks Toolbars show under /View/Toolbars as checked and right click on either one and hit the "Customize" button or panel.
The Customize panel should pop up and give you the option to show Icons Only; Text Only or both together.
You can also alter the size of the icons. I believe this setting goes down a level or so.
Last edited by Grumpus on April 11th, 2011, 12:04 pm, edited 2 times in total.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

jimmydean123
Guest
 

Post Posted April 11th, 2011, 11:59 am

Yeah, sorry. I meant the Ubuntu System menu. I haven't used 10.10 but the Icon settings are also found in gconf-editor. I don't know exactly where though.

Grumpus

User avatar
 
Posts: 12296
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 11th, 2011, 12:03 pm

I editied the above post - re read and see if that applies as well.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

jimmydean123
Guest
 

Post Posted April 11th, 2011, 12:08 pm

I am at work so I can't check this but according to this site http://forums.debian.net/viewtopic.php? ... 79#p303221 if you run gconf-editor, the settings should be at desktop > gnome > interface.

Grumpus

User avatar
 
Posts: 12296
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 11th, 2011, 12:26 pm

You can double check the settings underneath of Gconf editor. It's helpful to do that but it's better to perform the settings in the software and afterwards check to see if the change takes effect in the Gconf editor. Both Firefox and Ubuntu appearance are pipelined into the Gconf Editor if everything is properly done. One of the reasons it's suggested to use the Ubuntu repositories instead of some of the alternative methods of software installation.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

Wasser
Guest
 

Post Posted April 14th, 2011, 9:54 am

Ok, so I changed the option "Show Icons in Labels" in Gconf-editor ( there is not such an option in the appearance window in ubuntu 10.04...)
I restarted the computer. but nothing changed.

powerfool
 
Posts: 12
Joined: May 16th, 2005, 3:41 pm

Post Posted April 17th, 2011, 2:47 am

Open the gconf-editor and go to desktop -> gnome -> interface -> menus_have_icons
and enable that. That should fix it.
However,
I still don't like this behaviour because I don't want to have icons in all the menus of GNOME, I just want icons at the bookmarks menu of Firefox 4. In Firefox 3 you didn't need to do this to have icons in this menu, and it was better this way.

If you want to see what is it like to not have icons in the bookmarks menu of FF4 check out this link, I posted a screenshot: http://img861.imageshack.us/img861/3120/tooltip003.png

Ugly isn't it?

Wasser
Guest
 

Post Posted April 17th, 2011, 9:59 am

powerfool wrote:Open the gconf-editor and go to desktop -> gnome -> interface -> menus_have_icons
and enable that. That should fix it.
However,
I still don't like this behaviour because I don't want to have icons in all the menus of GNOME, I just want icons at the bookmarks menu of Firefox 4. In Firefox 3 you didn't need to do this to have icons in this menu, and it was better this way.

If you want to see what is it like to not have icons in the bookmarks menu of FF4 check out this link, I posted a screenshot: http://img861.imageshack.us/img861/3120/tooltip003.png

Ugly isn't it?



Thanks, it worked. For now I don't see too many changes in other applications, but I guess I will have to restart Ubuntu to check

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 15 guests