MozillaZine

How do I disable FF5 tab resize behaviour?

User Help for Mozilla Firefox
rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted September 17th, 2011, 12:28 pm

BruceAWittmeier wrote:Im not trying to be argumentative, but with this code in your userChrome.css file and the property you suggested above to be set false and the min-width and max-width set the same in TMP, I believe this works as desired.

/* remove the left / right arrow on the scroll bar */
.tabbrowser-tabs .scrollbutton-up, .scrollbutton-down
{
/* visible is default so without this code they will show */
visibility: hidden !important;
}


/* Show the arrows but gray when not needed */
.tabbrowser-arrowscrollbox
{
visibility: visible !important;
}

This makes a constant tab width, arrows are only present when there is overflow and the space for the arrows is retained even when there is no overflow. You can open tabs to overflow, click 1 place on any of the first few tabs without moving the mouse and close them all until you are below the tab you are closing with the 'X'.


I tried the code above and yes it works well at making the tabs width constant when not in "Tab Overflow Mode" and also places empty spaces on the far left and right ends the tab bar in either regular or tab overflow mode, which in my opinion looks odd. Your above CSS code doesn't disable the resizing tab close behavior of bug 465086 : Try the 'STR' in my above post while using your CSS code and you'll see what I'm talking about. If you use my style above and set about:config pref: browser.tabs.animate; set to false, it disables all tab animations, except 'Smoothscroll wheel tab animations' when in "Tab Overflow Mode" which can be disabled using about:config pref: toolkit.scrollbox.smoothScroll; set to false.

BruceAWittmeier

User avatar
 
Posts: 2645
Joined: June 9th, 2008, 10:53 am
Location: Near 37.501685 -80.147967

Post Posted September 17th, 2011, 12:34 pm

Even in overflow, the tabs were constant width for me when I set the min-width and max-width the same in TMP. Did you do that?

I suspect there is a way to avoid the spaces at the end of the tab bar area too, but I dont know what that is. Havent got there yet...still on the uphill side of the learning curve :)
~ I'm only here to Pay it Forward. ~

"I often take a very long windy road to my destination. When I arrive I often wonder how I missed the shortcut".

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted September 17th, 2011, 12:52 pm

BruceAWittmeier wrote:Even in overflow, the tabs were constant width for me when I set the min-width and max-width the same in TMP. Did you do that?
Yes, What I meant to say is that your CSS code alone doesn't have the same constant close tab behavior when you compare it in regular and "Tab Overfolw Mode" you close a tab in regular mode the tab width snaps back to fill the tab bar instantly while in "Tab Overflow Mode" closed tab width doesn't snap back instantly the tab width only snaps back to fill tab bar when the mouse cursor leaves the tab bar, which is caused by bug 465086 and my style above disables.

BruceAWittmeier wrote:I suspect there is a way to avoid the spaces at the end of the tab bar area too, but I dont know what that is. Havent got there yet...still on the uphill side of the learning curve :)

TMP has the option to remove/hide the scroll buttons while in "Tab Overflow Mode", so the use of your CSS code isn't required. (TMP Options > Display > Tab Bar > When tabs don't fit width: Scrollable without buttons)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests