MozillaZine

UTF-16 Encoding

User Help for Mozilla Firefox
IUsedToBeAnIdiot
 
Posts: 8
Joined: March 5th, 2005, 2:43 pm
Location: San Francisco

Post Posted March 5th, 2005, 3:03 pm

I have set firefox to auto-detect unversal encoding. Now, Firefox has a habit of reading a page in UTF-16 when it only appears correctly in UTF-8. Sometimes, firefox displays things in ISO-8859-1 when it would display just as well in UTF-8, while universal is its auto-detect mode.
- IUsedToBeAnIdiot -

monkeyman
 
Posts: 1183
Joined: April 2nd, 2003, 11:07 pm

Post Posted March 5th, 2005, 3:10 pm

When you do that you have a bunch of things working against you. Unicode detection in Firefox isn't all that great, both Windows 2000 and Windows XP have cobbled together unicode font support that sometimes goes awry for no particular reason and then you have pages with broken or missing headers. Because of those factors, it's not a great idea to rely on auto-detection for UTF fonts.

IUsedToBeAnIdiot
 
Posts: 8
Joined: March 5th, 2005, 2:43 pm
Location: San Francisco

Post Posted March 10th, 2005, 9:14 am

I have disabled auto detect and have selected UTF-8 as my encoding method. I have also removed UTF-16 from the active encoding list. But when I use Firefox, UTF-16 is STILL selected by default, and when I change the seting to UTF-8, it pops back to 16 when I go to the next site! Its very annoying having to reset my encoding settings every time I go to a new URL.
- IUsedToBeAnIdiot -

monkeyman
 
Posts: 1183
Joined: April 2nd, 2003, 11:07 pm

Post Posted March 10th, 2005, 1:22 pm

Is that weird or what? Maybe one of these three settings are borked in about:config (I have included the default values):

network.standard-url.encode-utf8 false
network.standard-url.escape-utf8 true
prefs.converted-to-utf8 false

IUsedToBeAnIdiot
 
Posts: 8
Joined: March 5th, 2005, 2:43 pm
Location: San Francisco

Post Posted March 10th, 2005, 5:20 pm

how would I check those vlues? (what is about:config)?
- IUsedToBeAnIdiot -

monkeyman
 
Posts: 1183
Joined: April 2nd, 2003, 11:07 pm

Post Posted March 10th, 2005, 5:33 pm

Type about:config in the Urlbar (address bar) and type utf8 in the find field when about:config comes up.

IUsedToBeAnIdiot
 
Posts: 8
Joined: March 5th, 2005, 2:43 pm
Location: San Francisco

Post Posted March 10th, 2005, 8:21 pm

all of these settings are correct already. any other ideas?
- IUsedToBeAnIdiot -

monkeyman
 
Posts: 1183
Joined: April 2nd, 2003, 11:07 pm

Post Posted March 10th, 2005, 8:28 pm

Geeze, I was hoping that was it. I'm afraid I'm out of ideas, sorry. I guess it's down to the last resort and you'll have to backup your profile, delete the old one and start again. Profile Backup
:(

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], dfoulkes, Google Adsense [Bot] and 25 guests