MozillaZine

Google Search Results Redirect back to Google.com in FX7?

User Help for Mozilla Firefox
orvn
Guest
 

Post Posted September 27th, 2011, 6:13 pm

Video of the issue http://searchanddevelop.ca/dump/foxsearchredirect.mov

I've been having this issue with my Firefox 6.0.2 (now upgraded to 7, issue still persists) on OSX Lion 10.7.1.

When I go to Google, any search result I click on redirects me back to either the Google homepage or the same search results page I was on (effectively just refreshing the page).

If I open the search result in a new tab, then it loads the external site I click on, but only if I "open in new tab".

Worst of all, when I am redirected back to the Google homepage I can't even push the "back" button in my browser- on account of the AJAXified SERP data retrieval I guess.

When I google "Firefox Google search results redirect" I get a bunch of results pertaining to Windows users with malware issues- presumably these Windows users are being redirected to other sites.

But in my case it's redirecting back to Google.
AND I'm on OSX.

I haven't installed any new extension or themes in a long while. Not sure when the issue began because I've been using Chromium.

Suggestions anyone?

mbd35
Guest
 

Post Posted September 27th, 2011, 6:33 pm

Interesting.

I know that Google redirects search results through its site. See here: http://www.google.com/support/forum/p/Web%20Search/thread?tid=10e3b52855c4a37f&hl=en

The problem may have something to do with that. Maybe something got corrupted on your end so that you just wind up going back to Google rather than to the proper site. First try clearing all of your cookies. If that doesn't work then you might just want to completely uninstall then reinstall Firefox or try a new profile. http://support.mozilla.com/en-US/kb/Profiles

orvn
Guest
 

Post Posted September 27th, 2011, 6:41 pm

Thanks for the resources. Cookies and cache are cleared, issue still persists.
I suspect it must be something to do with Google instant, which I can't turn off >.<

New Firefox profile it is. Will report my findings.

mbd35
Guest
 

Post Posted September 27th, 2011, 6:43 pm

Do you use something called the "https everywhere" addon? Someone on a different thread suggested disabling that. http://www.google.com/support/forum/p/Web%20Search/thread?tid=4e89e212805a2132&hl=en

mbd35
Guest
 

Post Posted September 27th, 2011, 6:45 pm

You should be able to turn off google instant if you have cookies enabled and your browser isn't set to clear them after closing.

orvn
Guest
 

Post Posted September 27th, 2011, 7:07 pm

mbd35 wrote:Do you use something called the "https everywhere" addon? Someone on a different thread suggested disabling that. http://www.google.com/support/forum/p/Web%20Search/thread?tid=4e89e212805a2132&hl=en


I do use HTTPS everywhere!

OH MY GOODNESS IF THIS FIXES IT I WILL NAME MY FIRSTBORN AFTER YOU MBD35

orvn
Guest
 

Post Posted September 27th, 2011, 7:18 pm

orvn wrote:
mbd35 wrote:Do you use something called the "https everywhere" addon? Someone on a different thread suggested disabling that. http://www.google.com/support/forum/p/Web%20Search/thread?tid=4e89e212805a2132&hl=en


I do use HTTPS everywhere!

OH MY GOODNESS IF THIS FIXES IT I WILL NAME MY FIRSTBORN AFTER YOU MBD35


IT IS FIXED!

I am indebted to you for life mbd35.

If you are a woman; please, bear my children.

If you are a man; nothing would please me greater than engaging in profoundly enlightening travels with you for many years, during the course of which we share countless memories, experiences and lessons; emerging as better- more cognitively developed- humans.

mbd35
Guest
 

Post Posted September 27th, 2011, 7:22 pm

No problem.

"HTTPS Everywhere" has to do with security/encryption, right? Google must not want people to use that. Very suspicions.

Guest
Guest
 

Post Posted September 27th, 2011, 7:24 pm

mbd35 wrote:No problem.

"HTTPS Everywhere" has to do with security/encryption, right? Google must not want people to use that. Very suspicions.


Yes, it forces SSL encryption on all webpages that allow it making the whole internet experience much more secure.

Thanks again!

mbd35
Guest
 

Post Posted September 27th, 2011, 7:29 pm

The Ixquick search engine has an option to always use https. It's not quite as good as google though, except being better in terms of security. http://www.ixquick.com/do/preferences.pl?language_ui=english

Heck, you don't even need to enable cookies to save your settings with ixquick. That's an interesting feature.

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted September 27th, 2011, 7:30 pm

HTTPS Everywhere forces websites that offer an HTTPS connection to always use it. In an ideal world this would make sites more secure... actually in an ideal world all sites would already use an HTTPS connection, but that's beside the point. The result of forcing sites to use this kind of connection is that it can cause all kinds of problems if the entire site, or parts of it do not have that connection. In this case, I'm betting it's breaking the redirect process. I've also seen many cases where users are shown an Untrusted Connection warning for sites that have an HTTPS connection available, but don't actually have an encrypted version of their site, and therefore don't have their domains registered with a cert authority. While it seems like a clever idea, I think there are just too many downsides.

Edit: also Google has a fully secure website:
https://encrypted.google.com/
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

huyi82
 
Posts: 1
Joined: November 4th, 2011, 5:01 pm

Post Posted November 4th, 2011, 5:08 pm

i am having similar problem and i am using windows 7, ever since i installed firefox 4.0.1 and google toolbar i cannot do a websearch, everytime i enter a search term into the google toolbar it redirects me to igoogle, and even when i set my homepage as classic google it will redirect me to that, i have cleaned all related google cookies and turned off instant search but i still get the same problem, any ideas as to how i can restore my search box back to normal? i can't search anything because of this so i would really appreciate if someone out there had some idea what is going on.

searching in other browsers such a google chrome is completely fine, this problem is only isolated to firefox 4.

i have also disable google toolbar and tried to do a search term and i still get redirected so it's definitively not google toolbar that is causing the problem, it's firefox, i have no idea how to stop firefox from going to the homepage everytime i try to search for something, till i ever find a solution i have to use google chrome to search for anything now, it's inconvenient to have 2 browsers open but what else can i do?

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 8 guests