MozillaZine

Streaming Radio not Working in WMP, Firefox 7.x

User Help for Mozilla Firefox
Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 12:22 pm

Ever since upgrading to Firefox 7.0, I can no longer listen to internet radio stations that use Windows Media Player, ie: http://www.3wk.com. I'm currently using WMP v11 and the Windows Media Player plugin with Firefox 7.0.1. File associations for WMP are fine and local MP3 files play in WMP without problems.

Disabling my A-V program, firewall, and adblockers has no effect on the lack of streaming.

Any suggestions or advice?

...Thanks

Anonymosity
 
Posts: 8144
Joined: May 7th, 2007, 12:07 pm

Post Posted October 1st, 2011, 1:06 pm

Maybe it is something to do with Flash? I tried the 3 items at the top of the page (which are Flash), and heard nothing.

MarkRH

User avatar
 
Posts: 718
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 1st, 2011, 1:43 pm

The Windows Media Broadband links worked for me. FF7.0.1, WMP11 on Win XP/SP3 Sounded crappy.. but it did work.

Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 1:50 pm

When I click on any of the Windows Media or MP3 links on that site, I just see a black bar under the "Click here to see the last 20 songs" line, but no player. Everything worked fine in FF 6.0.

All above player links on 3WK currently work in IE8 on my PC. I have XP SP3 also.

MarkRH

User avatar
 
Posts: 718
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 1st, 2011, 2:23 pm

Just tried the MP3 link for the Classic Rock one and it worked fine for me. That site is kind of buggy though.. I've seen a few PHP errors being tossed out with some links.

Curious, does this show the media player and play the midi file for you: http://www.markheadrick.com/dvd/BennyHill.shtml

Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 2:31 pm

The Benny Hill link does the same thing in FF; just a black bar - no player or controls. It works in IE, though :?

MarkRH

User avatar
 
Posts: 718
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 1st, 2011, 2:43 pm

Is the Windows Media Player Plug-in Dynamic Link Library 3.0.2.629 listed in your plug-ins?

In Tools > Options > Applications

Are the Windows Media Audio/Video items set to use the Windows Media Player Plug-in Dynamic Link Library in Firefox?

Also, you're not blocking javascript from loading are you? I know on my site, a JavaScript file is used to configure the player and display it based on the browser being used.

Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 5:37 pm

Thanks for your assistance :)

Yes, the DLL library 3.0.2.629 is listed in enabled plugins.

All audio/video items in Tools > Options > Applications are using Windows Media Player except for .ogg, .3gx, .m4v, and .mp4 files, which are handled by the VLC plug-in. I don't see an actual reference to the DLL Library listed, though.

Javascript is enabled.

MarkRH

User avatar
 
Posts: 718
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 1st, 2011, 6:00 pm

So, this is not showing in Applications?

Image

If not, might want to download and re-install the WMP plug-in: http://www.interoperabilitybridges.com/ ... n-download

Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 6:28 pm

Not exactly - this is what I have:

Image

I tried to re-install the Firefox WMP plug-in but the result is the same.

mightyglydd

User avatar
 
Posts: 7519
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted October 1st, 2011, 6:49 pm

Hmm, FWIW, all the above links fire right up here, I'm seeing the same as MarkRH, not what you are . :-k
@We're all on the same OS.
Edit: Oops, the same results with 7.0.1.
# KeepFightingMichael

MarkRH

User avatar
 
Posts: 718
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 1st, 2011, 7:13 pm

I'm wondering if there's some other Windows Media Player plug-in installed somewhere that's gumming up the works. The only Windows Media Player plugin I have listed in about:plugins is:

Windows Media Player Plug-in Dynamic Link Library
File: C:\Program Files\Windows Media Player\npdsplay.dll
Version: 3.0.2.629

Hrmmm... odd.

mightyglydd

User avatar
 
Posts: 7519
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted October 1st, 2011, 7:40 pm

MarkRH wrote:I'm wondering if there's some other Windows Media Player plug-in installed somewhere that's gumming up the works. .

Maybe, I have the same Plugin as you.
# KeepFightingMichael

Xantho
 
Posts: 56
Joined: February 1st, 2006, 1:16 pm

Post Posted October 1st, 2011, 11:17 pm

I removed the 'WMP Firefox Plug-in' via Add/Remove Programs, and now instead of "Use Microsoft Windows Media Player Firefox plugin...", the "Use Windows Media Player Plug-in Dynamic Link Library..." option is showing up (same as in Mark's App window). The streaming player is still broken, though.
Maybe there is either something wrong with the DLL install, or something is interfering with it...? :(

Bob87564586
Guest
 

Post Posted October 2nd, 2011, 7:01 am

Desactivating the VLC plugin from firefox is a working solution for me; but I don't understand why.
But anyway: it works! :)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 25 guests