MozillaZine


favicons broken in Firefox 8

User Help for Mozilla Firefox
winedog
 
Posts: 50
Joined: January 17th, 2005, 2:27 pm

Post Posted November 9th, 2011, 2:43 am

Just updated to Firefox 8 and a heap of my favicons are broken both in the address bar and in my bookmarks toolbar. What I see now is just a square made up of a dotted line on favicons that were working just fine prior to upgrading to FF 8.

Anyone else have this and any suggestions for a fix? I rely pretty heavily on those favicons

guestar
Guest
 

Post Posted November 9th, 2011, 3:11 am

I also now have broken favicons after updating to FF8.

winedog
 
Posts: 50
Joined: January 17th, 2005, 2:27 pm

Post Posted November 9th, 2011, 3:20 am

I have tried the Places extension and run a full check....the favicons that are broken in the bookmarks and address bar are still broken. It didn't fix a single one.

Frank Lion

User avatar
 
Posts: 20972
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 9th, 2011, 3:52 am

winedog wrote:Anyone else have this and any suggestions for a fix?

You have a corrupted places.sqlite, which is where this stuff is stored.

Go into your profile - http://kb.mozillazine.org/Profile_folder_-_Firefox (use the Help Menu method) and then close Firefox. Rename the places.sqlite file in your profile to places1.sqlite and restart Firefox. Firefox will then use one of the backups from the BookmarkBackup folder from a day or so back.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Guest
Guest
 

Post Posted November 9th, 2011, 4:22 am

Hi Frank,
i tried it and now is every favicon broken...
I switch back to old places.sqlite and it is like before - 30% of them are broken 8-[

Greets, Olaf

Frank Lion

User avatar
 
Posts: 20972
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 9th, 2011, 4:31 am

Guest wrote:Hi Frank,
i tried it and now is every favicon broken...
I switch back to old places.sqlite and it is like before - 30% of them are broken 8-[

Greets, Olaf

Hi Olaf,

FWIW The favicons will come back when you revisit the sites.

Doing the above, uses the latest bookmark/history backup and preserves the usual places.sqlite, in case it doesn't work, so it's a good first move.

The only other thing to try is to import an even earlier backup using the Bookmarks Organiser. This normally overwrite places.sqlite, but if you rename it first then you'll still have it, if you need it.

If an earlier backup doesn't do it, then you're stuffed unless you have a pre-update profile backup floating about. - should not be necessary, but not a bad idea to backup your profile before updating.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted November 9th, 2011, 5:12 am

winedog wrote:Just updated to Firefox 8 and a heap of my favicons are broken both in the address bar and in my bookmarks toolbar. What I see now is just a square made up of a dotted line on favicons that were working just fine prior to upgrading to FF 8.

Anyone else have this and any suggestions for a fix? I rely pretty heavily on those favicons

The favicon was changed.

Bug 648668 - update blank document default favicon

Yes it is intentional and expected behavior. Only for my home page and or about:blank. Also for sites that do not have a favicon also.

You could use this style:
http://userstyles.org/styles/52581/fx-6-branding-logo-has-favicon-on-new-blank-tabs

Frank Lion

User avatar
 
Posts: 20972
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted November 9th, 2011, 5:37 am

rob64rock wrote:The favicon was changed.

Yes it is intentional and expected behavior.

How does stuff about the default blank favicon relate to website favicons, which is what the guy has lost here?
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Surprised
Guest
 

Post Posted November 9th, 2011, 5:49 am

I preferred the white document sheet of paper.
I don't like this new "default" one that looks like it is a BETA version...
:(

Surprised
Guest
 

Post Posted November 9th, 2011, 5:53 am

I forgot to say, the tabs animations don't work on Mac.
I have read that there should be "animations" or scrolling effects when you move tabs...

What's happening with Firefox 8.0?????

PimpUigi

User avatar
 
Posts: 234
Joined: February 1st, 2010, 12:03 pm

Post Posted November 9th, 2011, 6:17 am

Maybe they'll update it to a better icon later.
http://hardforum.com/showthread.php?t=1641786 - Try Firefox PimpUigi Edition

ReggieNJ
Guest
 

Post Posted November 9th, 2011, 7:14 am

That ugly weird looking box is the new default favicon, replacing the blank page.

The icon still exists though, you can you use this code to bring it back.

Code: Select all
#page-proxy-favicon:not(src),
#tabbrowser-tabs .tab-icon-image:not(src),
#personal-bookmarks .bookmark-item .toolbarbutton-icon:not(src) {
list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
-moz-image-region: rect(0px, 16px, 16px, 0px)!important;
}

Geese1
Guest
 

Post Posted November 9th, 2011, 7:29 am

Hope the developers come up with an update to fix this issue as it's pretty annoying to have all these blank favicon icons cluttering up your toolbar and favorites list.

Still, this seems like an apparent enough issue that it should have been caught in beta testing - it's not like it's something that's hidden away or only appears under specific circumstances. [-X

jenjis
Guest
 

Post Posted November 9th, 2011, 10:11 am

I see "dotted" icon in icons tabs too!
I tried ReggieNJ code (I put it in chrome.css, I presume), but nothing change.

This bug is inacceptable! I hope someone find a solution.

LIMPET235
Moderator

User avatar
 
Posts: 39442
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted November 9th, 2011, 10:21 am

FWIW...
I just tried v8 in "Safe Mode" which uses the default theme instead of the "Red Cats-Green Flavour" I run, to see what all the fuss is about.
I now see what y'awll mean.
Have you ever thought about using a theme?
All my favicons look great.

Just saying.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0-79.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 4 guests