MozillaZine


favicons broken in Firefox 8

User Help for Mozilla Firefox
Night Wing

User avatar
 
Posts: 179
Joined: August 20th, 2011, 5:18 am
Location: Texas

Post Posted November 13th, 2011, 6:49 am

Maybe I'm not getting this right, but in the screenshot shown by Jenjis on page 3, my favicons are still there in (v7.0.1) and (v8.0), but I did make one slight change and I'll explain. BTW, it doesn't involve modifying files or making a new profile.

Since my main Windows 7 computer's main "C" hard drive was failing and had to be replaced, my neighbor helped me back up all my files, bookmarks, etc; onto a flash (thumb, jump) drive. When my new hard drive was installed, we had to download FF (v7.0.1) again since v8.0 wasn't out yet. We then loaded my bookmarks back into FF (v7.0.1).

When I "single clicked" on my backed up bookmarks now installed into FF (v7.0.1), many of the favicons looked like the screenshot posted by Jenjis up above with no tabs open or with two or three tabs open.

But, my neighbor told me to "double click" each bookmark instead of single clicking on it and those favicons that didn't show up, now showed up. When I updated to (v8.0), the favicons are still there. The only favicons that didn't show up and never did in v7.0.1 was because some websites don't have a favicon.

Maybe this trick might work for others. Try it and see if it does.

jenjis
Guest
 

Post Posted November 13th, 2011, 10:44 am

Update my situation:
as my previous screenshot showed, I had two distinct problems.
The first was empty icons in bookmarks bar.
The second was empty icons in tabs.

For the first problem a paste this code in my userChrome.css and works:
Code: Select all
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Set a standard favicon to bookmarks without favicon */

#page-proxy-favicon:not(src),
#tabbrowser-tabs .tab-icon-image:not(src),
#personal-bookmarks .bookmark-item .toolbarbutton-icon:not(src),
.menuitem-with-favicon .menu-iconic-icon:not(src) {
   list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
   -moz-image-region: rect(0px, 16px, 16px, 0px)!important;
}
treechildren::-moz-tree-image(title) {
  list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
  -moz-image-region: rect(0px, 16px, 16px, 0px)!important;
  padding-right: 2px!important;
  margin: 0px 2px!important;
  width: 16px!important;
  height: 16px!important;
}
treechildren::-moz-tree-image(title, livemarkItem) {
  list-style-image: url("chrome://browser/skin/livemark-item.png")!important;
}
treechildren::-moz-tree-image(title, separator) {
  list-style-image: none!important;
  width: 0!important;
  height: 0!important;
}
treechildren::-moz-tree-image(title, container) {
  list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
  -moz-image-region: rect(0px, 32px, 16px, 16px)!important;
}
treechildren::-moz-tree-image(title, open) {
  -moz-image-region: rect(16px, 32px, 32px, 16px)!important;
}
treechildren::-moz-tree-image(title, container, livemark) {
  list-style-image: url("chrome://browser/skin/livemark-folder.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(container, OrganizerQuery_AllBookmarks) {
  list-style-image: url("chrome://browser/skin/places/allBookmarks.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksToolbar) {
  list-style-image: url("chrome://browser/skin/places/bookmarksToolbar.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(container, OrganizerQuery_BookmarksMenu) {
  list-style-image: url("chrome://browser/skin/places/bookmarksMenu.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(container, OrganizerQuery_UnfiledBookmarks) {
  list-style-image: url("chrome://browser/skin/places/unsortedBookmarks.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(title, query) {
  list-style-image: url("chrome://browser/skin/places/query.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(title, query, tagContainer), treechildren::-moz-tree-image(query, OrganizerQuery_Tags) {
  list-style-image: url("chrome://mozapps/skin/places/tagContainerIcon.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(query, OrganizerQuery_Downloads) {
  list-style-image: url("chrome://browser/skin/places/downloads.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(title, query, dayContainer) {
  list-style-image: url("chrome://browser/skin/places/calendar.png")!important;
  -moz-image-region: auto!important;
}
treechildren::-moz-tree-image(title, query, hostContainer) {
  list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
  -moz-image-region: rect(0px, 32px, 16px, 16px)!important;
}
treechildren::-moz-tree-image(title, query, hostContainer, open) {
  list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
  -moz-image-region: rect(16px, 32px, 32px, 16px)!important;
}
treechildren::-moz-tree-image(title, query, OrganizerQuery_History) {
  list-style-image: url("chrome://browser/skin/places/history.png")!important;
}
treechildren::-moz-tree-image(title, query, folder) {
  list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
  -moz-image-region: rect(0px, 32px, 16px, 16px)!important;
}
treechildren::-moz-tree-image(title, query, folder, open) {
  -moz-image-region: rect(16px, 32px, 32px, 16px)!important;
}


For the second problem, I found that the fault was due to Favicon Picker 2 addon. I uninstall it and now I have favicon tabs again.
I hope this help anyone. 8-)

Homer.D.Poe

User avatar
 
Posts: 12
Joined: November 13th, 2011, 1:17 pm

Post Posted November 13th, 2011, 5:05 pm

It's not a "theme" problem!
Nobody cares what the "default blank page icon" looks like!

The problem is NOT about blank pages but regular ones.
I go to the NY Times page, and they have a fancy blackletter T as their favicon
It does NOT appear on the tab.
If you use the older version, or Internet Explorer, the favicon appears on the tab.

Has nothing to do with the bookmark file, since this is a non-bookmark site reference. Just type in nytimes.com and see what you get.
This is what I got:
Image


Internet Explorer: Image
Last edited by Homer.D.Poe on November 13th, 2011, 5:21 pm, edited 1 time in total.

teodorgant
Guest
 

Post Posted November 13th, 2011, 5:09 pm

For the square and empty icons, there is a workaround in this comment to the bug. Comment number 17. It works. Restore the favicon as it was before. As it was in Firefox 7.

https://bugzilla.mozilla.org/show_bug.cgi?id=701287

Homer.D.Poe

User avatar
 
Posts: 12
Joined: November 13th, 2011, 1:17 pm

Post Posted November 13th, 2011, 5:13 pm

Nobody cares about what the blank icon looks like!

The bug is that the "blank page" icon is appearing for EVERY site, even those with favicons.
IE displays them, the old version displays them.

The bug is that the "blank page" icon is appearing for EVERY site, even those with favicons.

Has nothing to do with the bookmark file, since this is a non-bookmark site reference. Just type in nytimes.com and see what you get.
This is what I got:
Image
Internet Explorer: Image
Last edited by Homer.D.Poe on November 13th, 2011, 5:22 pm, edited 1 time in total.

Night Wing

User avatar
 
Posts: 179
Joined: August 20th, 2011, 5:18 am
Location: Texas

Post Posted November 13th, 2011, 5:16 pm

I typed in www.nytimes.com in my address bar and got the fancy black letter "T" favicon when FF 8.0 brought up the site. I then went back to my home page, opened up a new tab, typed in www.nytimes.com and the tab opened the site and also displayed the black letter "T" favicon again.

It's working for me so there must be a problem somewhere with FF 8.0 on your end.

Homer.D.Poe

User avatar
 
Posts: 12
Joined: November 13th, 2011, 1:17 pm

Post Posted November 13th, 2011, 5:24 pm

Yes, and I'm not alone, which is why there are multiple bug reports on this.

The last several versions have given headaches in many ways, not the least when useful add-ons are killed in the process.
I just have to swear off ever using new versions. I have turned off auto update.

Homer.D.Poe

User avatar
 
Posts: 12
Joined: November 13th, 2011, 1:17 pm

Post Posted November 13th, 2011, 5:35 pm

LoudNoise wrote:Are you using Favicon Picker 2 addon?


LoudNoise wrote:Are you using Favicon Picker 2 addon?


YES!
I turned it off and I'm back to normal.
THANK YOU for getting that the problem was that the new version was breaking an add-on.
I would never have remembered that, that's been working for years.

I just hope they get better at not breaking add-ons.
Surely someone in beta test has that add-on.

Night Wing

User avatar
 
Posts: 179
Joined: August 20th, 2011, 5:18 am
Location: Texas

Post Posted November 13th, 2011, 5:36 pm

Try this. Go to the NY Times site. Once there, left click on "Tools" in the menu bar. A box should pop up with some prompts and one should say "Page Info". Left click on that. When another box pops with some tabs, left click on the "Media" tab. Then scroll on down till you see the Icon notation (http://css.nyt.com/images/icons/nyt.ico) that should be displayed and at the bottom of the box the black fancy letter "T" should be displayed.

edit: Looks like I was too late. Glad the problem is solved.

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted November 19th, 2011, 5:14 pm

Last edited by rob64rock on November 20th, 2011, 1:51 pm, edited 3 times in total.

jinni
Guest
 

Post Posted November 19th, 2011, 7:44 pm

have those who are missing favicons in bookmark toolbar and tabs gone to about:config and checked if browser.chrome.favicons and browser.chrome.site_icons have the value set to "true"?

rob64rock

User avatar
 
Posts: 2122
Joined: November 11th, 2009, 6:16 am

Post Posted November 20th, 2011, 1:57 pm

jinni wrote:have those who are missing favicons in bookmark toolbar and tabs gone to about:config and checked if browser.chrome.favicons and browser.chrome.site_icons have the value set to "true"?

"true" it is...
That question was asked a couple post pages back and Mozilla is aware of this bug and will be pushing the update out to all users with in the next week.

Here are these for those of you interested...


Devrt
Guest
 

Post Posted November 20th, 2011, 5:55 pm

Even when visiting the page again the icon is still broken dotted line

patrickjdempsey

User avatar
 
Posts: 23734
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 20th, 2011, 7:48 pm

Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

mllrtyme
Guest
 

Post Posted December 4th, 2011, 8:55 am

There are two files that must be altered to get your favicons back:
1. user.js
2. prefs.js
Both are located in your profile folder under Roaming.
In both edit browser.chrome.favicons and turn false to true. If you don't edit both files at startup the file will be reverted back to false (killing your favicons).

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot], tuaris and 8 guests