MozillaZine

How to completely remove AVG Safe Search add-on?

User Help for Mozilla Firefox
Guest
Guest
 

Post Posted November 22nd, 2011, 3:52 pm

Hi,
Is there a way to completely remove (not just disable) the AVG Safe Search add-on? It prevents me from connecting to the internet!

I have Windows Vista, FF 6.0.1 with options marked as "warn me when sites try to install add-ons" and "ask me what to do when updates are found".
When I installed AVG free, I unticked the search bar because I didn't want to install it.
I'm not sure if the Safe Search add-on was installed then or if was "updated" afterwords, but within a day or two I kept getting messages saying "firefox is using too much memory. Close and restart". Then I could not connect to the internet anymore.

After several hours trying to figure out what the problem was, I found the add-on and disabled it. It didn't solve the problem.
Finally, I found a post suggesting un-ticking the boxes in link-scanner settings in AVG Tools / advanced options. It did the trick and all was well for a few days ...

... until this morning when I once again lost internet connection.
Checking the add-ons I saw that the AVG search was still disabled, but showed as recently updated. I certainly did not update it!!!
Took me a few more hours to finally find a post suggesting ticking LinkScanner in Ignore error status in AVG Tools / advanced options. I'm finally back online.

Now, I've always thought that AVG was a great anti-virus, but this add-on is a nightmare. And how can it install and update itself without my knowledge? The FF options I have marked should prevent from it?
It only gives the option to enable/disable it, so is there a way to remove this piece of @#!$%# ?

Thank you very much for any help.

JayhawksRock

User avatar
 
Posts: 9839
Joined: October 24th, 2010, 8:51 am

Post Posted November 22nd, 2011, 4:20 pm

You need to change settings in AVG. Try this > http://support.mozilla.com/en-US/kb/Con ... %20add-ons
Scroll down to AVG Safe Search
"Get your facts first, then you can distort them as you please." ~ Mark Twain

Guest
Guest
 

Post Posted November 22nd, 2011, 5:46 pm

Thank you very much for the quick reply.
This is what I did to get it to work. What I'm looking for now is a way to completely remove the add-on.

patrickjdempsey

User avatar
 
Posts: 23707
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted November 22nd, 2011, 5:57 pm

It's a component of AVG. Probably the only way to completely remove it is to completely remove AVG.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

makaiguy

User avatar
 
Posts: 15960
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted November 22nd, 2011, 6:02 pm

I use AVG also but haven't had these problems in a long, long time.

You might try uninstalling AVG, then reinstalling. On the reinstall, configure it not to install Safe search or Link Scanner.
Doug Wilson, "The Makai Guy"
Win10: FF 46.0, TB 45.0 ║ Android 5.0.2/6.0.1: FF 46.0, No Android TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

velascomike
 
Posts: 4
Joined: November 5th, 2009, 1:29 pm

Post Posted November 23rd, 2011, 1:19 pm

Here is a solution I found:

In the registry editor navigate to:
KEY_CURRENT_USER\Software\Mozilla\Firefox\Extensions

and delete the key:
{3f963a5b-e555-4543-90e2-c3908898db71}
C:\Program Files\AVG\AVG8\Firefox

Then delete the contents of the folder:
C:\Program Files\AVG\AVG8\Firefox

Worked for me

via (http://www.technipages.com/firefox-3-ca ... d-out.html)

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests