MozillaZine

Firefox Blank Page Google Search Results

User Help for Mozilla Firefox
jadi01
 
Posts: 4
Joined: January 11th, 2012, 6:18 am

Post Posted January 11th, 2012, 6:24 am

Have this issue on 2 PC's. One with XP pro, the other windows 7 x64.

When "Googleing" and clicking on a page, all is fine. Then clicking back to return to the search results, 8 out of 10 times will show a blank page. However the Google search URL is still present and a refresh can display the results again.

Does not happen on any other browser. Also happens on stable and Beta builds since version 7-8 upwards.

Have tired removing all possible add-ons, but issue still present.

Any others having this?

Dingler

User avatar
 
Posts: 1219
Joined: November 14th, 2011, 4:41 am

Post Posted January 11th, 2012, 7:00 am

I observed this behaviour too, and sometimes Google fails to display the result page after validating the search. But I think it's related to the new template/layout/whatever of Google implemented since 1-2 years.

jadi01
 
Posts: 4
Joined: January 11th, 2012, 6:18 am

Post Posted January 11th, 2012, 8:00 am

Thanks for confirming it's not just me!

I really couldn't find information on anyone having a similar issue. But it stands to reason that if I have this on 2 different PC's (at work and home) that Firefox suffers from this "glitch" so other users must be effected. I am the only "constant" between the 2 PC's and it could be that I have an add on that causes the issue. I have however removed all add ons and as mentioned the problem persists.

dfoulkes

User avatar
 
Posts: 18867
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted January 11th, 2012, 8:09 pm

I have however removed all add ons and as mentioned the problem persists.

Removing everything is kind of a over-kill to testing...

If you restart Firefox in safe-mode it disables all extensions during that mode... much easier do test that way...
This is only for Firefox safe-mode...Don't check off any of it's safe-mode boxes...
http://kb.mozillazine.org/Safe_Mode

In the event that one of your extensions (or you) modified some internal settings to cause this you could also create a test profile (make no changes) and test it...
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

The outcome of either of those test will/should point to some type of solution... or not...

When I've done search and I click on a link I have those links open in a new tab (focused) and/so when I close it goes back the the orig. search page... maybe that would be easier?
I use one of the options in Tab Mix Plus for that but other mods/extensions may also do the same thing.
https://addons.mozilla.org/en-US/firefox/addon/1122
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

jadi01
 
Posts: 4
Joined: January 11th, 2012, 6:18 am

Post Posted January 12th, 2012, 3:25 am

Thanks for that. I've created a new profile, backed up up and restored passwors, backed up and restored sessions and we'll see if that helps.

dfoulkes

User avatar
 
Posts: 18867
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted January 12th, 2012, 8:29 am

You're Welcome! :D
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

jadi01
 
Posts: 4
Joined: January 11th, 2012, 6:18 am

Post Posted January 18th, 2012, 9:11 am

Just thought I'd check back with the results so far. All good. Snappier and no more blank pages. However I am still pointing the finger at a certain add-on for causing this... PageRank 1.2 being my suspect!

Gary King
 
Posts: 970
Joined: September 5th, 2003, 9:27 pm

Post Posted September 17th, 2013, 5:34 pm

I'm having this problem too, but it only happens when I click on certain websites in Google's search results. http://answers.microsoft.com/ in particular, and http://productforums.google.com/ . The problem still occurs in safe mode and in a new profile. Simply using Firefox's back/forward buttons can cause this problem. Seems more like a Firefox problem than a Google problem?

9x9
 
Posts: 10
Joined: April 2nd, 2012, 11:22 am

Post Posted September 26th, 2013, 12:28 am

I have this same annoying problem. It also occurs in safe mode. Wikipedia is a site that triggers it often for me. I have noticed that this began when Google searches went from http to HTTPS. I can no longer do a Google search without it instantly being redirected to https. This problem only happens on Google, not any other search engine. On my main profile I am refusing all Google cookies and am not signed in to any Google products.

On another profile on this same computer I was always signed in to Google and I did not have the blank page problem, then it began there as well. I am using Kubuntu 12.04 (completely updated including KDE) and FF 24.

I read someplace that it might be a 302 & 304 redirect coming from Google but I could not confirm how that would then return a blank page. And I have read all kinds of crazy things like, clear your cache completely, delete all cookies, browsing history, etc. As well as going into about:config and changing all kinds of settings. None of the "answers" I have found on the net have had a valid solution so far. I'm hoping someone here might have an idea?

I realize the web is going through many changes right now with HTML5, IPV6, plugins being mothballed permenantly etc, could any of these things be effecting the big picture?

Any thoughts??? I have been relegated to middle clicking all Google search results to open in a new tab as the only work around, 'cause I'm so tired of having to reload the bloody page to get my search results back.

jscher2000

User avatar
 
Posts: 9605
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted October 2nd, 2013, 5:15 pm

There's an active "bug" on this in Bugzilla, and an active support thread on SuMo (not solved, but workarounds suggested). It seems to be related to a combination of high zoom levels, instant prediction results, the fast back-forward cache, and Firefox shaving milliseconds by not re-parsing.

* https://bugzilla.mozilla.org/show_bug.cgi?id=908446
* https://support.mozilla.org/en-US/questions/970863

Gary King
 
Posts: 970
Joined: September 5th, 2003, 9:27 pm

Post Posted October 2nd, 2013, 6:48 pm

Excellent, thanks for pointing out these bug reports.

Yes, perhaps the zoom level is the problem. I use the NoSquint extension to zoom all pages to 130%. However, I recall also testing the problem in a new profile, so no zoom there, and the problem still occurred. But anyway, any leads at all are welcome!

9x9
 
Posts: 10
Joined: April 2nd, 2012, 11:22 am

Post Posted October 3rd, 2013, 4:21 am

I can confirm that this works, https://bugzilla.mozilla.org/show_bug.cgi?id=908446 see the solution toward the end of the thread.

Gary King
 
Posts: 970
Joined: September 5th, 2003, 9:27 pm

Post Posted October 3rd, 2013, 8:51 am

It's just a temporary fix; it's definitely nice to know that we have narrowed down the problem, but I'll wait for an "official" fix, now that there's some activity on fixing the bug. I'm worried I'll forget to switch the setting back to default when it's fixed.

JeffLeites
 
Posts: 66
Joined: April 23rd, 2008, 7:49 pm

Post Posted October 18th, 2013, 4:38 pm

Here's the fix:

1. Go to FireFox's configuration editor by typing about:config where you'd type a URL address and press Enter.

2. Ignore the warning message, this is standard procedure.

3. Scroll down to Browser.sessionhistory.max total viewers.

It is probably set to -1.

Change it to 0 (not 1, not 2, but ZERO).

Problems solved!

You can read about what this entry is suppose to do herehttp://kb.mozillazine.org/Browser.s ... al_viewers but it's causing this annoying that problem.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot], KWierso, L.A.R. Grizzly and 17 guests