MozillaZine

Disable Font Smoothing

User Help for Mozilla Firefox
Katai
Guest
 

Post Posted February 15th, 2012, 12:44 am

It looks like Firefox 10 reintroduced font smoothing, and now my eyes are paying the price. Before the update, I disabled font smoothing by setting gfx.direct2d.disabled=false, but that doesn't seem to work anymore. A lot of fonts that look better aliased (Courier, for instance) are now blobby messes. Is there anything I can do about this?

dfoulkes

User avatar
 
Posts: 18204
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 15th, 2012, 10:58 am

I've got mine set to true in this Win7 sys. and have no problems with clear fonts. Have you set your ClearType settings in your Winy7?
http://www.microsoft.com/typography/cleartypeinfo.mspx
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Katai
Guest
 

Post Posted February 15th, 2012, 11:34 am

ClearType is already disabled in my windows settings.

dfoulkes

User avatar
 
Posts: 18204
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 15th, 2012, 11:43 am

Disabled?
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Katai
Guest
 

Post Posted February 15th, 2012, 2:19 pm

Yes, disabled. I want to disable font smoothing in Firefox.

In XP, Display Properties > Appearance > Effects > "Use the following method to smooth the edges of screen fonts:" Unchecked.

Katai
Guest
 

Post Posted February 15th, 2012, 2:44 pm

Let me see if I can illustrate this better.

This is what I WANT (as shown in Wordpad)
Image

This is what Firefox displays
Image

Dingler

User avatar
 
Posts: 1213
Joined: November 14th, 2011, 4:41 am

Post Posted February 15th, 2012, 5:32 pm

Try about:config > gfx.font_rendering.cleartype_params.rendering_mode = 2
(restart Firefox)

Katai
Guest
 

Post Posted February 15th, 2012, 8:06 pm

That did nothing :(

Fanolian
 
Posts: 583
Joined: February 21st, 2011, 10:14 am

Post Posted February 16th, 2012, 1:18 am

According to https://hg.mozilla.org/mozilla-central/ ... l.js#l1756 you can try setting gfx.font_rendering.cleartype_params.rendering_mode to 1.

Image
This is what I get when setting it to 1, with both Win7 cleartype and Firefox's hardware acceleration on.

Dingler

User avatar
 
Posts: 1213
Joined: November 14th, 2011, 4:41 am

Post Posted February 16th, 2012, 7:29 am

gfx.font_rendering.cleartype_params.rendering_mode = 1 (aliased), 2 (GDI Classic, as in XP)
So 1 appears to be the good value.

Katai
Guest
 

Post Posted February 16th, 2012, 11:44 am

No luck there either.

To summarize, I'm on Windows XP, Using Firefox 10, with Hardware Acceleration Disabled, gfx.font_rendering.cleartype_params.rendering_mode = 1, and gfx.direct2d.disabled=true

Katai
Guest
 

Post Posted February 16th, 2012, 11:48 am

I have a suspicion that Firefox is replacing all instances of "Courier" with "Courier New", and is probably doing the same with other fonts. Any ideas on what to do in this direction?

Katai
Guest
 

Post Posted February 16th, 2012, 3:14 pm

Okay, so Firefox is indeed replacing Courier with Courier New. I deleted the Courier New fonts from the C:\Windows\Fonts directory, and the font is working properly.

Now, is there a less drastic way of keeping Firefox from replacing Courier with Courier New?

dfoulkes

User avatar
 
Posts: 18204
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 16th, 2012, 5:02 pm

Have you by chance checked on Options/Content and reviewed what is set in there for fonts?... including the Advanced section?
Last edited by dfoulkes on February 17th, 2012, 8:52 am, edited 1 time in total.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Katai
Guest
 

Post Posted February 16th, 2012, 6:50 pm

Yes, those settings don't do anything

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 20 guests