MozillaZine

firefox 10.1 mouse cursor flickering/disappearing

User Help for Mozilla Firefox
smarty2600
Guest
 

Post Posted February 15th, 2012, 6:09 pm

Yesterday I first noticed that my mouse pointer/cursor was flickering so I rebooted my laptop, it had been a while since it's last reboot and had a lot of things open. I then opened everything back up and shut down my laptop for the night. Next day, I opened my laptop and noticed it was doing the same flicker thing. I realized it was only firefox and updated to 10.1, I had been running version 10. Same thing happened, my efforts have gone no where.

Basically what happens is if I leave my mouse alone or stop typing for just a second or two it suddenly disappears and then doesn't reappear until I move the mouse or type again. Although occasionally it will blink at first and then go away, which is why flickering probably best describes the problem. Also strange if I have another thing open, such as microsoft word or chrome, not full screen but I have control of them and not firefox, BUT firefox is in the background and my mouse hovers over firefox the disappearing mouse happens again even though I'm not controlling firefox the mouse somehow senses it is over firefox and disappears. I'm not quite sure if it is firefox or my windows 7 laptop's problem but help would be appreciated. Firefox is my favorite browser but if I can't fix this annoying problem, I'll have to use chrome or internet explorer, thanks for any advice!

BTW, I'm also pretty sure my blinking cursor is unrelated the f7 caret mode.

smarty2600
Guest
 

Post Posted February 15th, 2012, 6:55 pm

I would like to correct a small detail, I updated firefox to 10.0.1 not 10.1 as that does not exist. Sorry about that but anywhere it says 10.1, I mean 10.0.1.

dfoulkes

User avatar
 
Posts: 19094
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 15th, 2012, 7:07 pm

To rule out some things... have you tried this out with Firefox running in safe-mode?
Try running Firefox in safe-mode... do not check any boxes.
viewtopic.php?f=38&t=2393747
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

smarty2600
Guest
 

Post Posted February 15th, 2012, 7:33 pm

That did not fix anything. How do I get out of safe mode?

smarty2600
Guest
 

Post Posted February 15th, 2012, 7:36 pm

Also, I never added anything to firefox and don't have any themes. I stopped using add ons since the fast update schedule because they never were updated fast enough.

sarpo
Guest
 

Post Posted February 16th, 2012, 7:27 am

Some plugins, especially java, had been making the cursor disappear. That was fixed for most in 10.0.1, but since your problem remains, try both settings for
dom.ipc.plugins.enabled at URL about:config- default is true, try toggling it to the opposite of whatever yours is currently.

smarty2600
Guest
 

Post Posted February 16th, 2012, 8:07 am

Huh...what do I need to do to get these settings you are about? And I though safe mode disabled all the plug-ins anyways?

dfoulkes

User avatar
 
Posts: 19094
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 16th, 2012, 9:07 am

"Plugins" do not get disabled while Firefox is in safe-mode... "Extensions" do.

about:config entered into your Location bar (and hit enter) will open up a display of all internal settings... when the warning prompt appears just click on the "I'll be careful" area... and be careful with this...
Copy/paste dom.ipc.plugins.enabled into its search window and the setting for it should appear. True or False should display on the right side... place the mouse arrow over the lift side and right-click... a menu should appear... click on toggle. Then close that screen, restart Firefox and check for your problem. If the problem doesn't go away you can just reverse the above process.

That did not fix anything. How do I get out of safe mode?
By just restarting Firefox should take you out of safe-mode and here's what it does...
>What safe-mode does
* The status of plug-ins is not affected.
* Custom preferences are not affected.
* All extensions are disabled.
* The default theme is used, without a persona.
* userChrome.css and userContent.css are ignored.
* The default toolbar layout is used.
* The JIT Javascript compiler is disabled.
* Hardware acceleration is disabled.

I stopped using add ons since the fast update schedule because they never were updated fast enough.

I use over 45 extensions and all but one were updated at the time of the move to FF10.0 .. and the other one came alone a day later.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

smarty2600
Guest
 

Post Posted February 16th, 2012, 9:58 am

Well the problem seems to gone away, I was going to attempt to use follow the instructions but then noticed the mouse pointer was no longer blinking. The only thing I can think that solved the problem was I earlier closed a youtube tab that I no longer needed open. If that is the problem well just one more reason to hate flash. But the weird thing is I had the tab open for days just paused and it hadn't caused a problem. Either way, I'm glad the problem just went away. Thanks for the info on safe mode and about:config.

dfoulkes

User avatar
 
Posts: 19094
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 16th, 2012, 10:15 am

You're Welcome! :D

And... you're not the only one around here that hates Flash...
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

carebear_5
Guest
 

Post Posted February 24th, 2012, 7:21 pm

I had the exact same problem with it! I just force quit out of Firefox and restarted it and it seems to be working fine. I hope this doesn't become a common occurrence.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 31 guests