MozillaZine

Protocol (magnet) isn't associated with any program

User Help for Mozilla Firefox
rustydailey
Guest
 

Post Posted February 28th, 2012, 7:25 pm

I keep getting an error when I click links. The error says: Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program. I have looked at the applications tab and the program is associated but I still get the error. Anyone have an idea?

Thanks
Rusty

Guest
Guest
 

Post Posted February 28th, 2012, 7:46 pm

The magnet protocol is used for bittorrent links. You need to have a torrent client such as uTorrent installed and configured to handle magnet links.

WLS

User avatar
 
Posts: 2054
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted February 28th, 2012, 7:49 pm

You have a magnet protocol associated with what program?

I had to register the magnet protocol first. This may help.

http://kb.mozillazine.org/Register_protocol
AMD Athlon(tm) II X3 455 3.3GHz | 4.0GB RAM | GeForce GT 630
Kubuntu 14.10 | KDE 4.14.1

rustydailey
Guest
 

Post Posted February 29th, 2012, 6:36 pm

WLS wrote:You have a magnet protocol associated with what program?

I had to register the magnet protocol first. This may help.

http://kb.mozillazine.org/Register_protocol



I do have a torrent program installed. I tried to follow the link but just got confused.

jairusan
Guest
 

Post Posted April 5th, 2012, 5:45 am

I am using firefox 11.0 in Linux and after following the instructions in the mozillazine link, firefox still don't ask me what program to run #-o I am sure there is something missing here since when I try to open the magnet torrent links with google chrome it ask what application to use.

Help please... I will continue researching and if find the solution will paste it here.

Thank you,

WLS

User avatar
 
Posts: 2054
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted April 5th, 2012, 8:37 am

I just followed those instructions in Firefox Nighlty, and the magnet protocol is not showing up for me, under Content Type in Preferences -> Applications, so something must have changed.

It does appear in Firefox Beta, and I have it set to Always ask, but it doesn't work either.

Oh well, I just copy and paste them anyway.

EDIT:

Appears I had the value set wrong (didn't follow instructions). :-"

I changed it to true for some reason, once changed back to false, it now works in Nightly.
AMD Athlon(tm) II X3 455 3.3GHz | 4.0GB RAM | GeForce GT 630
Kubuntu 14.10 | KDE 4.14.1

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 17 guests