MozillaZine

plugin container crashes

User Help for Mozilla Firefox
sunnrider
Guest
 

Post Posted April 11th, 2012, 3:38 pm

On pages with flash videos FF has been crashing more and more often.
I get the "plugin container has stopped working for firefox" message, it´s the Adobe Flash plugin.

I´m running Win7 Ultimate, and Flash is up to date. There is no extra flash installations.

I tried disabling FF extensions but it makes no difference, still crashes on videos.
Please help, I really don´t want to switch to Chrome.

DanRaisch
Moderator

User avatar
 
Posts: 107273
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 11th, 2012, 4:01 pm

The Flash plugin and the plugin container are two different things.

Have you just disabled extensions or did you try Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode
Have you tried disabling hardware acceleration by right clicking on the Flash app and changing the settings in that environment?

sunnrider
Guest
 

Post Posted April 11th, 2012, 5:18 pm

I´ve disabled acceleration already.

It doesn´t seem to happen in safe mode but without addons I´d just rather not use FF.
My addons are up to date and theres only 10 of them. Only AdBlock runs the whole time.

makaiguy

User avatar
 
Posts: 15670
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted April 11th, 2012, 6:06 pm

sunnrider wrote:I´ve disabled acceleration already.


Just to be sure... have you disabled hardware acceleration in Flash, not just in Firefox, as Dan was suggesting?
Doug Wilson, "The Makai Guy"
Win7 Home Prem (64bit): FF 38.0.5, TB 38.0.1║ Android 4.2.2/4.4.2: FF 38.0.5, no Android TB available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

sunnrider
Guest
 

Post Posted April 12th, 2012, 2:02 am

I disabled acceleration by right-clicking a flash video and going into the settings.

sunnrider
Guest
 

Post Posted April 12th, 2012, 2:55 am

It just happened again so I copied the info in the popup:

Problem signature:
Problem Event Name: APPCRASH
Application Name: plugin-container.exe
Application Version: 11.0.0.4454
Application Timestamp: 4f5ecbd4
Fault Module Name: StackHash_2264
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: c0000005
Exception Offset: 011121ee
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: 2264
Additional Information 2: 2264db07e74365624c50317d7b856ae9
Additional Information 3: 875f
Additional Information 4: 875fa2ef9d2bdca96466e8af55d1ae6e

Frank Lion

User avatar
 
Posts: 17534
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist... United Kingdom

Post Posted April 12th, 2012, 3:00 am

sunnrider wrote:I´ve disabled acceleration already.

Just in Flash.

It doesn´t seem to happen in safe mode

Now in normal mode - Firefox menu > Tools > Options > Advanced > General > uncheck 'use hardware accel...' . Restart Firefox.
Metal Lion latest Firefox Themes -Tiger SP, Tiger, Graphite, Australis
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

sunnrider
 
Posts: 5
Joined: April 12th, 2012, 4:42 am

Post Posted April 12th, 2012, 4:44 am

Thanks for the help, but I actually already had that disabled too.

DanRaisch
Moderator

User avatar
 
Posts: 107273
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 12th, 2012, 8:08 am

You may be able to identify a specific extension that is causing the problem if the issue is not actually hardware acceleration. Try disabling all extensions but one and then close and restart the program. (Disable them by using menu path Tools->Addons->Extensions->click on "Disable" for every extension but one.) See if the problem is present. If not, enable an additional extension and close and restart the application. Repeat this procedure until the problem reappears. The last enabled extension will be the cause of the problem.

sunnrider
 
Posts: 5
Joined: April 12th, 2012, 4:42 am

Post Posted April 12th, 2012, 9:18 am

OK I´ll give it a shot and report back here.

sunnrider
 
Posts: 5
Joined: April 12th, 2012, 4:42 am

Post Posted April 12th, 2012, 4:00 pm

All adons disabled and it still happens.

patrickjdempsey

User avatar
 
Posts: 22705
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted April 12th, 2012, 4:49 pm

Just so we are all clear on what you have:

It works in Safe Mode.

But it crashes with:

hardware acceleration disabled in both Firefox and Flash,
and all extensions disabled,
and running the default theme?

And I'm going to assume you restarted Firefox after disabling hardware acceleration?
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

sunnrider
 
Posts: 5
Joined: April 12th, 2012, 4:42 am

Post Posted April 13th, 2012, 12:10 pm

patrickjdempsey wrote:Just so we are all clear on what you have:

It works in Safe Mode.

But it crashes with:

hardware acceleration disabled in both Firefox and Flash,
and all extensions disabled,
and running the default theme?

And I'm going to assume you restarted Firefox after disabling hardware acceleration?


Yes to all of the above.

Frank Lion

User avatar
 
Posts: 17534
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist... United Kingdom

Post Posted April 13th, 2012, 12:26 pm

sunnrider wrote:
patrickjdempsey wrote:Just so we are all clear on what you have:
It works in Safe Mode.
But it crashes with:
hardware acceleration disabled in both Firefox and Flash,
and all extensions disabled,
and running the default theme?
And I'm going to assume you restarted Firefox after disabling hardware acceleration?

Yes to all of the above.


Well, looks like your options are narrowing, doesn't it? Good luck with it all.


Safe Mode is a debugging startup mode available in Firefox, Thunderbird, and SeaMonkey 2, where all added extensions are disabled, the default theme is used, and default localstore settings (toolbar settings and controls) are used. Also disabled was the Just-in-time (JIT) JavaScript compiler (until Firefox 10, when JIT was disabled by default and then removed from Firefox 11 versions onwards), any changes made via userContent.css and userChrome.css and hardware acceleration. Any changes made to preference settings are unaffected and all available plugins are used in Safe Mode.


http://kb.mozillazine.org/Safe_mode
Metal Lion latest Firefox Themes -Tiger SP, Tiger, Graphite, Australis
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

sunnrider
 
Posts: 5
Joined: April 12th, 2012, 4:42 am

Post Posted April 15th, 2012, 3:51 pm

I give up. Much as I don´t want to I´m going to give chrome a shot.
Thanks for trying to help.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests