MozillaZine

Extensions don't show up

User Help for Mozilla Firefox
barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 27th, 2012, 4:02 pm

My extensions don't show up under Tools>Add ons anymore!
What could cause this?

JayhawksRock

User avatar
 
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted July 27th, 2012, 4:26 pm

barbas wrote:My extensions don't show up under Tools>Add ons anymore!
What could cause this?

Do you see anything when you open Tools>Addons ? You should have a list of at least 4 links along the left side. Click each one and see what shows then post back.
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 27th, 2012, 4:53 pm

Appearance and Plugins show when I click on them. Extensions doesn't show anything and Get Add ons just says 'loading' but nothing ever comes up.

KWierso
 
Posts: 8831
Joined: May 7th, 2006, 10:29 pm
Location: California

Post Posted July 27th, 2012, 8:31 pm

Does it work in safe mode?

barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 28th, 2012, 8:34 am

I don't know how to get in - or get out of - safe mode. :(

JayhawksRock

User avatar
 
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted July 28th, 2012, 9:07 am

barbas wrote:I don't know how to get in - or get out of - safe mode. :(

http://kb.mozillazine.org/Safe_mode
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

LIMPET235
Moderator

User avatar
 
Posts: 38763
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted July 28th, 2012, 9:07 am

Here's how...
> http://kb.mozillazine.org/Safe_Mode
or... Help > Re-start with Addons disabled.
Do not check any boxes.
This is a fault finding mode.

Don't add any extensions or themes until it's working O.K.
If Firefox is O.K. in Safe Mode then it's an extension/theme...etc causing it.
Run Firefox in normal mode & disable them all. Re-start Firefox.
Enable each in turn, or by ½'s, re-starting Firefox each time, till the faulty extension is found.
Either update or un-install it.
It's just a simple process of elimination.

See this incomplete list,
> http://kb.mozillazine.org/Problematic_extensions

When in Safe Mode...
* The status of plug-ins is not affected.
* Custom preferences are not affected.
* All extensions are disabled.
* The default theme is used, without a persona.
* userChrome.css and userContent.css are ignored.
* The default toolbar layout is used.
* The JIT Javascript compiler is disabled.
* Hardware acceleration is disabled.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
(Always choose the "Custom" Install.)

barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 28th, 2012, 11:25 am

When I do the Safe Mode no extensions show up - it says they're disabled - so how can I check them? When I go back to normal mode, they don't show so I can't disable anything. ??

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted July 28th, 2012, 1:57 pm

One of the files that stores details about your installed extensions could be corrupt. To fix the problem:

Open your Firefox profile folder. You can use this button to go to the Firefox profile folder:

Firefox > Help > Troubleshooting Information > Profile Directory: Show Folder

Next, close Firefox and then delete (or rename) any of these files you see listed:

extensions.cache
extensions.ini
extensions.rdf
extensions.sqlite
extensions.sqlite-journal

Reopen Firefox to see if that solves the problem.

Ref:
* https://support.mozilla.org/questions/931019
* http://kb.mozillazine.org/Uninstalling_add-ons#Corrupt_extension_files
Alice Wyman

barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 28th, 2012, 4:13 pm

Ok, I deleted extensions.cache
extensions.ini
extensions.rdf

Couldn't see any files called extensions.sqlite
extensions.sqlite-journal

It didn't change anything, my extensions still do not show.

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted July 28th, 2012, 4:34 pm

Your User Agent shows you are using Firefox 14.0.1. It's odd that you don't see an extensions.sqlite file since that file stores extensions information in Firefox 4.0 and above. The extensions.rdf file stores extension information in Firefox 3.6 and below.

Try again, but this time make sure Firefox is completely closed and also delete the "compatibility.ini" file.
Alice Wyman

barbas

User avatar
 
Posts: 87
Joined: June 28th, 2008, 6:00 am

Post Posted July 28th, 2012, 5:30 pm

I did as instructed -- found the extensions.sqlite file and the compatibility.ini file -- deleted both. Started FF and it asked to install all, which I did, and now all is fine. Extensions show now.

Thank you so much!! :D

Alice

User avatar
 
Posts: 2627
Joined: April 23rd, 2003, 11:47 am

Post Posted July 29th, 2012, 1:00 am

You're welcome! Glad it worked :-D
Alice Wyman

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests