Firefox times out

User Help for Mozilla Firefox
Posts: 3
Joined: April 16th, 2005, 10:31 am

Post Posted April 16th, 2005, 1:02 pm


whatever could not be found, please check the name and try again

and notice on loading firefox top right corner says timed out

Have the same prob if i try I.E. not resolved till a reboot.

I am using firefox 1.0.2


Post Posted April 16th, 2005, 1:04 pm

Checking DNS issues

The set of problems reported in this thread appears to overlap with the set of problems discussed in the following thread which by now has bulged to more than 600 posts:

The principal problem discussed in that thread is erratic behavior of Fx in connecting to a website, i.e. connecting to and loading websites very slowly, at times connecting slowly and then again connecting quickly, or failing to connect altogether. For example, people have been getting the following kinds of error messages:

"The connection timed out in trying to connect to <name_of_website> ...", or "looking up <name_of_website> .... [10-15 sec wait] .... <name_of_website> could not be found. Please check the name and try again".

In the great majority of cases the problem turns out to be due to either a software firewall that hasn't been properly configured to allow Fx access to the Internet, or to DNS lookup failure. Both are easy to fix. How to properly configure your firewall (in many cases ZoneAlarm is the culprit) has been described in quite a few posts in the quoted thread; see the first half dozen pages. Below I'll describe how to deal with DNS lookup failure.

First, to diagnose whether you're dealing with a DNS lookup problem, do the following:

In Fx's URL field, aka "location bar" (the space into which you type a hostname) type and hit <Enter>. If Fx can't load the Google homepage, then there is a problem. Now, clear the URL field, type and hit <Enter>. [You can also simply click on the highlighted URL's in this post.] If Fx can load the Google homepage now, then the problem is a failure of your ISP's DNS nameservers to resolve the hostname that you wish to access.

The DNS nameservers are like a telephone directory service; their purpose is to convert the easy to remember hostname "" to the IP address "" that is actually used by the servers and routers on the Internet. If the DNS nameserver is dead or unresponsive, "" will get you nowhere but "" will bypass the nameserver and get you to Google more directly.

A DNS lookup problem could be caused by actual failure or misconfiguration or overloading of your ISP's DNS nameserver. When such a failure is intermittent, overloading of the server is a likely cause. Many broadband providers have experienced such intermittent failures lately. Examples are OptimumOnline, Verizon, Comcast, RCN, Roadrunner.

How to fix it:

1. Call your ISP's tech support and ask them whether any of the DNS nameservers that your machine automatically connects to through DHCP are experiencing problems (overloading or failure because of Internet attacks) and if so what they are planning to do about it. Unfortunately, many people report that this may be a waste of time: your ISP may not acknowledge that a problem exists or their tech support may be ignorant and isn't able to help you. If you can't get satisfaction from them, forget about using their DNS nameservers and go to step 2.

2. Rather than using your ISP's DNS nameservers, use stable, reliable and non-congested alternative nameservers such as public nameservers or those of a major university nearby. A list of public nameservers can be found at , e.g. (PS0.NS1.VRX.NET) - Toronto, ON, Canada (PS0.NS3.VRX.NET) - Richmond Hill, ON, Canada (PS0.NS2.VRX.NET) - Apopka, Fl (NL.PUBLIC.BASESERVERS.NET) - Nederlands (NS1.QUASAR.NET) - Orlando, FL, USA (ZOLIBORZ.ELEKTRON.PL) - Poland (NS1.JERKY.NET) - Boston, MA, USA (PAN.BIJT.NET) - The Netherlands Detroit

Choose two or three addresses from this list that are closest to you. If you go this route, make sure the servers you chose are current, i.e. ping them or run nslookup on them, e.g. nslookup

3. Or, to find the IP addresses of the nameservers of a big university nearby, run the following command on the command line (in Windows go to Start > Run > enter "command", this opens a DOS window)

nslookup -type=NS <domainname_of_university>

To find out what to enter for <domainname_of_university> google for a big university nearby, go to their homepage and examine their web address. Generally, the last two address fields is what you want. Examples would be,,,

For MIT or Harvard you would type on the command line:

nslookup -type=NS
nslookup -type=NS

The "authoritative answers" to this command will give you the IP addresses of their nameservers. E.g. for MIT or Harvard: internet address = internet address = internet address = internet address = internet address = internet address = internet address =

4. Next, open the network configuration dialog in your operating system, go to the dialogs that assign DNS nameservers and enter two or three of the IP addresses chosen from the list of public nameservers or from the entries you obtained with the nslookup command.

For Windows XP, you would go to Control Panel > Network and Internet Connections > Network Connections > double-click on the icon of your currently used Internet connection > General | Properties > General | Internet Protocol > click on Internet Protocol > Properties | General > check the box "Use the following DNS server addresses" > enter the two or three nameserver addresses you chose above.

Make sure you force your machine to use the specified nameservers by unchecking any box saying "DNS automatically provided through DHCP" or checking any box saying "override DHCP DNS servers", or whichever way your OS may provide to give you this option.

5. An alternative solution (which is available for Windows but not for Linux or MacOS) may be to install the program TreeWalk DNS which can be downloaded from . I haven't investigated exactly what this program does. It may simply automate the change of the DNS configuration in Windows (you wouldn't have to go through the above steps manually), and it may enter their own DNS nameservers (or it may set up a nameserver on your own machine). A number of people have found this to be an easy fix to the DNS lookup problem but you don't know in what ways this program changes your network config, and this solution may work fine until 10,000 other people dissatisfied with their ISPs sign up for and crash their servers. You may be better off to custom pick a local university nameserver.

6. If changing the DNS nameservers fails to correct the problem, you may want to uninstall your current version of Fx (1.0 or 1.0.1) and go back to the last version of Fx that doesn't appear to have this problem, i.e. v. 1.0PR (for PreRelease), also called v.0.10, or an even earlier version. You can find them here: ... /releases/

E.g. v.1.0PR = v.0.10 is here: ... ases/0.10/
For Windows download Firefox_Setup_1.0PR.exe, for Linux firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz

General comments:

It looks as though recent versions of Fx are not well tuned when it comes to dealing with problems in DNS lookup. Perhaps Fx times out too quickly as it's trying to get through to the ISP's nameservers when the lines are congested. This problem may have been introduced, or aggravated, with the final release of v.1.0, and it's still there in v.1.0.1. It may be the result of a trade-off for increased browser security (IE: browse but die, Fx: live but don't browse). Other browsers, Mozilla included, seem to be better able to deal with congested or low grade DNS nameservers. Anyway, until this problem is fixed by the Fx developers, it can probably be patched either by using less compromised nameservers or by going back to older versions of Fx.

My own experience with Fx precisely parallels that of hundreds of other people who have been complaining in this thread about Fx not connecting to websites. I've been using Fx for ages, both under WinXP and Linux; I never had any major problems with DNS lookup. I installed Fx 1.0 a few weeks ago, and it ran fine at first. Then I experienced one episode of constant failure of Fx to load webpages which lasted about two days. I called my ISP (RCN); they claimed there were no problems with their lines or servers. Then Fx again worked fine for a while. Then one week ago, the same problem reappeared: "page not found", or "waiting to load page", then timeout, and instant loading of the page on the second or third try (Fx presumably managing to get the copy of the resolved name now cached on the server). While Fx flailed, all of my other browsers (Mozilla, Konqueror, Opera, Dillo) loaded the exact same pages instantly. Finally, Fx became virtually nonfunctional and wouldn't load any pages, and Opera was beginning to slow and eventually also fail, then Mozilla failed and eventually even the lightning-fast Dillo failed. I hypothesize that at this stage the RCN DNS nameserver had become totally gummed up. In fact, the Linux command "dig" told me that it couldn't locate a DNS nameserver.

At this point, I uninstalled Fx 1.0 and reinstalled it: no change. Uninstalled 1.0 and installed 1.0.1. The new version ran fine for the first 3 hr session but next morning it was totally gummed up. I went through practically all of the two dozen remedies proposed in the thread referred to above; none of them really worked. Uninstalled 1.0.1 and installed 0.93; it worked. Then installed 1.0PR: it also worked. Reinstalled 1.0.1 and used the MIT nameservers: this worked. Went back to the RCN nameservers which now worked. Presumably, the congestion had cleared, or RCN had fixed their servers.

I'm just waiting for the RCN servers to flail again, then do some net diagnostics and packet sniffing, as well as switching to the MIT nameservers. That should nail down my diagnosis. Next, I'd like to figure out how to tweak Fx 1.0.1 in its DNS lookup timings to make it more forgiving (as 1.0PR presumably is), or else entice the Fx team to fix this problem which can be extremely frustrating and appears to affect a lot of people, regardless of platform (Win, MacOS, Linux).

Supposed remedies that had no effect on my system:

with "about:config" disabling IPv6
uninstalling extensions
changing Java Script settings
clearing browser cache
with "about:config" change pipelining and/or http timeout settings
stopping or even uninstalling my firewall (Firestarter for Linux)
fiddling with the setup of my router
installing a virgin copy of 1.0 and creating a new profile (i.e. renamed my default folder, hence no user configs were carried over, no previous themes, extensions, bookmarks, caches, cookies, etc.)

..... etc. etc. etc.: no change

[Using Fx 1.0.1 under Linux (Xandros 2.0.1), with Netgear RP614 router, 3Com cable modem, 5 Mbps broadband connection, ISP is RCN]

Return to Firefox Support

Who is online

Users browsing this forum: DanRaisch, Google Adsense [Bot] and 6 guests