MozillaZine

Firefox audio issue

User Help for Mozilla Firefox
Maxor127
Guest
 

Post Posted September 11th, 2012, 5:30 pm

It seems like no one else is having this issue based on google searches. I have no clue what the problem is. Ever since Firefox 15 was installed, HTML5 audio is messed up. I checked audio from my offline website, and I also checked audio from w3schools.com and wikipedia, and they have the same problem.

I'm using a simple HTML5 audio code. Here is an example of what my code looks like:

Code: Select all
<audio autoplay="autoplay">
   <source src="../music.mp3" />
   <source src="../music.ogg" />
</audio>


It's hard to describe what the problem is. It sounds like the audio is playing too slow and kind of stutters and crackles. I've tested both .ogg and .wav. I've tried different things to get it working, including using an embed/object tag for audio instead of html5, and it may have worked with mp3, but had the same stuttering problem when I switched to .ogg. Audio works fine in IE9. I have no clue what the problem is.

erkla
Guest
 

Post Posted September 11th, 2012, 5:45 pm

In Firefox 14 or 15, SPDY is on by default and changes how networking works. It is meant to improve speed but it also may increase jitter, you could try turning it off:
network.http.spdy.enabled in about:config set to false

Before doing that, try Firefox safe mode (hold shift and do not check any boxes) to see if an extension is the cause.

Maxor127
Guest
 

Post Posted September 11th, 2012, 5:56 pm

erkla wrote:In Firefox 14 or 15, SPDY is on by default and changes how networking works. It is meant to improve speed but it also may increase jitter, you could try turning it off:
network.http.spdy.enabled in about:config set to false

Before doing that, try Firefox safe mode (hold shift and do not check any boxes) to see if an extension is the cause.

I turned it off, but it didn't fix the problem. I also tried toggling the spdy v2 and v3. I tried safe mode, and that didn't fix the problem either.

I tested my brother's computer, which is on the same network. Audio worked fine in the latest Firefox on his computer. If it matters, he has Windows 7 64-bit and I have Vista 32-bit.

I can't be 100% sure that the problem started with Firefox 15.

Maxor127
Guest
 

Post Posted September 11th, 2012, 7:36 pm

I also completely reset Firefox, and it didn't fix the problem. So I'm completely out of ideas besides completely reinstalling Firefox. I doubt it's a hardware or driver problem since everything else sounds fine.

JayhawksRock

User avatar
 
Posts: 10390
Joined: October 24th, 2010, 8:51 am

Post Posted September 11th, 2012, 8:02 pm

Did you try Mozilla Safe-Mode as suggested? Menu > Help > Restart with addons disabled (do not check any boxes) and then see what happens

dfoulkes wrote:Safe Mode - MozillaZine Knowledge Base

>What safe-mode does
* The status of plug-ins is not affected.
* Custom preferences are not affected.
* The Just-in-time (JIT) JavaScript compiler is disabled.
* All extensions are disabled.
* The default theme is used, without a persona.
* userChrome.css and userContent.css are ignored.
* The default toolbar layout is used.
* Hardware acceleration is disabled.
"Get your facts first, then you can distort them as you please."
~ Mark Twain

Maxor127
Guest
 

Post Posted September 11th, 2012, 8:25 pm

Yes, I tried Firefox Safe Mode. I tried completely resetting Firefox. I tried manually disabling extensions and add-ons. I tried messing with my system audio settings. I have Vista 32-bit with Soundblaster X-Fi Gamer card. I don't have any issues with anything else. Games sound fine. IE9 sounds fine. Flash games in Firefox sound fine. My brother's computer with Firefox 15.0.1 installed doesn't have the issues I have.

Maxor127
Guest
 

Post Posted September 11th, 2012, 9:19 pm

I rolled back to Firefox 14 and audio was working again in it. So I can confirm that the issue started once I upgraded to Firefox 15. I still have no clue what that issue could be, though.

GLCh
Guest
 

Post Posted September 12th, 2012, 2:55 pm

It seems that this problem affects only Vista users: https://bugzilla.mozilla.org/show_bug.cgi?id=788005#c6
After adding the "media.use_cubeb" ---> "false" preference, audio crackling should disappear (at least, it worked for me).

Maxor127
Guest
 

Post Posted September 12th, 2012, 3:49 pm

GLCh wrote:It seems that this problem affects only Vista users: https://bugzilla.mozilla.org/show_bug.cgi?id=788005#c6
After adding the "media.use_cubeb" ---> "false" preference, audio crackling should disappear (at least, it worked for me).

That worked for me too. What is cubeb?

patrickjdempsey

User avatar
 
Posts: 23733
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted September 12th, 2012, 4:45 pm

Just a guess.... bicubic interpolation? http://en.wikipedia.org/wiki/Bicubic_interpolation
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

Maxor127
Guest
 

Post Posted October 12th, 2012, 10:46 pm

This issue is still present in Firefox 16.0.1 if you don't have media.use_cubeb set to false.

patrickjdempsey

User avatar
 
Posts: 23733
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted October 13th, 2012, 1:13 am

You'll have to wait for something to happen in that bug I'm guessing.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

rj0
Guest
 

Post Posted October 15th, 2012, 12:24 pm

Still broken in 16.0.1. Requires manual addition of media.use_cubeb=false to fix.
Vista 64.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests