MozillaZine

No Audio in Firefox (Linux, HTML5)

User Help for Mozilla Firefox
jaxjax
Guest
 

Post Posted September 28th, 2012, 11:12 am

Good day,
I have a problem: Firefox doesn't play any audio. It used to when I had Pulseaudio but it hasn't been playing any audio since I removed it. I'm using the x86 build from the Arch Linux repository. How can I make sure Firefox is using ALSA and not the wrong audio driver (such as Pulse or JACK)? Can I change the driver manually? I've done my scouting in about:config but had no luck. Thanks.

Guest
Guest
 

Post Posted October 9th, 2012, 8:29 pm

jaxjax wrote:Good day,
I have a problem: Firefox doesn't play any audio. It used to when I had Pulseaudio but it hasn't been playing any audio since I removed it. I'm using the x86 build from the Arch Linux repository. How can I make sure Firefox is using ALSA and not the wrong audio driver (such as Pulse or JACK)? Can I change the driver manually? I've done my scouting in about:config but had no luck. Thanks.


I have a similar problem.
Me stupidly upgrading Debian here to Squeeze, blindly following their recommended directions to not use the Aptitude tool,(mistake for me), simply caused many desktop apps to get pulled in, including Pulseaudio.
When I noticed it, I removed it, and FireFox no longer played sound correctly.
However, the only sound app which broke was the audible alert from the NoScript extension.
All other sounds play ok.
This has affected all versions of FF and NoScript on this machine.
It was playing when Pulse was present, but I simply do not want Pulse or desktops installed.
HTML5 and Flash, Ogg, etc seem ok, just the alert from NoScript is gone.
All other independent media players work ok without Pulse also.
Can't wait for Wheezey to see what else breaks.LOL.
Any help or insight appreciated, Thanks.

Return to Firefox Support


Who is online

Users browsing this forum: Google Adsense [Bot] and 29 guests