MozillaZine

how to create a shortcut as firefox and not IE?

User Help for Mozilla Firefox
homeport
 
Posts: 25
Joined: November 10th, 2004, 2:02 pm

Post Posted April 26th, 2005, 2:20 pm

I use IE but primarily Firefox. Firefox is not my default homepage. Whenever I am in Firefox and "Create a Shortcut" to my Desktop, it creates an IE shortcut.

How can I get this to create a Firefox shortcut?

Thanks

mtz1of4
 
Posts: 3665
Joined: November 4th, 2004, 9:26 am
Location: Fairport, NY USA

Post Posted April 26th, 2005, 2:22 pm

Manually create a shortcut on the desktop and give it this

"C:\Program Files\Mozilla Firefox\firefox.exe" www.blahblah.com

You fill in the URL.

Problem is you are telling it to create a shortcut to a webpage but IE is the Default to open Web Page Links.

homeport
 
Posts: 25
Joined: November 10th, 2004, 2:02 pm

Post Posted April 26th, 2005, 2:30 pm

This procedure creates the Firefox for a specific URL. I would like to have all shortcuts created as Firefox (globally). The questions is how I can manually change the Default so that it opens, not in IE, but in Firefox?

Guest
Guest
 

Post Posted April 26th, 2005, 2:31 pm


Guest
Guest
 

Post Posted April 26th, 2005, 2:35 pm

If you don't want Firefox as your default browser, you need to manually change the association. Windows Explorer, go to Tools > Folder Options > File types, scroll down to "URL - Internet Shortcut", Click Advanced, select "Open", Click "Edit", click "Browse", navigate to firefox.exe, select and open. Click OK...

Guest
Guest
 

Post Posted April 26th, 2005, 2:35 pm

Thanks,

My Homepage "Location" is now set to my ISP which is Roadrunner. I was looking for a way to create the Firefox shortcut without having to reset my default browser as Firefox.

Guest
Guest
 

Post Posted April 26th, 2005, 4:42 pm

I did make the changes suggested for the Windows Explorer. However, there are 2 problems:
There are 2 "Internet Shortcut" designations. The first one has (NONE) in the Extensions column. The second has URL in the Extensions column. I changed the one with the "URL Internet Shortcut" as was recommended. This seemed to also change the first one as well. The application location was changed to "C:\Program Files\Mozilla Firefox\firefox.exe" %1. The "%1" got added automatically. However, nothing worked. When I created a shortcut, it still turned out to be an Internet Explorer shortcut.

The second problem was getting rid of the IE icon. It directed me to the System 32 icon files, but I could not find a Firefox icon either here or at any other location. However, this is a minor problem since I can use any other icon once I get the program to create a Firefox shortcut.

Any other suggestions as to what I may be doing wrong?
Thanks

Guest
Guest
 

Post Posted April 26th, 2005, 4:56 pm

Try importing the following into your registry:
Code: Select all
REGEDIT4

[HKEY_CLASSES_ROOT\InternetShortcut\shell\open\command]
@="C:\\Program Files\\Mozilla Firefox\\firefox.exe -url \"%1\""

[HKEY_CLASSES_ROOT\InternetShortcut\DefaultIcon]
@="C:\\Program Files\\Mozilla Firefox\\firefox.exe,0"


Just copy the above into notepad and save as "url.reg". Include the quotes around the filename when saving.
Double click the new .reg file to import it into your registry.

Guest
Guest
 

Post Posted April 26th, 2005, 7:06 pm

I entered the HKEY changes and did not see any change.
It may be that these were not entered exactly as you have shown. It is difficult to tell if any spaces should be left in the first line at "\"%1\"". Could you let me know. Also I assume the "@=" is not part of the inserted line and stands for the (Default) in the Key line in the registry. Is this correct?

Thanks

Guest
Guest
 

Post Posted April 26th, 2005, 7:28 pm

There is a space between -url and \"%1\"", however, you can't enter these values with the extra back slashes using regedit. If you are manually entering these with regedit, then:
Code: Select all
[HKEY_CLASSES_ROOT\InternetShortcut\shell\open\command]
(Default) --  C:\Program Files\Mozilla Firefox\firefox.exe -url "%1"

[HKEY_CLASSES_ROOT\InternetShortcut\DefaultIcon]
(Default) --  C:\Program Files\Mozilla Firefox\firefox.exe,0


It would be simpler to copy and paste the previous code into notepad and then merge the saved file into the registry.

@ is the default value. Also, try merging this as well:
Code: Select all
REGEDIT4

[HKEY_CLASSES_ROOT\.url]
@="InternetShortcut"


Manually with regedit:
Code: Select all
[HKEY_CLASSES_ROOT\.url]
(Default) -- InternetShortcut

nolan_vode
 
Posts: 173
Joined: November 16th, 2004, 2:11 am

Post Posted April 26th, 2005, 8:28 pm

Anonymous wrote:There is a space between -url and "%1"", however, you can't enter these values with the extra back slashes using regedit. If you are manually entering these with regedit, then:
Code: Select all
[HKEY_CLASSES_ROOT\InternetShortcut\shell\open\command]
(Default) --  C:\Program Files\Mozilla Firefox\firefox.exe -url "%1"

[HKEY_CLASSES_ROOT\InternetShortcut\DefaultIcon]
(Default) --  C:\Program Files\Mozilla Firefox\firefox.exe,0


It would be simpler to copy and paste the previous code into notepad and then merge the saved file into the registry.
If you are use the "merge" method:

1. After copying and pasting the code into notepad, remember to leave 2 spaces after the last line of the file (registry files won't merge without them)

2. When naming the file, it must be given a .reg file extension

Guest
Guest
 

Post Posted April 26th, 2005, 8:42 pm

nolan_vode wrote:1. After copying and pasting the code into notepad, remember to leave 2 spaces after the last line of the file (registry files won't merge without them)


Never heard of that requirement. I just tested a reg file without two empty lines at the end; it merged fine.

Does it matter which version of regedit is used? I'm using XP SP2.

GUEST :)
 
Posts: 2428
Joined: July 26th, 2004, 10:27 pm

Post Posted April 26th, 2005, 8:58 pm

Perhaps I am missing something here, but what exactly does your homepage setting have to do with your default browser? Firefox (and any other browser) will let you set whatever homepage you want. What the default browser setting or designation does is determine which browser will open links...

mtz1of4
 
Posts: 3665
Joined: November 4th, 2004, 9:26 am
Location: Fairport, NY USA

Post Posted April 26th, 2005, 9:33 pm

homeport wrote:This procedure creates the Firefox for a specific URL. I would like to have all shortcuts created as Firefox (globally). The questions is how I can manually change the Default so that it opens, not in IE, but in Firefox?



Sorry homeport, I didn't get that from your first post. As the first guest following me said,
http://kb.mozillazine.org/Setting_Your_Default_Browser

Set your Firefox to be the default browser and you can also apply your isp's home page in Firefox by going to Tools->Options-> and then General Tab on left and choosing your home page. You can have more then one by opening the correct number of tabs and then going to that tools option and choosing "Use Current Pages "

I would also install the ieview extension at https://addons.update.mozilla.org/exten ... on=firefox
which will allow you to open Right Click a page you may not be able to view that well in Firefox(Which I have only come across one so far) and tell it to Open the page in IE.

Guest
Guest
 

Post Posted April 30th, 2005, 1:49 am

I was called away for a few days, but finally got back to this.
First, I copied your files into Notebook and tried to merge this file into the registry as a "url.reg" file. I kept getting an error message that "I could only import binary registry files from within the registry editor".
I then cut and pasted your file lines directly into the registry. Again, after restarting the computer, it did not work. The only browser screen that would come up was IE. I checked to make sure that all of the changes that had been made as shown in this thread were still in effect.

Finally, the only thing I could do to make this work was to make the default browser Mozilla Firefox and only then could the Firefox page be created as a shortcut.

In summary, the url.reg did not work. Cut and pasting did not work. Changing the default browser did work. Can you think of any reason why changing the conditions in the registry and the windows explorer were not sufficient to cause the change to occur?

Thanks for all you help.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 27 guests