MozillaZine

Turn off Google Bar suggestions? How...

User Help for Mozilla Firefox
Gews
Guest
 

Post Posted October 9th, 2012, 5:18 pm

I've turned off the automatic suggestions in the URL bar, but I can't turn off the suggestions in the Google search bar (next to the URL bar).

I've unchecked "Show Suggestions" and gone to "Manage Search Engines" and tried to turn it off there. It's remembering things I've typed in previously. It is not showing Google's own suggestions.

For example if I type in "Julian Assa" it does not suggest "Julian Assange". If I type in "Dan" it automatically suggests "Dan Winkler Belt Knife" and "Horse Dance" among other things, since I have searched those in the bar before.

It's extremely irritating. I don't want to delete my history and cookies and that would only be a temporary fix.

This is a Firefox problem, since if I switch the bar to use Yahoo! or Bing it shows the same suggestions I have previously typed in...

malliz
Folder@Home

User avatar
 
Posts: 41734
Joined: December 7th, 2002, 4:34 am
Location: Aus

Post Posted October 9th, 2012, 5:23 pm

Right mouse click on the bar and untick "Show suggestions"
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

Gews
Guest
 

Post Posted October 9th, 2012, 5:55 pm

malliz wrote:Right mouse click on the bar and untick "Show suggestions"


I did that! As you can see, it is unticked... but suggestions still how up. It only appears to have stopped Google's suggestions, not my previous searches.

Image

dfoulkes

User avatar
 
Posts: 18156
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted October 9th, 2012, 9:28 pm

That show suggestions is not exactly the same as it show you stuff that you typed in before... I suppose that would be Search History.

Now, I see in Tools/Options and the Privacy Tab the line for Form and Search history and I also see in the Settings page if you have Clear History when Firefox closes.

But, unless there's a separate internal config setting to control just the Search History I would think that if you activated that clearing the Search and Form history at time of Firefox close that you would also lose form history... that is not good and I wonder why they would thing that those two things are equal.

Anyway, I do know that within the settings of this extension is the ability to clear out specific types of history such as the search history.... anyway, you might want to take a look at it..
Form History Control :: Add-ons for Firefox
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

MarkRH

User avatar
 
Posts: 701
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 10th, 2012, 8:16 am

I think the answer is right there in your screenshot. Click "Clear Search History" right above "Show Suggestions". After you click it, it will grey out due to no history to clear.

dfoulkes

User avatar
 
Posts: 18156
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted October 10th, 2012, 9:28 am

MarkRH wrote:I think the answer is right there in your screenshot. Click "Clear Search History" right above "Show Suggestions". After you click it, it will grey out due to no history to clear.

Hmmm... I don't have a Clear Search History where you see yours... I also checked my basic profile (nothing changed/installed) and it isn't there either... maybe you have a change in your config? .. or an extension?
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

MarkRH

User avatar
 
Posts: 701
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 10th, 2012, 9:57 am

dfoulkes wrote:
MarkRH wrote:I think the answer is right there in your screenshot. Click "Clear Search History" right above "Show Suggestions". After you click it, it will grey out due to no history to clear.

Hmmm... I don't have a Clear Search History where you see yours... I also checked my basic profile (nothing changed/installed) and it isn't there either... maybe you have a change in your config? .. or an extension?


I still see it when I right-click in the Search Bar when restarting FF with add-ons disabled (Help > Restart with add-ons Disabled). Maybe you've changed something so that it doesn't remember search history and so removes that menu item? The only Search Bar related add-on I have is Add to Search Bar: https://addons.mozilla.org/en-US/firefo ... earch-bar/

dfoulkes

User avatar
 
Posts: 18156
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted October 10th, 2012, 10:12 am

Oops... you're right... I thought that we were working "within" the Manage search engines area ... now I see it in the right-click area.

Thanks.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Return to Firefox Support


Who is online

Users browsing this forum: Gubbio and 15 guests