MozillaZine

FF v17.0 - now cleartype is on everything - can't disable?

User Help for Mozilla Firefox
converse
 
Posts: 2
Joined: November 21st, 2012, 4:29 am

Post Posted November 21st, 2012, 4:35 am

I've just updated to Firefox v17 (via the release update channel), and now all the interface and all webpages are being rendered with ClearType which I find bad to ready my high-res displays.

I've checked the About:Config cleartype sections:
gfx.font_rendering.cleartype.always_use_for_content is set to default as False
and I've set:
gfx.font_rendering.cleartype.use_for_downloadable_fonts to False as it was true, but even on restart, everything is in the soft cleartype.

Nothing else on my system in ClearType and it isn't enabled elsewhere.

Please can you tell me how to fix this, or confirm it's a bug awaiting to be fixed! Thanks, converse.

Windows 7 Pro 64-bit SP-1, Firefox v17.0

converse
 
Posts: 2
Joined: November 21st, 2012, 4:29 am

Post Posted November 21st, 2012, 4:53 am

I've just managed to fix it myself after going through a lot of settings in the About:Config, finally changing:

gfx.direct2d.disabled to True seems to sort it out.

Is there any reason why upgrading from v16 to v17 changed this default setting (I've never set it myself before)?

Puppy2012
 
Posts: 12
Joined: August 28th, 2012, 4:01 pm

Post Posted November 21st, 2012, 5:06 am

Same problem here :-/

But I found that some dialogs of Firefox does NOT use these ugly blurry fonts. For example the web site information "bubble", if you click the icon next to address in address bar. It is proof that Firefox *CAN* render readable non-blurry fonts even with HW acceleration *enabled*. Here is screenshot: http://members.upc.cz/petr/temp/firefoxblurry.png

Since I'm extremly sensitive on these ugly blurry font rendering I had to disable HW acceleration in Options but I don't think it is right solution. I hope it will be fixed soon.

Note that Thunderbird 17.0 on the same machine does NOT render these blurry fonts.

pickwick
New Member
 
Posts: 1
Joined: November 21st, 2012, 8:21 am

Post Posted November 21st, 2012, 8:28 am

Same here.

Automatic update was on, got automatically updated to the new version 17.0 and now all my fonts have that horrible Cleartype rendering. Indeed my old trick (mentioned in post 1) for disabling it, doesn't seem to work anymore.

So back to v16. That fixed my problem.

Browsing without Cleartype was the reason for me to switch to Firefox. IE9 hasn't got the option anymore to disable it.

ecarlson
 
Posts: 8
Joined: February 25th, 2003, 5:21 pm
Location: Sterling, VA

Post Posted November 21st, 2012, 8:52 am

Thanks. Setting gfx.direct2d.disabled to True also fixed the problem for me.

winedog
 
Posts: 36
Joined: January 17th, 2005, 2:27 pm

Post Posted November 22nd, 2012, 1:11 am

Yup, had this problem too after upgrading to FF 17.0

Terribad, it made FF unreadable. I can only imagine how many people this will cause problems for!

Bad move team mozilla [-X

Fortunately gfx.direct2d.disabled set to TRUE did resolve it for me as well.

XMan77
 
Posts: 31
Joined: May 18th, 2008, 8:19 am

Post Posted November 22nd, 2012, 1:10 pm

Better solution that worked for me:
To (possibly) resolve this without disabling hardware acceleration/Direct2D, try changing the setting "gfx.content.azure.enabled" to false in about:config and then restarting the browser.

winedog
 
Posts: 36
Joined: January 17th, 2005, 2:27 pm

Post Posted November 22nd, 2012, 3:37 pm

XMan77 wrote:Better solution that worked for me:
To (possibly) resolve this without disabling hardware acceleration/Direct2D, try changing the setting "gfx.content.azure.enabled" to false in about:config and then restarting the browser.


I tried this and it works, too....and I presume is a better choice.

dickvl

User avatar
 
Posts: 51411
Joined: July 18th, 2005, 3:25 am

Post Posted November 22nd, 2012, 6:37 pm

See also bug 814101 - Font Issue in FF 17

(please do not comment in bug reports)

StealthX
 
Posts: 619
Joined: November 15th, 2011, 4:50 pm

Post Posted November 22nd, 2012, 7:04 pm

XMan77 wrote:Better solution that worked for me:
To (possibly) resolve this without disabling hardware acceleration/Direct2D, try changing the setting "gfx.content.azure.enabled" to false in about:config and then restarting the browser.


This works better for me also because it doesn't make the Tab fonts look wrong in return for having the webpage fonts look normal! This makes all my fonts look as they are suppose to. Thank you very much. =D>

winedog
 
Posts: 36
Joined: January 17th, 2005, 2:27 pm

Post Posted November 22nd, 2012, 8:07 pm

dickvl wrote:See also bug 814101 - Font Issue in FF 17

(please do not comment in bug reports)


Nice work Moz Devs and =D> for jumping onto this one and treating it with priority

Puppy2012
 
Posts: 12
Joined: August 28th, 2012, 4:01 pm

Post Posted January 8th, 2013, 2:20 pm

Fixed in 18.0.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 17 guests