MozillaZine

Firefox 17.0.1 reports Java plugin as "outdated"

User Help for Mozilla Firefox
rameshiyer1
 
Posts: 1
Joined: August 3rd, 2011, 8:18 am

Post Posted December 13th, 2012, 10:38 pm

I regularly check for plugins to be up-to-date in Firefox. In my current version, i.e. 17.0.1, the plugin check reports that my Java Plugin (Java SE7 U9 10.9.2.5) is "outdated" and so is Java Deployment Kit 7.0.100.18. On clicking on "update' it takes me to the Free Java Download page and prompts me to download Java SE7 Update 9 which is already showing in my Windows 7 Control Panel. Moreover, when I run the manual update for Java (32-Bit) in Programs (Windows 7 Control Panel) it prompts me that a newer version Java SE7 Update 10 is available and I should download it.

I have removed all Java installations from my system and installed the version Java SE7 U9 as recommended by Firefox 17.0.1, yet it again reports on plugin check that Java SE7 U9 is "outdated" and so is JDK. Is this a bug in Firefox and should I await a fix from Mozilla / Oracle, or is there more to it ?

Have read a few posts and threads related to this issue and many other Firefox 17.0.1 users seem to face this issue too. Am not a IT expert, so would be grateful if someone can advise me on how to resolve this. Thanks.

dfoulkes

User avatar
 
Posts: 18198
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted December 14th, 2012, 8:47 am

I've tried using that Plugin checking but it's never given me good info... many posts around here say the same thing about it... I don't use it due to that reason....and, if I were you I'd forget using it also...

I do use this free program to check my system from time to time... seems to catch most of them... and, I don't like software auto-updating my system... that's why I use it....
http://secunia.com/vulnerability_scanning/personal/
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

the-edmeister

User avatar
 
Posts: 31013
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted December 14th, 2012, 12:44 pm

First off, unless you are a Java developer you don't need the JDK (Java Developers Kit) - the JRE = Java Runtime Environment is for normal users. The difference in the size of the download and installation size is huge.

Something is messed up to the Java U10 installation, it is apparently missing a registry entry which prevents Firefox from seeing that the U10 version is installed. What seems to work is to have both the U10 and the old U9 version installed; when the U10 Deployment Toolkit and the U9 Platform plugins are showing as enabled in the Firefox Plugins panel, the Plugin Check webpage report them both as being up-to-date.


.
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

Gopher John

User avatar
 
Posts: 1710
Joined: May 8th, 2008, 3:42 pm
Location: Northwest Ohio

Post Posted December 14th, 2012, 6:49 pm

I downloaded the off-line installers for JRE 7 U10 32-bit for my WinXP Pro SP3 desktop and Win7 Pro SP1 64-bit laptop. I also downloaded the off-line installer for JRE 7 U10 64-bit for the laptop, which Firefox (being 32 bit) won't use. I then uninstalled all versions of JRE, and installed the downloaded JRE 7 U10. The Java plug-in is installed and shows as updated at https://www.mozilla.org/en-US/plugincheck/.

Current wisdom seems to indicate that uninstalling isn't necessary for updating, but I'm a creature of habit and it worked for me.
The significant problems we face cannot be solved at the same level of thinking we were at when we created them. - Albert Einstein

James
Moderator

User avatar
 
Posts: 25425
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted December 14th, 2012, 8:22 pm

rameshiyer1 wrote:Is this a bug in Firefox and should I await a fix from Mozilla / Oracle, or is there more to it ? Have read a few posts and threads related to this issue and many other Firefox 17.0.1 users seem to face this issue too.

Firefox was released on November 30, while this Java update issue on Windows has only been in the last few days.
(*.mozillaZine.org is not Mozilla!)
The Complaint Department at Mozilla (current complaints) (<It is not a real complaint site but for jokes/testing of bugzilla).
The Complaint department link is borked until unknown time.

JayhawksRock

User avatar
 
Posts: 8574
Joined: October 24th, 2010, 8:51 am

Post Posted December 14th, 2012, 8:55 pm

Firefox looks in this Windows registry key to report the version of the plugin installed
HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\@java.com/JavaPlugin

That registry key is created and changed by the Java installer as versions are added or updated. Maybe the installer did not update the info or did not have permission to write to the registry. Check and see what that says.

FWIW.. all plugins from programs installed in Windows should register themselves in HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins\ in order to be detected by Firefox

A work around for your Java problem would be to put a copy of "npjp2.dll" from the Java program in windows into a folder named plugins created in the root of your profile.
"Computers make it easier to do a lot of things, but most of the things they make it easier to do don't need to be done."
~ Andy Rooney

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 19 guests