MozillaZine

QuickTime won't work on Firefox 18.0 (Mac)

User Help for Mozilla Firefox
clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 14th, 2013, 8:21 am

I have recently just upgraded to a Mac Book Pro running Mountain Lion. I cannot now see a video in my web browser which uses QuickTime.

The Plugin is in my Library/Internet Plug-Ins folder but when I use the utility in Firefox to find Plug-Ins its not listed.

Anyone know how I can resolve this apart from viewing it in Safari?

8-[

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 14th, 2013, 8:34 am

.
When you go to Preferences > Applications and scroll down to any QuickTime file type (e.g., QuickTime file (video/x-m4v) what is selected under "Action"? It should be Use QuickTime Plug-in 7.7.1 (in Firefox).

Also the plug-in should be here

/Library/Internet Plug-Ins/QuickTime Plugin.plugin


.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 14th, 2013, 8:49 am

Thanks Robert but the Plugin is in that folder. Thats the Library folder on my Hard Drive with other plug ins. Not the hidden Library folder(which is empty). Which library folder should it be in?
When I go to Preferences there are QuickTime files to select to check!

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 14th, 2013, 9:00 am

clairesp8 wrote:Thanks Robert but the Plugin is in that folder. Thats the Library folder on my Hard Drive with other plug ins. Not the hidden Library folder(which is empty).

That is correct.

clairesp8 wrote:When I go to Preferences there are QuickTime files to select to check!


Under "Action"? It should be Use QuickTime Plug-in 7.7.1 (in Firefox).

If this doesn't help can you post a link to a site where you are having the issue so I can check it?


.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 14th, 2013, 9:27 am

When I go to Action in Firefox there is nothing related to QuickTime there :(
I can view QuickTime movies that are on my desktop though.
My partner is running 10.6.8 and Firefox 18 and is not having a problem.
Here is the link to the site. I guess if I can't resolve it I will have to watch anything that will not play in Safari. But just wondered if this is a universal problem or just my machine?

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 14th, 2013, 9:31 am

clairesp8 wrote:Here is the link to the site.


No link.


.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 14th, 2013, 11:04 am

whoops, sorry! Trying to work and solve the mystery
http://www.isleofwightfilmfestival.co.uk/

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 14th, 2013, 11:20 am

.
OK, that video plays for me in FF18 and FF19b1; although the site takes a long time to load. Few things to try.

  1. Make sure that your QT plugin.plugin in the Library on your disk is QuickTime Plugin, 7.7.1 dated June 20, 2012 [use get info to find out]
  2. Try rebooting your computer
  3. See if in Preferences > Applications your QuickTime Player app(s) under Content Type show Use QuickTime Plug-in 7.7.1 (in Firefox)
Let me know; I have a few more ideas.


.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 14th, 2013, 1:35 pm

My plugin is dated 7 September 2012
Have tried re booting. No change
There is no QuickTime Player app(s) under Content Type in Preferences (in Firefox) In fact there are very few things listed in the Content Type pane. I could make a screen grab of the window but don't think I can attach it to this thread?

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 14th, 2013, 1:52 pm

Try this:

  1. Type about:config into the address bar.
  2. Find the preference browser.download.pluginOverrideTypes and, if it is present, right-click on it and select reset.
  3. Find the preference plugin.disable_full_page_plugin_for_types and, if it is present, right-click on it and select reset.
  4. Open the profile folder. You can open the profile folder from the Firefox menu, via "Help -> Troubleshooting Information". Click on the "Show in Finder" button next to Profile Folder Name in List
  5. Completely close your Mozilla browser after opening the profile folder.
  6. In your default folder delete (or rename) the file mimeTypes.rdf.
  7. Restart FF and see what happens.


.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

clairesp8
 
Posts: 6
Joined: January 14th, 2013, 7:24 am

Post Posted January 15th, 2013, 10:07 am

Mmmm I can't see anything called:
preference browser.download.pluginOverrideTypes
The only thing I can see like this is this:
plugin.override_internal_types

But that won't give me the option to reset when I right click!

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted January 15th, 2013, 10:21 am

.
OK. Time to try a new temporary profile. Quit FF and then go to

Applications -> Utilities

and launch Terminal.app

Then paste this in exactly without the quotes

"/Applications/Firefox.app/Contents/MacOS/firefox -P"

and hit return

You will see a screen that looks like this

Image

click on the "Create Profile" button and follow the instructions. Then see if in Preferences > Applications your QuickTime Player app(s) under Content Type show Use QuickTime Plug-in 7.7.1 (in Firefox)

To go back to your old or default profile simply quit and restart FF from the profile manager and select your default profile.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

nrw34260
 
Posts: 2
Joined: May 23rd, 2013, 2:22 am

Post Posted May 23rd, 2013, 2:35 am

Hi, I used this and it worked :D , the only trouble is that I have lost all my bookmarks. :cry: Is there any way of recovering the bookmarks to the new profile?

nrw34260
 
Posts: 2
Joined: May 23rd, 2013, 2:22 am

Post Posted May 23rd, 2013, 4:18 am

OK sorted -

Keep open the current version of FF

Then

Applications -> Utilities

and launch Terminal.app

Then paste this in exactly without the quotes

"/Applications/Firefox.app/Contents/MacOS/firefox -P"

and hit return

Select the old profile and Start FF

I then opened "Show all bookmarks" in the original version of FF and also opened "Show all bookmaks in the updated version - I then dragged the bookmarks across from the old to the new - Sorted!

RobertJ
Moderator

User avatar
 
Posts: 10858
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted May 23rd, 2013, 6:53 am

.
Glad you solved your problem. There is an easier way to move the bookmarks but the end result is the same. Have a good evening.

.
FF 79.0 - FF 80b5 - FF 81a - TB 68.10 - Mac OSX 10.13.6

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests