MozillaZine

Firefox 18 and Shockwave Flash

User Help for Mozilla Firefox
ineuw

User avatar
 
Posts: 211
Joined: March 19th, 2006, 4:17 pm

Post Posted January 15th, 2013, 8:17 pm

Using FF 18 with Windows 7 Pro SP1 and Shockwave Flash keeps crashing. Updated it to the version listed below and still crashes occasionally. Does anyone know of a solution to this problem? Thanks.

NPSWF32_11_5_502_146.dll
Version: 11.5.502.146
Shockwave Flash 11.5 r502

P.S: Please disregard the tech info in my signature. This is not the same desktop.
Windows 7, Xubuntu 14.04 with the latest FF & TB releases -ASUS P5B-E 2 core 32bit 2.4Ghz MB 2GB RAM, Nvidia GT 620 1GB video, LG V2500 22", 1536 x 864 @96dpi.

Ortho_Fan
 
Posts: 124
Joined: December 7th, 2012, 4:49 pm

Post Posted January 15th, 2013, 8:25 pm

You'll probably find this post sting of interest -- viewtopic.php?f=38&t=2570675

As noted, disabling Flash Player's protected mode by adding ProtectedMode=0 to the mms.cfg file is the only way I've found to prevent crashes, freezes and mystery dmp files from piling up.

Also see -- http://techdows.com/2012/06/disable-fla ... refox.html

Ortho_Fan

ineuw

User avatar
 
Posts: 211
Joined: March 19th, 2006, 4:17 pm

Post Posted January 16th, 2013, 9:41 am

Ortho_Fan thanks for the help. I added the ProtectedMode=0 to the mms.cfg file and rebooted. I will post here later if it works or not, because I am logged in to a web radio station all day and they use Flash where the problem occurs.
Windows 7, Xubuntu 14.04 with the latest FF & TB releases -ASUS P5B-E 2 core 32bit 2.4Ghz MB 2GB RAM, Nvidia GT 620 1GB video, LG V2500 22", 1536 x 864 @96dpi.

ineuw

User avatar
 
Posts: 211
Joined: March 19th, 2006, 4:17 pm

Post Posted January 16th, 2013, 2:05 pm

Unfortunately the solution didn't help. Flash faithfully crashes at regular intervals :(
Windows 7, Xubuntu 14.04 with the latest FF & TB releases -ASUS P5B-E 2 core 32bit 2.4Ghz MB 2GB RAM, Nvidia GT 620 1GB video, LG V2500 22", 1536 x 864 @96dpi.

alecarfi
 
Posts: 3
Joined: January 16th, 2013, 9:39 am

Post Posted January 16th, 2013, 3:34 pm

ok guys i'm not as tech savvy as you, but i have the same problem since installing the newer firefox 18 i also get shockwave flash crashing when i try to play music from online radio/soundcloud/etc.
what i get is actually the website telling me it can't play because the plug in appears to be disabled, but from the settings i know it's actually active.
maybe we should just re-install the older version of firefox (i never had this problem with it) and faithfully wait for a firefox 19 with these problems fixed?

alecarfi
 
Posts: 3
Joined: January 16th, 2013, 9:39 am

Post Posted January 16th, 2013, 3:35 pm

ok guys i'm not as tech savvy as you, but i have the same problem since installing the newer firefox 18 i also get shockwave flash crashing when i try to play music from online radio/soundcloud/etc.
what i get is actually the website telling me it can't play because the plug in appears to be disabled, but from the settings i know it's actually active.
maybe we should just re-install the older version of firefox (i never had this problem with it) and faithfully wait for a firefox 19 with these problems fixed?

Ortho_Fan
 
Posts: 124
Joined: December 7th, 2012, 4:49 pm

Post Posted January 16th, 2013, 6:08 pm

ineuw wrote:Unfortunately the solution didn't help. Flash faithfully crashes at regular intervals :(


Sorry to hear that. I know it cured the problems I was having, but in my case, FF didn't really crash--at least no warning message to that effect was displayed. It did, nonetheless, generate those annoying dmp files and from time to time, there was a crash report listed in about:crashes.

I'm wondering, specifically, what appears in YOUR crash folder. You can either type about:crashes in your address bar and hit the enter key to get to that page, or you can click Help, Troubleshooting Information, and on the following page, click about:crashes.

In the meantime, have you tried tweaking the "hardware acceleration" setting in Flash Player. You do this by quickly right clicking on a youtube video--before it crashes--and selecting "Settings." Then, if you see a check mark next to "Enable Hardware Acceleration," click on it to remove it. Conversely, if there isn't one there, try enabling it to see if that helps.

Along this line, you might try disabling hardware acceleration in Firefox, if it's enabled, by clicking on Tools, Options, Advanced, and clicking the box next to hardware acceleration, if it's checked, to clear it.

(None of this will probably do any good, but it's something to troubleshoot while waiting for more helpful response to come in.)

The next troubleshooting step after this is to try running Firefox in "Safe" mode, which is explained here -- http://support.mozilla.org/en-US/kb/tro ... -safe-mode

In that way you can find out if any add-ons are clashing with Flash Player.

BTW, I take it your graphics driver is up to date. (That seldom solves anyone's problem, but it's something Adobe always has people check when they have problems.)

Ortho_Fan
(Not a geek or techie by any stretch of the imagination. If it doesn't have a crank sticking out the side of it's cabinet, I probably will not be able to figure it out.)

mightyglydd

User avatar
 
Posts: 7612
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 16th, 2013, 6:20 pm

Ortho_Fan wrote:In the meantime, have you tried tweaking the "hardware acceleration" setting in Flash Player. You do this by quickly right clicking on a youtube video--before it crashes--and selecting "Settings." Then, if you see a check mark next to "Enable Hardware Acceleration," click on it to remove it. Conversely, if there isn't one there, try enabling it to see if that helps.

Along this line, you might try disabling hardware acceleration in Firefox, if it's enabled, by clicking on Tools, Options, Advanced, and clicking the box next to hardware acceleration, if it's checked, to clear it.


Yep, worth a try.
# KeepFightingMichael

ineuw

User avatar
 
Posts: 211
Joined: March 19th, 2006, 4:17 pm

Post Posted January 16th, 2013, 9:02 pm

I will respond to each as best I can since I am not much of a techie, just an experienced user, and if I forgot the ideas proposed here, it's only because things usually run problem free. I am not using any video, just listening to radiotuna.com which doesn't seem to have Shockwave Flash settings. I have two crash reports in about:crash.
The first three days ago: https://crash-stats.mozilla.com/report/ ... 3f32130112
and the second yesterday: https://crash-stats.mozilla.com/report/ ... a162130116

I hope this helps.
Windows 7, Xubuntu 14.04 with the latest FF & TB releases -ASUS P5B-E 2 core 32bit 2.4Ghz MB 2GB RAM, Nvidia GT 620 1GB video, LG V2500 22", 1536 x 864 @96dpi.

mightyglydd

User avatar
 
Posts: 7612
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 16th, 2013, 9:11 pm

ineuw wrote: I am not using any video, just listening to radiotuna.com which doesn't seem to have Shockwave Flash settings.
Fire up any Flash/YouTube video and right click on it, then Settings, Flash Hardware Acceleration option, check/uncheck will appear.
For disabling Fx HWA follow Ortho_Fan's advice.
you might try disabling hardware acceleration in Firefox, if it's enabled, by clicking on Tools, Options, Advanced, and clicking the box next to hardware acceleration, if it's checked, to clear it.

@ Disabling both takes a couple of minutes max...
# KeepFightingMichael

Ortho_Fan
 
Posts: 124
Joined: December 7th, 2012, 4:49 pm

Post Posted January 17th, 2013, 10:37 am

ineuw wrote:I will respond to each as best I can since I am not much of a techie, just an experienced user, and if I forgot the ideas proposed here, it's only because things usually run problem free. I am not using any video, just listening to radiotuna.com which doesn't seem to have Shockwave Flash settings. I have two crash reports in about:crash.
The first three days ago: https://crash-stats.mozilla.com/report/ ... 3f32130112
and the second yesterday: https://crash-stats.mozilla.com/report/ ... a162130116

I hope this helps.


The bad news is, the #$%$#$@ thing continues to crash. The Good news is that others have reported this problem and have filed bug reports, which you can see by scrolling down and checking "Related Bugs" in each of the crash reports.

Along this line, you might want to check if anything was picked up by Windows' crash reporter. Click on the "white flag" that appears in your task bar, or simply type Action Center in the search box of your start menu. Then click on the down arrow next to "Maintenance," and click on "view reliability history." That will show you a graph and list of any crashes that have appeared on a daily or weekly basis.

Ortho_Fan

ineuw

User avatar
 
Posts: 211
Joined: March 19th, 2006, 4:17 pm

Post Posted January 17th, 2013, 2:20 pm

Thanks all for contributing to this post. Windows crash reporter report nothing related to this, and the last report is from an unrelated issue occurring in the spring of 2012. It's only a matter of time before this will be corrected, or a workaround is issued and will post here if I discover something missed.
Windows 7, Xubuntu 14.04 with the latest FF & TB releases -ASUS P5B-E 2 core 32bit 2.4Ghz MB 2GB RAM, Nvidia GT 620 1GB video, LG V2500 22", 1536 x 864 @96dpi.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 20 guests