MozillaZine

Disable the nagging "activate plugins" popup

User Help for Mozilla Firefox
Reflective
 
Posts: 1370
Joined: February 15th, 2007, 11:13 am

Post Posted January 17th, 2013, 4:35 am

Since the advent of FF18, an annoying "Activate plugins" popup appears whenever I visit a site which includes Flash. I assume that happens because I have "click_to_play" set to "true" in about:config.

Does anybody know if there's some way of disabling that popup? I have "click_to_play" enabled for a reason and don't want to have to make a choice about whether I want to allow Flash to run every time I visit a site.

Anonymosity
 
Posts: 8162
Joined: May 7th, 2007, 12:07 pm

Post Posted January 17th, 2013, 1:27 pm

Is this a new behaviour? I do not remember that happening the first time I tried it. Of course, it was buggy the first time I tried it.

WLS

User avatar
 
Posts: 2228
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted January 17th, 2013, 1:33 pm

So enable "Always activate plugins for this site".

Directions can be found here.
Useless to you, is useful to someone else.
AMD Athlon(tm) II X3 455 3.3GHz | 4.0GB RAM | GeForce GT 630
Kubuntu 14.10 | KDE 4.14.1

Reflective
 
Posts: 1370
Joined: February 15th, 2007, 11:13 am

Post Posted January 18th, 2013, 12:50 am

Anonymosity wrote:Is this a new behaviour? I do not remember that happening the first time I tried it. Of course, it was buggy the first time I tried it.

Suggest you go to http://www.bbcnews.com

If you don't see the popup, it's because you have "click_to_play" set to "false" in about:config

There's a pix of it at the foot of this article: http://support.mozilla.org/en-US/kb/why ... te-plugins

WLS wrote:So enable "Always activate plugins for this site".

That's not want I want to do. What I want is a means of preventing the popup from appearing, something like a permanent "not now" option. That way, having "click_to_play" set to "true" prevents flash from running automatically. If I want to see the flash video which is associated with a particular article, I can activate it. Also, while reading an article, I don't want to be distracted by having a video running at the same time.

Actually, in the meantime, I've discovered a workaround which is simply to open another tab. When I click the tab which has the annoying popup, it will have gone. However, it's not ideal and I was hoping you guys would know of some way of disabling the popup altogether.

Gingerbread Man

User avatar
 
Posts: 7412
Joined: January 30th, 2007, 10:55 am

Post Posted January 18th, 2013, 3:26 am

Reflective wrote:If you don't see the popup, it's because you have "click_to_play" set to "false" in about:config

The preference name is plugins.click_to_play

This could be Bug 820678 - Only showing the CTP doorhanger popup if there is a vulnerable plugin on the page. The dependency tree for Click to Play is complex, and I don't have a good idea of developer intentions in regards to Click to Play behavior. One thing is for sure: if the developers thought Click to Play was ready for use, it would be exposed in the interface, either in the Add-ons Manager, Plugins section, or the Content section of the Options window.

That being said, a simple click anywhere on the page will dismiss it, and I don't see it showing up again (for that same site; I don't know any others that trigger it) unless I open a new window or restart Firefox.

It doesn't pop up by itself on pages like the following. However, on this page, the top banner also loads by itself without being manually activated. Flashblock doesn't fare any better.
http://www.adobe.com/software/flash/about/

Reflective
 
Posts: 1370
Joined: February 15th, 2007, 11:13 am

Post Posted January 19th, 2013, 3:37 am

Gingerbread Man wrote:The preference name is plugins.click_to_play

This could be Bug 820678 - Only showing the CTP doorhanger popup if there is a vulnerable plugin on the page. The dependency tree for Click to Play is complex, and I don't have a good idea of developer intentions in regards to Click to Play behavior. One thing is for sure: if the developers thought Click to Play was ready for use, it would be exposed in the interface, either in the Add-ons Manager, Plugins section, or the Content section of the Options window.

That being said, a simple click anywhere on the page will dismiss it, and I don't see it showing up again (for that same site; I don't know any others that trigger it) unless I open a new window or restart Firefox.

It doesn't pop up by itself on pages like the following. However, on this page, the top banner also loads by itself without being manually activated. Flashblock doesn't fare any better.
http://www.adobe.com/software/flash/about/

That bug you mentioned makes for an interesting read and I see that it's as yet unresolved.

Also, I didn't realize the doorhanger could be dismissed with a simple click anywhere on the page. Thanks for the tip.

Similarly, I wasn't aware that there could be invisible plugins on a page. The doorhanger doesn't provide any info with regard to that and merely demands to know whether the user wishes to enable plugins even though there doesn't appear to be any visible.

I guess we'll just have to wait and see what Mozilla comes up with.

jonnycat5000
 
Posts: 91
Joined: March 3rd, 2011, 9:58 am

Post Posted January 20th, 2013, 9:30 pm

You can also hit <ESC> (like we had to do in the pre-flash days when the annoyance was caused by animated .gif ads).

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Google Adsense [Bot] and 29 guests