MozillaZine

Asking about Java?

User Help for Mozilla Firefox
Hendikins

User avatar
 
Posts: 26
Joined: December 31st, 1969, 5:00 pm
Location: On a train

Post Posted September 24th, 2003, 1:21 pm

Welcome to the Mozilla Firefox Support forum. This sticky post is intended to help you with your Java questions before you ask them - saving you from searching/asking, and saving duplicate threads. It is, after all, a win-win situation.

Windows

On Windows, Mozilla Firefox can be used with Sun's Java Runtime Environment (JRE). It can not be used with the Microsoft Java VM, as that can only be used with Internet Explorer. Also, versions of Sun's JRE older than 1.3.0_01 will not work.

The quickest and easiest way to get Java installed is to install JRE 1.4.2_03 from within Mozilla Firefox, using XPInstall technology.

On some systems, JRE 1.4.2 does not work. If this happens, you can use JRE 1.4.1_07 until the issue you are having is resolved.

Linux

On Linux, Mozilla Firefox requires JRE 1.4.2 or later.

Mozilla Firefox is compiled with gcc 3.2.3, so a compatible version of the Java plugin must be used. JRE 1.4.2 contains a compatible plugin.

If you installed the JRE 1.4.2_03 RPM, this plugin is /usr/java/j2re1.4.2_03/plugin/i386/ns610-gcc32/libjavaplugin_oji.so - and to install it for Mozilla Firefox, do the following:

  • Open a terminal
  • Change to your Mozilla Firefox plugins directory
  • Issue the following command: ln -s /usr/java/j2re1.4.2_03/plugin/i386/ns610-gcc32/libjavaplugin_oji.so


If you are using an older Linux distribution, you may need to install the gcc3 support libraries, as the gcc 3.2 version of the Java plugin requires libgcc_s.so.1 to operate. You may be able to find packages using Google.

If you are using an unofficial build of Mozilla Firefox, or you compiled it yourself, you can check which compiler was used by entering about:buildconfig in the location bar and pressing enter. You will see a line such as "gcc version 3.3.1 (SuSE Linux)", which will show the compiler that was used. If gcc2.9x was used, you need to use the ns610 plugin, not the ns610-gcc32 plugin.

MacOS X

JRE 1.4.x will not work with Mozilla Firefox (Bug 197813). Applets will display using JRE 1.3.1.

Notes

You should not use Java with a spoofed useragent, as this may cause crashes (Bug 83376 - a JRE issue). You should also remove any Java plugin files from your Plugins directory when installing a new JRE release (if present).

This is not intended as an exhaustive set of instructions, but should cover most cases. If your question is not covered, feel free to post!
Last edited by Hendikins on February 10th, 2004, 2:26 am, edited 4 times in total.

old Neil Parks
Moderator
 
Posts: 0
Joined: December 31st, 1969, 5:00 pm

Post Posted November 13th, 2003, 11:56 am

After installing the Java Runtime, test it by visiting this page:

http://www.bodo.com/javame.htm

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 6 guests