MozillaZine


bookmark menu scroll wheel not responding

User Help for Mozilla Firefox
ropelife
 
Posts: 6
Joined: October 15th, 2011, 1:06 pm

Post Posted February 17th, 2013, 11:34 pm

I have a lot of bookmarks, so that when I open the bookmarks menu, it extends beyond the end of the page. The mouse scroll-wheel should move me up and down, but it doesn't (it doesn't do anything). Interestingly, if I go into a sub directory that also has enough bookmarks to extend beyond the end of the screen, the scroll wheel DOES work normally.

Does anyone know how to fix this problem so that my mouse scroll wheel will let me scroll through my bookmarks again? Thanks.

malliz
Folder@Home

User avatar
 
Posts: 44279
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted February 18th, 2013, 12:23 am

Does this happen in Firefox Safe mode?
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

ropelife
 
Posts: 6
Joined: October 15th, 2011, 1:06 pm

Post Posted February 18th, 2013, 12:50 am

No. In safe mode, the scrolling does work. I've tried disabling all of my plugins and extensions too, but that didn't solve it.

LIMPET235
Moderator

User avatar
 
Posts: 39602
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 18th, 2013, 2:02 am

When in Safe Mode...
* The status of plug-ins is not affected.
* Custom preferences are not affected.
* All extensions are disabled.
* The default theme is used, without a persona.
* userChrome.css and userContent.css are ignored.
* The JIT/javascript compiler is disabled.
* The default toolbar layout is used.
* Hardware acceleration is disabled.

To disable Hardware Acceleration in Firefox, go to,
Tools > Options > Advanced > General > Browsing..... & un-check the "Use hardware acceleration......." [] box.

& To disable hardware acceleration in Flash, > Right click in the Flash video screen & choose "Settings."
Un-check the box.
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0-79.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

Reflective

User avatar
 
Posts: 2283
Joined: February 15th, 2007, 11:13 am

Post Posted February 18th, 2013, 6:16 am

Open bookmarks in the sidebar using CTRL+B

If you know the name of the site you're looking for, or the subject, type it in the search field at the top. Otherwise, right click and then choose "Sort by name" which makes them easier to find.

There are also other Sort options available in the Library (CTRL+SHIFT+B). Click "Views", then "Sort" and choose any of the available options to sort by that criteria.

In addition, you can use Tab Groups which will display the sites you want to open when FF launches: http://support.mozilla.org/en-US/kb/tab ... anize-tabs

ropelife
 
Posts: 6
Joined: October 15th, 2011, 1:06 pm

Post Posted February 19th, 2013, 9:33 pm

Turning off hardware acceleration did not solve the problem. Keep in mind, that the mouse wheel scrolling DOES work, just so long as it's not in the initial menu. A folder within that menu that also extends past the end of the screen DOES scroll properly. It's all very strange...



I am aware that there are alternatives to the bookmarks menu, but I like the menu, and so would like to fix that if possible, rather than adopting an alternative.

dfoulkes

User avatar
 
Posts: 22575
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 20th, 2013, 9:09 am

* userChrome.css and userContent.css are ignored.

Check out those two files to see if you've made any entries into them that might be associated with scrolling... since safe-mode ignores those changes ... maybe code in there that's not working properly is doing it.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

dfoulkes

User avatar
 
Posts: 22575
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted February 20th, 2013, 9:20 am

Also... just a FYI ... I have this code in my userChrome.css file ... it produces a scroll-bar for anything that goes beyond my screen... including sub-folders... I like it a lot better than using the wheel.

Code: Select all
#appmenu_bookmarks arrowscrollbox > scrollbox,#bookmarksMenuPopup  arrowscrollbox > scrollbox {   overflow: auto !important;  }
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

ropelife
 
Posts: 6
Joined: October 15th, 2011, 1:06 pm

Post Posted April 1st, 2013, 2:00 am

Even with a scroll bar, the mouse wheel still doesn't move the initial menu.

dfoulkes

User avatar
 
Posts: 22575
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted April 1st, 2013, 8:50 am

ropelife wrote:No. In safe mode, the scrolling does work. I've tried disabling all of my plugins and extensions too, but that didn't solve it.

Did that also include disabling any non-default theme?

Also, it's probably not "plugins" because you said that all worked fine in safe-mode and that mode keeps plugins enabled.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Zoolcar9

User avatar
 
Posts: 2225
Joined: November 9th, 2004, 6:45 pm
Location: Jakarta, Indonesia (UTC+7)

Post Posted April 1st, 2013, 11:45 am

I had this problem before. The culprit was one of my userstyle that I used to
hide a menuitem in bookmarks menu (in my case, the "Open All in Tabs" menuitem).
If you have userstyle or userChrome.css with the following code, try to remove the line.

Code: Select all
menuitem[label="Open All in Tabs"]

or

Code: Select all
.openintabs-menuitem
My Firefox information | Add-ons | GitHub

"With great power, comes great desire to show it off."

Alice0775
 
Posts: 2788
Joined: October 26th, 2007, 11:25 pm

Post Posted April 1st, 2013, 3:05 pm

for hiding such menuitems, you should use "visibility:collapse" instead of "display:none"

Zoolcar9

User avatar
 
Posts: 2225
Joined: November 9th, 2004, 6:45 pm
Location: Jakarta, Indonesia (UTC+7)

Post Posted April 1st, 2013, 9:30 pm

 
Thank, Alice :)
Using visibility:collapse fixes it.
At least for me.
 
My Firefox information | Add-ons | GitHub

"With great power, comes great desire to show it off."

ropelife
 
Posts: 6
Joined: October 15th, 2011, 1:06 pm

Post Posted April 2nd, 2013, 2:49 pm

Yes, thank you! That solved it for me too.

I had the line:
#menu_unsortedBookmarks { display: none !important; }

But changing it to:
#menu_unsortedBookmarks { visibility:collapse; }

Solved the mouse wheel problem AND hid the "unsortedBookmarks" option.
Thank you.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], kreemoweet and 4 guests