MozillaZine

FF 19.0.2 opens last page instead of home page on startup

User Help for Mozilla Firefox
ccastr
 
Posts: 5
Joined: March 13th, 2013, 5:57 pm

Post Posted March 13th, 2013, 6:01 pm

I've been using FF 19.0.2 for a few days but this just started happening today. Whatever url I'm on when I close FF is the one that appears on startup even though I have options set to open home page (about:blank) on startup.

Does anyone know how to correct this (hopefully without losing my cookies and bookmarks)?

Thank you,
Carl

JayhawksRock

User avatar
 
Posts: 8656
Joined: October 24th, 2010, 8:51 am

Post Posted March 13th, 2013, 6:50 pm

Make sure that in Options > Start up you have blank page selected in the top "When Firefox Starts" dropdown

Alternative...Check this preference In about:config
browser.startup.page value should be integer 0 (zero)
http://kb.mozillazine.org/Browser.startup.page
"You Can't Always Get What You Want" ~ Mick Jagger - Keith Richards ~ Rolling Stones 1968

ccastr
 
Posts: 5
Joined: March 13th, 2013, 5:57 pm

Post Posted March 14th, 2013, 11:10 am

Yes on both recommendations.

I've tried: start up with blank page and I've tried start up with home page and have home page set to about:blank. Also startup.browser.page was set to zero.

It has just recently started showing the last page I had open when I start up. I think this started when I hit a webpage that confused FF and it shut down so I restarted it and everything seems ok except for this one glitch.

JayhawksRock

User avatar
 
Posts: 8656
Joined: October 24th, 2010, 8:51 am

Post Posted March 14th, 2013, 11:40 am

Well I'm out of ideas then. You are running Firefox 7 and current is 19
Your user agent at the bottom of the posts shows...
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/7.0.1

Lots of changes since then and I dont remember all of the differences. You could try a new Testing profile and see if the behavior changes. http://kb.mozillazine.org/Creating_a_ne ... on_Windows
So Good Luck
"You Can't Always Get What You Want" ~ Mick Jagger - Keith Richards ~ Rolling Stones 1968

ccastr
 
Posts: 5
Joined: March 13th, 2013, 5:57 pm

Post Posted March 14th, 2013, 2:38 pm

I'm running FF 19.0.2 (that's what shows in help -- about firefox) but the config value general.useragent.override was set to the string you saw (which contained 7.0.1). I've reset that string. I tried playing around with some of the other startup config parms but nothing seems to stop FF from opening the last page I was on at startup.

dickvl

User avatar
 
Posts: 51413
Joined: July 18th, 2005, 3:25 am

Post Posted March 15th, 2013, 5:32 pm

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.
http://kb.mozillazine.org/browser.sessi ... ssion_once
http://kb.mozillazine.org/Preferences_not_saved

Make sure that Firefox closes properly and that there isn't a hanging Firefox or plugin-container process left in the task manager.

Use "Firefox/File > Exit" to close Firefox if you are currently doing that by clicking the close X on the title bar.

http://kb.mozillazine.org/Firefox_hangs
http://kb.mozillazine.org/Firefox_crashes

ccastr
 
Posts: 5
Joined: March 13th, 2013, 5:57 pm

Post Posted March 15th, 2013, 10:26 pm

Thank you. Thank you.

browser.sessionstore.resume_session_once pref was set to true in my user.js file. I changed it in user.js to false and no longer does FF open my last page!!!

dickvl

User avatar
 
Posts: 51413
Joined: July 18th, 2005, 3:25 am

Post Posted March 18th, 2013, 1:26 am

It would be better to delete the user.js file or at least remove the line because this file shouldn't be there.
Setting the pref to false makes it impossible to restart Firefox after installing an extension.

http://kb.mozillazine.org/user.js_file

ccastr
 
Posts: 5
Joined: March 13th, 2013, 5:57 pm

Post Posted March 19th, 2013, 12:52 pm

Thanks again. Will do.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], therube and 27 guests