MozillaZine

Firefox 20.0.1 shows update message tabs every time it opens

User Help for Mozilla Firefox
paulfields
 
Posts: 8
Joined: November 9th, 2006, 10:11 pm

Post Posted April 23rd, 2013, 10:34 am

Hi there,

Since I upgraded to Firefox 20.0.1, every time I open the browser two things happen automatically:

1 - before the browser itself opens, a smaller window pops up and then and Firefox performs a "Add-ons compatibility check", thus unnecessarily wasting my time over and over;

2 - then, when the browser finally opens, two tabs always come up: the "Hooray! Your Firefox is up to date" and the "Tab Mix Plus - Version 0.4.1.0 Installed". Then I have to go and close those useless, unwanted tabs every single time.

So does anyone know how to get rid of those annoying things?

DanRaisch
Moderator

User avatar
 
Posts: 108329
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 23rd, 2013, 10:40 am

Browse to a page you want to use as your home page and close all tabs except the one displaying that site. Use menu path Tools->Options->General->Homepage->click on "Use current pages".
In that same dialogue box, select "Show my home page" from the dropdown for "When Firefox starts",

paulfields
 
Posts: 8
Joined: November 9th, 2006, 10:11 pm

Post Posted April 23rd, 2013, 11:30 am

Hey Dan,

Thanks for the reply.

Unfortunately, applying your proposed solution would work in one way, but that would create to me an even worse situation, as I would lose all my previously opened tabs. I always have many tabs open for things I'm continuously working on day-to-day.

Then, to avoid that, I would have to remember to "Bookmark all tabs" every single time before closing the browser, but sure enough -- since I'm human :>) --, sometimes I will forget to do that, or the browser will just crash, and when that happens I know that sometimes I will not remember all the tabs I had open.

Anyway, thanks. I hope Mozilla will fix those bugs in the next release.

Paul

LIMPET235
Moderator

User avatar
 
Posts: 34781
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted April 23rd, 2013, 11:33 am

You might like to try the Session Manager extension that works heaps better than the built-in manager.
> https://addons.mozilla.org/en-US/firefo ... n-manager/
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-30.0-36.0.1-38/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.5.0.
RadioYachting. Conficker Test.

DanRaisch
Moderator

User avatar
 
Posts: 108329
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the East Coast

Post Posted April 23rd, 2013, 12:16 pm

paulfields wrote:Unfortunately, applying your proposed solution would work in one way, but that would create to me an even worse situation, as I would lose all my previously opened tabs. I always have many tabs open for things I'm continuously working on day-to-day.


Ah, you're right about losing those open tabs. But then, you didn't mention that you had those open tabs in your first post. In this case, the same procedure would be applied, but instead of selecting "Show my home page" at start up, you would select "Show windows and tabs from last time."

But Limpet is correct in suggesting that the Session Manager extension is quite a bit better than the built in session management functionality.

paulfields
 
Posts: 8
Joined: November 9th, 2006, 10:11 pm

Post Posted April 23rd, 2013, 12:58 pm

Hey guys,

I installed the Session Manager add-on and changed the 'Startup' option in Firefox to "Show selected Session Manager session". I just guessed that was the thing to do, but I'm not really sure.

Then I checked my Tab Mix Plus add-on and saw that it had automatically disabled its own Session Manager and relinquished that job to the newly installed Session Manager add-on.

However, even after that, the 'Add-on Compatibility Check' still runs every time and the two unwanted tabs keep coming up along with the real tabs from the previous session.

If by any chance you still have any other trick up your sleeves, I'm willing to try them. Otherwise, no problem. I'm sure Mozilla will eventually catch that and fix it.

paulfields
 
Posts: 8
Joined: November 9th, 2006, 10:11 pm

Post Posted April 28th, 2013, 1:09 pm

Hi there,

I finally found the solution at the Mozilla Support site at:

https://support.mozilla.org/en-US/quest ... k&r=8&as=s

Basically, the solution is to delete the user.js file. In my case, what I did instead was transfer that file from its original place to another folder I created outside of Firefox to store the file. I don't know if I'll ever need that file again in the future, but just in case, I opted to do that.

Here is the way to do it:

Go to Firefox > Help and click on "Troubleshooting Information". That will open a new tab with that same name.

In that new tab, under the first topic (Application Basics), click on the 'Show Folder' button (at the right of 'Profile Folder'). Then a new Windows Explorer window should open up. Go the end of that window, find the "user.js" file and delete it (or save it anywhere outside of Firefox, if you want).

After that, restart Firefox and both problems -- the recurring Add-on Compatibility check and the tabs informing that such and such add-ons have been updated -- should disappear. In the unlikely event that it doesn't, try rebooting the computer.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 24 guests