MozillaZine

Vine videos do not play on Firefox.

User Help for Mozilla Firefox
StealthX
 
Posts: 623
Joined: November 15th, 2011, 4:50 pm

Post Posted August 6th, 2013, 5:52 pm

https://vine.co/v/bFQx23mmUBp and all other vine video links display as a still image. Even in safe mode.

The real eee
 
Posts: 32
Joined: July 21st, 2011, 8:11 am

Post Posted August 6th, 2013, 9:49 pm

same problem here, just adventure also :-(

http://img202.imageshack.us/img202/9375/xl0c.png

JayhawksRock

User avatar
 
Posts: 8915
Joined: October 24th, 2010, 8:51 am

Post Posted August 6th, 2013, 9:55 pm

@StealthX
Well according to the page info, there are NOT any videos on this page > https://vine.co/v/bFQx23mmUBp Only a flash animation.... unless of course I'm missing something....

@The real eee ... What is the URL of the site you are commenting on. Cant tell from the image you posted
"Computers make it easier to do a lot of things, but most of the things they make it easier to do don't need to be done." ~ Andy Rooney

The real eee
 
Posts: 32
Joined: July 21st, 2011, 8:11 am

Post Posted August 6th, 2013, 10:02 pm

sorry Jay, i put that to avoid commercial, on firefox 22 worked for sure

https://store.justadventure.com/The-Rav ... p_261.html

https://store.justadventure.com/Blackwe ... p_239.html

JayhawksRock

User avatar
 
Posts: 8915
Joined: October 24th, 2010, 8:51 am

Post Posted August 6th, 2013, 10:13 pm

The 4 Flash slide shows here > https://store.justadventure.com/The-Rav ... p_261.html all play for me. Each one has 4 frames that load from upper left across the slide show player when you click each box under the slide show player... There are no Videos on that page according to the page info... And of course the entire page runs with scripts.
Last edited by JayhawksRock on August 6th, 2013, 10:18 pm, edited 1 time in total.
"Computers make it easier to do a lot of things, but most of the things they make it easier to do don't need to be done." ~ Andy Rooney

The real eee
 
Posts: 32
Joined: July 21st, 2011, 8:11 am

Post Posted August 6th, 2013, 10:17 pm

yeah, are 4 slide that are 4 pictures , those work for me too, but are 5 slides and first slide is a video and that one dosent work/play, has only a picture with play simbol :D

http://img18.imageshack.us/img18/5369/5df6.png

Try with other browser and you will see the differences.

JayhawksRock

User avatar
 
Posts: 8915
Joined: October 24th, 2010, 8:51 am

Post Posted August 6th, 2013, 10:27 pm

This is the link to the vid from the page source http://www.youtube.com/embed/VWyVZiNnse ... owsearch=0

Can you play it... the page code points to youtube but the coding is dodgy...
"Computers make it easier to do a lot of things, but most of the things they make it easier to do don't need to be done." ~ Andy Rooney

The real eee
 
Posts: 32
Joined: July 21st, 2011, 8:11 am

Post Posted August 6th, 2013, 10:31 pm

how it was on ff 22 >>> http://img43.imageshack.us/img43/3742/dyah.png and video played directly

how it is on ff 23 >>>> http://img18.imageshack.us/img18/5369/5df6.png and video dosent play

StealthX
 
Posts: 623
Joined: November 15th, 2011, 4:50 pm

Post Posted August 6th, 2013, 10:32 pm

I don't know what vine plays as but they don't play for anyone I know who uses Firefox and they play fine in every other browser. Instagram videos work fine, youtube videos work fine. Btw The real eee your link works fine for me, it loads the youtube video after a quick flash of what you see for the entire time.

StealthX
 
Posts: 623
Joined: November 15th, 2011, 4:50 pm

Post Posted August 6th, 2013, 10:51 pm

Hopefully this is SFW I just searched Vine on twitter and since the video doesn't play for me I don't know what it is, but does this play for you https://vine.co/v/hb2jilbYaYH Jayhawk

MarkRH

User avatar
 
Posts: 742
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted August 6th, 2013, 11:00 pm

Hmmm you know. Vine videos were working for me (in FF22) and then recently they quit and just show a single image (while I was still on FF22). Hmm..

StealthX
 
Posts: 623
Joined: November 15th, 2011, 4:50 pm

Post Posted August 6th, 2013, 11:04 pm

MarkRH wrote:Hmmm you know. Vine videos were working for me (in FF22) and then recently they quit and just show a single image (while I was still on FF22). Hmm..

Same for me, they worked fine up until about a week or so ago (Maybe longer.), and they still don't work on FF23.

MarkRH

User avatar
 
Posts: 742
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted August 6th, 2013, 11:13 pm

Well, it looks like Firefox's HTML5 player is the reason (or part of it). If I set media.windows-media-foundation.enabled to false then they will play. Well, at least the one at https://vine.co/v/hb2jilbYaYH will play.

I found this thread: http://support.mozilla.org/en-US/questions/961627

Apparently they changed the codec or something with their videos and the HTML5 player can't decode it or figure out what to do. However, if I access the video directly: https://v.cdn.vine.co/r/videos/02C3A427 ... 9XpNJGcd5g

Then it will play in Firefox using it's built-in player (with the above setting at "true"). Hmmm..

patrickjdempsey

User avatar
 
Posts: 22763
Joined: October 23rd, 2008, 11:43 am
Location: Asheville NC

Post Posted August 6th, 2013, 11:49 pm

The justadventure site doesn't use Vine video... it's a video embedded using an iFrame, and from the looks of it, they've farmed out the embed code to either YouTube and/or Vimeo and one of those guys must have changed their code so it's no longer compatible. It's sloppy, fragile programming.
Tip of the day: If it has "toolbar" in the name, it's crap.
What my avatar is about: https://addons.mozilla.org/en-US/seamonkey/addon/sea-fox/

The real eee
 
Posts: 32
Joined: July 21st, 2011, 8:11 am

Post Posted August 7th, 2013, 12:10 am


Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 17 guests